summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-11-06 21:27:55 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-11-06 21:27:55 +0000
commit231ff96c12f0b9c503a1bfeac8c827188bce2642 (patch)
tree2e708973d2c5bb8ba21652981d251bd56248c9f3 /x11-drivers
parentMask glamor for xf86-video-ati too. (diff)
downloadgentoo-2-231ff96c12f0b9c503a1bfeac8c827188bce2642.tar.gz
gentoo-2-231ff96c12f0b9c503a1bfeac8c827188bce2642.tar.bz2
gentoo-2-231ff96c12f0b9c503a1bfeac8c827188bce2642.zip
Add USE flags for glamor and udev.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog6
-rw-r--r--x11-drivers/xf86-video-ati/metadata.xml3
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild17
3 files changed, 21 insertions, 5 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 671bb9d9149b..4b6811c3b511 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.178 2012/11/06 21:13:11 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.179 2012/11/06 21:27:55 chithanh Exp $
+
+ 06 Nov 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> metadata.xml,
+ xf86-video-ati-7.0.0.ebuild:
+ Add USE flags for glamor and udev.
*xf86-video-ati-7.0.0 (06 Nov 2012)
diff --git a/x11-drivers/xf86-video-ati/metadata.xml b/x11-drivers/xf86-video-ati/metadata.xml
index 01c4c004e735..b19c4dca8ea3 100644
--- a/x11-drivers/xf86-video-ati/metadata.xml
+++ b/x11-drivers/xf86-video-ati/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>x11</herd>
+<use>
+ <flag name="glamor">Enable Glamor OpenGL 2D acceleration</flag>
+</use>
</pkgmetadata>
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild
index d6fd74ca5df4..5cf30d396ff0 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild
@@ -1,17 +1,26 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild,v 1.1 2012/11/06 21:13:11 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-7.0.0.ebuild,v 1.2 2012/11/06 21:27:55 chithanh Exp $
EAPI=4
XORG_DRI=always
-XORG_EAUTORECONF=yes
inherit xorg-2
DESCRIPTION="ATI video driver"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="glamor udev"
-RDEPEND=">=x11-libs/libdrm-2.4.36[video_cards_radeon]"
+RDEPEND=">=x11-libs/libdrm-2.4.36[video_cards_radeon]
+ glamor? ( x11-libs/glamor )
+ udev? ( sys-fs/udev )"
DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}