summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-12-23 20:26:29 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-12-23 20:26:29 +0000
commit5f64089a232ca299770892e229d97848076196ff (patch)
treecd4a808125b749cf3fff888b5e467179089f6251 /x11-drivers/xf86-video-ati
parentBump for 7.0. (diff)
downloadgentoo-2-5f64089a232ca299770892e229d97848076196ff.tar.gz
gentoo-2-5f64089a232ca299770892e229d97848076196ff.tar.bz2
gentoo-2-5f64089a232ca299770892e229d97848076196ff.zip
Bump for 7.0.
(Portage version: 2.1_pre1)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.32
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.3.ebuild31
3 files changed, 40 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 6d5be012e87d..a5a7c801faf2 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.17 2005/12/18 00:07:05 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.18 2005/12/23 20:21:48 joshuabaergen Exp $
+
+*xf86-video-ati-6.5.7.3 (23 Dec 2005)
+
+ 23 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-ati-6.5.7.3.ebuild:
+ Bump for 7.0.
*xf86-video-ati-6.5.7.2 (18 Dec 2005)
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.3 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.3
new file mode 100644
index 000000000000..827af6deae9e
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.3
@@ -0,0 +1,2 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+MD5 a87420414681c53681a330b55ffb04ea xf86-video-ati-6.5.7.3.tar.bz2 700284
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.3.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.3.ebuild
new file mode 100644
index 000000000000..1bfe866bc505
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.3.ebuild,v 1.1 2005/12/23 20:21:48 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}