summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-14 17:30:44 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-14 17:30:44 +0000
commit005fa6712f9770d25b28213d5e7563ee1708370c (patch)
tree50592dbf95c1c9d526217d61d42c5df000cb3a95 /x11-drivers/xf86-video-ati
parentAdd mask for X.Org 7.1 RC. (diff)
downloadgentoo-2-005fa6712f9770d25b28213d5e7563ee1708370c.tar.gz
gentoo-2-005fa6712f9770d25b28213d5e7563ee1708370c.tar.bz2
gentoo-2-005fa6712f9770d25b28213d5e7563ee1708370c.zip
Bump drivers for 7.1RC1.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.06
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.6.0.ebuild31
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index b0935c3141da..8b87c78df7a2 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.22 2006/03/21 22:53:10 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.23 2006/04/14 17:30:42 joshuabaergen Exp $
+
+*xf86-video-ati-6.6.0 (14 Apr 2006)
+
+ 14 Apr 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-ati-6.6.0.ebuild:
+ Bump for 7.1 RC1.
21 Mar 2006; Luca Barbato <lu_zero@gentoo.org>
+files/xf86-video-ati-6.5.7.3-hangup-ppc.patch,
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.0 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.0
new file mode 100644
index 000000000000..328add6d864b
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.0
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 fbf04977d41239d55387122a4de6bd16 xf86-video-ati-6.6.0.tar.bz2 723687
+RMD160 ac58673f76c6693f35cb515731c2d7250b8c88b8 xf86-video-ati-6.6.0.tar.bz2 723687
+SHA256 23027b52d5b82c47201ac7471c545162149a6c6d38ec9c090469f6698e83eb21 xf86-video-ati-6.6.0.tar.bz2 723687
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.0.ebuild
new file mode 100644
index 000000000000..18f9e8ff6814
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.0.ebuild,v 1.1 2006/04/14 17:30:42 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}