summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-09-24 00:01:11 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-09-24 00:01:11 +0000
commit04ee5423b8c120c80ebf10bdca8d7ff0a1a142c9 (patch)
tree33e329cbcbcc5e5b541c49e656472b7dfaf9f242 /x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-04ee5423b8c120c80ebf10bdca8d7ff0a1a142c9.tar.gz
gentoo-2-04ee5423b8c120c80ebf10bdca8d7ff0a1a142c9.tar.bz2
gentoo-2-04ee5423b8c120c80ebf10bdca8d7ff0a1a142c9.zip
Bump. Should fix dead mice after resume from suspend.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild
new file mode 100644
index 000000000000..03f17470319f
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.5.ebuild,v 1.1 2008/09/24 00:01:11 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}