summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-01-03 06:56:25 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-01-03 06:56:25 +0000
commitcbb6e16657c7853eb56f901b03c5c3582a85c04a (patch)
tree0a303f97778b3e8c5f344182c19d66214f54b57c /x11-base
parentarm love (diff)
downloadgentoo-2-cbb6e16657c7853eb56f901b03c5c3582a85c04a.tar.gz
gentoo-2-cbb6e16657c7853eb56f901b03c5c3582a85c04a.tar.bz2
gentoo-2-cbb6e16657c7853eb56f901b03c5c3582a85c04a.zip
Fix the libglx* relocation routine to look in the right place so that xorg-x11
will play nice with eselect. Bug #117100. (Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog11
-rw-r--r--x11-base/xorg-server/Manifest14
-rw-r--r--x11-base/xorg-server/files/digest-xorg-server-1.0.1-r12
-rw-r--r--x11-base/xorg-server/xorg-server-1.0.1-r1.ebuild157
4 files changed, 171 insertions, 13 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index bae6932bcd95..bf19a83a3756 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/xorg-server
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.77 2005/12/26 13:41:39 stefaan Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.78 2006/01/03 06:56:24 joshuabaergen Exp $
+
+*xorg-server-1.0.1-r1 (03 Jan 2006)
+
+ 03 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xorg-server-1.0.1-r1.ebuild:
+ Fix the libglx* relocation routine to look in the right place so that xorg-x11
+ will play nice with eselect. Bug #117100.
26 Dec 2005; Stefaan De Roeck <stefaan@gentoo.org>
xorg-server-1.0.1.ebuild:
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 251decc3dadc..f5e57aceea73 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 960ed23ccdb6459665fba2eb2765430c ChangeLog 15448
+MD5 98842324ba3e208d05259404cef65367 ChangeLog 15700
MD5 3d490e022ae44d377a50153b649185d5 files/digest-xorg-server-1.0.1 138
+MD5 3d490e022ae44d377a50153b649185d5 files/digest-xorg-server-1.0.1-r1 138
MD5 912a66d58d73ad9c95c1c7d40c71f679 files/xorg-server-1.0.1-Sbus.patch 2388
MD5 a37bab73e2f24b213932c30997d3d360 metadata.xml 156
+MD5 b2033080680439ac006d758810bf176b xorg-server-1.0.1-r1.ebuild 4085
MD5 b6876de82033b5d1ca29f1a6b9987fb0 xorg-server-1.0.1.ebuild 4074
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDuLSP2+ySkm8kpY0RAvtqAJ97Di6HBIDUHy2SZ8IKA1HWeozMfwCgnHtK
-Fatr4BLeFpSfGKXTpoLxPt4=
-=KPs9
------END PGP SIGNATURE-----
diff --git a/x11-base/xorg-server/files/digest-xorg-server-1.0.1-r1 b/x11-base/xorg-server/files/digest-xorg-server-1.0.1-r1
new file mode 100644
index 000000000000..03b15b3b3286
--- /dev/null
+++ b/x11-base/xorg-server/files/digest-xorg-server-1.0.1-r1
@@ -0,0 +1,2 @@
+MD5 ea148c828ec6f645526451db1b8556f1 MesaLib-6.4.1.tar.bz2 2913887
+MD5 aa0ccb851ec5f7f9b132581d9a5827e4 xorg-server-1.0.1.tar.bz2 5975199
diff --git a/x11-base/xorg-server/xorg-server-1.0.1-r1.ebuild b/x11-base/xorg-server/xorg-server-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..cf3d163cc97e
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-1.0.1-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.0.1-r1.ebuild,v 1.1 2006/01/03 06:56:25 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# Hack to make sure autoreconf gets run
+#SNAPSHOT="yes"
+
+inherit flag-o-matic x-modular multilib
+
+OPENGL_DIR="xorg-x11"
+
+MESA_PN="Mesa"
+MESA_PV="6.4.1"
+MESA_P="${MESA_PN}-${MESA_PV}"
+MESA_SRC_P="${MESA_PN}Lib-${MESA_PV}"
+
+PATCHES="${FILESDIR}/${P}-Sbus.patch"
+
+SRC_URI="${SRC_URI}
+ mirror://sourceforge/mesa3d/${MESA_SRC_P}.tar.bz2"
+DESCRIPTION="X.Org X servers"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~sh ~sparc ~x86"
+IUSE="dri ipv6 minimal xprint"
+RDEPEND="x11-libs/libXfont
+ x11-libs/xtrans
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libXdmcp
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXi
+ media-libs/freetype
+ >=media-libs/mesa-6
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-misc/xbitmaps
+ x11-misc/xkbdata
+ x11-apps/iceauth
+ x11-apps/rgb
+ x11-apps/xauth
+ x11-apps/xinit
+ app-admin/eselect-opengl
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/libXxf86misc
+ x11-libs/libXxf86vm
+ !minimal? ( x11-libs/libdmx
+ x11-libs/libXtst
+ x11-libs/libXres )
+ x11-libs/libxkbui
+ x11-libs/liblbxutil"
+ # Xres is dmx-dependent, xkbui is xorgcfg-dependent
+ # Xaw is dmx- and xorgcfg-dependent
+ # Xpm is dmx- and xorgcfg-dependent, pulls in Xt
+ # Xxf86misc and Xxf86vm are xorgcfg-dependent
+ # liblbxutil is lbx- dependent
+DEPEND="${RDEPEND}
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/fixesproto
+ x11-proto/damageproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86miscproto
+ x11-proto/xf86rushproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86bigfontproto
+ x11-proto/compositeproto
+ x11-proto/recordproto
+ x11-proto/resourceproto
+ x11-proto/videoproto
+ x11-proto/scrnsaverproto
+ x11-proto/evieext
+ x11-proto/trapproto
+ >=x11-proto/xineramaproto-1.1-r1
+ x11-proto/fontsproto
+ >=x11-proto/kbproto-1.0-r1
+ x11-proto/inputproto
+ x11-proto/bigreqsproto
+ x11-proto/xcmiscproto
+ >=x11-proto/glproto-1.4.1_pre20051013
+ !minimal? ( x11-proto/dmxproto )
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )
+ xprint? ( x11-proto/printproto
+ x11-apps/mkfontdir
+ x11-apps/mkfontscale )"
+
+pkg_setup() {
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+ CONFIGURE_OPTIONS="
+ $(use_enable ipv6)
+ $(use_enable !minimal dmx)
+ $(use_enable !minimal xvfb)
+ $(use_enable !minimal xnest)
+ $(use_enable dri)
+ $(use_enable xprint)
+ --enable-xcsecurity
+ --with-mesa-source=${WORKDIR}/${MESA_P}
+ --enable-xorg
+ --enable-xtrap
+ --enable-xevie
+ --sysconfdir=/etc/X11
+ --localstatedir=/var
+ --disable-static
+ --enable-install-setuid
+ --with-default-font-path=/usr/share/fonts/misc,/usr/share/fonts/75dpi,/usr/share/fonts/100dpi,/usr/share/fonts/TTF,/usr/share/fonts/Type1"
+}
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+
+ # As of 20051028, should be taken care of by upstream
+ dosym Xorg /usr/bin/X
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if ! has_version x11-base/xorg-server; then
+ if [ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]; then
+ rm -rf ${ROOT}/usr/$(get_libdir)/xorg/modules
+ fi
+ fi
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ local x=""
+ for x in ${D}/usr/$(get_libdir)/xorg/modules/extensions/libglx*; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}