summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-09-28 12:43:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-09-28 12:43:19 +0000
commit836861fce354ddda76f40ca2ae27e6aad8b1b1e1 (patch)
treef395348851dc3cd900bca43330a55e498d50f9c0 /x11-base
parentVersion bump (diff)
downloadgentoo-2-836861fce354ddda76f40ca2ae27e6aad8b1b1e1.tar.gz
gentoo-2-836861fce354ddda76f40ca2ae27e6aad8b1b1e1.tar.bz2
gentoo-2-836861fce354ddda76f40ca2ae27e6aad8b1b1e1.zip
Revision bump to fix initscript, thx to Michal Gorny (bug #338837). Apply patch to fix compilation issues, thx to Alexandre Rostovtsev (bug #337020). Update deps per bug #338519.
(Portage version: 2.2_rc87/cvs/Linux x86_64)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog11
-rw-r--r--x11-base/xorg-server/files/1.9.0-fix-VbeModeInfoBlock-memcpy.patch36
-rw-r--r--[-rwxr-xr-x]x11-base/xorg-server/files/xdm.initd-3 (renamed from x11-base/xorg-server/files/xdm.initd-2)57
-rw-r--r--x11-base/xorg-server/xorg-server-1.9.0-r1.ebuild (renamed from x11-base/xorg-server/xorg-server-1.9.0.ebuild)40
4 files changed, 96 insertions, 48 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index 77882e413155..acdc231ff85e 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.535 2010/09/26 19:03:05 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.536 2010/09/28 12:43:19 scarabeus Exp $
+
+*xorg-server-1.9.0-r1 (28 Sep 2010)
+
+ 28 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.9.0-fix-VbeModeInfoBlock-memcpy.patch, -xorg-server-1.9.0.ebuild,
+ +xorg-server-1.9.0-r1.ebuild, -files/xdm.initd-2, +files/xdm.initd-3:
+ Revision bump to fix initscript, thx to Michal Gorny (bug #338837). Apply
+ patch to fix compilation issues, thx to Alexandre Rostovtsev (bug
+ #337020). Update deps per bug #338519.
26 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
xorg-server-1.7.7-r1.ebuild:
diff --git a/x11-base/xorg-server/files/1.9.0-fix-VbeModeInfoBlock-memcpy.patch b/x11-base/xorg-server/files/1.9.0-fix-VbeModeInfoBlock-memcpy.patch
new file mode 100644
index 000000000000..239213928acf
--- /dev/null
+++ b/x11-base/xorg-server/files/1.9.0-fix-VbeModeInfoBlock-memcpy.patch
@@ -0,0 +1,36 @@
+From ef6c9d2af50ac03b28ad92ea90105047d8bc9948 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Sun, 12 Sep 2010 23:53:26 -0400
+Subject: [PATCH] Fix VbeModeInfoBlock memcpy.
+
+Reserved2 is 189 bytes (not 188). From LinBytesPerScanLine to end of
+Reserved2 we have 189 + 16 = 205 bytes (not 206). From PhysBasePtr to end
+of Reserved2 we have 189 + 26 = 215 bytes (not 216).
+---
+ hw/xfree86/vbe/vbe.c | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/hw/xfree86/vbe/vbe.c b/hw/xfree86/vbe/vbe.c
+index 0b34648..2051577 100644
+--- a/hw/xfree86/vbe/vbe.c
++++ b/hw/xfree86/vbe/vbe.c
+@@ -583,13 +583,13 @@ VBEGetModeInfo(vbeInfoPtr pVbe, int mode)
+ block->LinRsvdMaskSize = ((char*)pVbe->memory)[60];
+ block->LinRsvdFieldPosition = ((char*)pVbe->memory)[61];
+ block->MaxPixelClock = *(CARD32*)(((char*)pVbe->memory) + 62);
+- memcpy(&block->Reserved2, ((char*)pVbe->memory) + 66, 188);
++ memcpy(&block->Reserved2, ((char*)pVbe->memory) + 66, 189);
+ }
+ else
+- memcpy(&block->LinBytesPerScanLine, ((char*)pVbe->memory) + 50, 206);
++ memcpy(&block->LinBytesPerScanLine, ((char*)pVbe->memory) + 50, 205);
+ }
+ else
+- memcpy(&block->PhysBasePtr, ((char*)pVbe->memory) + 40, 216);
++ memcpy(&block->PhysBasePtr, ((char*)pVbe->memory) + 40, 215);
+
+ return block;
+ }
+--
+1.7.2.2
+
diff --git a/x11-base/xorg-server/files/xdm.initd-2 b/x11-base/xorg-server/files/xdm.initd-3
index 47942b0d6cff..ae5f59e45015 100755..100644
--- a/x11-base/xorg-server/files/xdm.initd-2
+++ b/x11-base/xorg-server/files/xdm.initd-3
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/files/xdm.initd-2,v 1.1 2010/09/12 20:45:23 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/files/xdm.initd-3,v 1.1 2010/09/28 12:43:19 scarabeus Exp $
# This is here to serve as a note to myself, and future developers.
#
@@ -37,7 +37,7 @@
# 04 March 2002
depend() {
- need localmount xdm
+ need localmount xdm-setup
# this should start as early as possible
# we can't do 'before *' as that breaks it
@@ -55,12 +55,15 @@ depend() {
}
setup_dm() {
- local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
+ local MY_XDM
+
+ MY_XDM=$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')
# Load our root path from profile.env
# Needed for kdm
- PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
+ PATH=${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")
+ NAME=
case "${MY_XDM}" in
kdm|kde)
EXE="$(which kdm)"
@@ -93,7 +96,7 @@ setup_dm() {
PIDFILE="/var/run/${MY_XDM}.pid"
# warn user that he is doing sick things if the exe was not found
- if [ "${EXE}" = "" ]; then
+ if [ -z "${EXE}" ]; then
echo "ERROR: Your XDM value is invalid."
echo " No ${MY_XDM} executable could be found on your system."
fi
@@ -123,10 +126,10 @@ vtstatic() {
}
start() {
- local EXE= NAME= PIDFILE=
+ local EXE NAME PIDFILE
setup_dm
- if [ -f /etc/.noxdm ] || get_bootparam "nox" ; then
+ if [ -f /etc/.noxdm ]; then
einfo "Skipping ${EXE##*/}, /etc/.noxdm found or \"nox\" bootparam passed."
rm /etc/.noxdm
return 0
@@ -141,9 +144,9 @@ start() {
if [ -n "${CHECKVT-y}" ] ; then
if vtstatic "${CHECKVT:-7}" ; then
- if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ]; then
ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
- telinit a >/dev/null 2>/dev/null
+ telinit a >/dev/null 2>&1
return 0
else
eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
@@ -157,41 +160,43 @@ start() {
}
stop() {
- local retval=0
- local curvt=
- if [ -t 0 ] ; then
- if type fgconsole >/dev/null 2>/dev/null ; then
- curvt="$(fgconsole 2>/dev/null)"
+ local curvt retval
+
+ retval=0
+ if [ -t 0 ]; then
+ if type fgconsole >/dev/null 2>&1; then
+ curvt=$(fgconsole 2>/dev/null)
else
- curvt="$(tty)"
+ curvt=$(tty)
case "${curvt}" in
- /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
+ /dev/ttyv[0-9]*) curvt=${curvt#/dev/ttyv} ;;
*) curvt= ;;
esac
fi
fi
- local myexe="$(get_options "service")"
- local myname="$(get_options "name")"
- local mypidfile="$(get_options "pidfile")"
- local myservice=${myexe##*/}
+ local myexe myname mypidfile myservice
+ myexe=$(get_options "service")
+ myname=$(get_options "name")
+ mypidfile=$(get_options "pidfile")
+ myservice=${myexe##*/}
[ -z "${myexe}" ] && return 0
ebegin "Stopping ${myservice}"
- if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}"; then
start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
${mypidfile:+--pidfile} ${mypidfile} \
${myname:+--name} ${myname}
- retval=$?
+ retval=${?}
fi
# switch back to original vt
- if [ -n "${curvt}" ] ; then
- if type chvt >/dev/null 2>/dev/null ; then
+ if [ -n "${curvt}" ]; then
+ if type chvt >/dev/null 2>&1; then
chvt "${curvt}"
else
- vidcontrol -s "$((${curvt} + 1))"
+ vidcontrol -s "$((curvt + 1))"
fi
fi
diff --git a/x11-base/xorg-server/xorg-server-1.9.0.ebuild b/x11-base/xorg-server/xorg-server-1.9.0-r1.ebuild
index f7d2130f83eb..f1c9a73480db 100644
--- a/x11-base/xorg-server/xorg-server-1.9.0.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.9.0.ebuild,v 1.3 2010/09/21 17:18:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.9.0-r1.ebuild,v 1.1 2010/09/28 12:43:19 scarabeus Exp $
EAPI=3
inherit xorg-2 multilib versionator
@@ -85,8 +85,8 @@ DEPEND="${RDEPEND}
)
!minimal? (
>=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.1
- >=x11-libs/libdrm-2.3.0
+ >=x11-proto/dri2proto-2.3
+ >=x11-libs/libdrm-2.4.21
)"
PDEPEND="
@@ -106,6 +106,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-disable-acpi.patch
"${FILESDIR}"/${PN}-1.9-nouveau-default.patch
"${FILESDIR}"/1.7.5.902-fix-tslib-1.0-check.patch
+ "${FILESDIR}"/1.9.0-fix-VbeModeInfoBlock-memcpy.patch
)
pkg_setup() {
@@ -152,6 +153,18 @@ pkg_setup() {
--with-os-vendor=Gentoo
${conf_opts}"
+ # Xorg-server requires includes from OS mesa which are not visible for
+ # users of binary drivers.
+ # Due to the limitations of CONFIGURE_OPTIONS, we have to export this
+ mkdir -p "${T}/mesa-symlinks/GL"
+ for i in gl glx glxmd glxproto glxtokens; do
+ ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
+ done
+ for i in glext glxext; do
+ ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
+ done
+ append-cppflags "-I${T}/mesa-symlinks"
+
# (#121394) Causes window corruption
filter-flags -fweb
@@ -175,24 +188,6 @@ pkg_setup() {
fi
}
-src_configure() {
- # this is required only for configure and build time
- # we need to ensure having enough glxtokens
- # the subshell is needed so the addwrite is not shared in rest of that phase
- OLD_IMPLEM="$(eselect opengl show)"
- [[ ${OLD_IMPLEM} != ${OPENGL_DIR} ]] && ( addwrite "${ROOT}"; eselect opengl set ${OPENGL_DIR}; )
- xorg-2_src_configure
-}
-
-src_compile() {
- emake # no die here intentional
- if [[ $? != 0 ]]; then
- [[ ${OLD_IMPLEM} != ${OPENGL_DIR} ]] && ( addwrite "${ROOT}"; eselect opengl set ${OLD_IMPLEM}; )
- die "Compilation failed"
- fi
- [[ ${OLD_IMPLEM} != ${OPENGL_DIR} ]] && ( addwrite "${ROOT}"; eselect opengl set ${OLD_IMPLEM}; )
-}
-
src_install() {
xorg-2_src_install
@@ -215,6 +210,9 @@ src_install() {
}
pkg_postinst() {
+ # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
+ eselect opengl set --use-old xorg-x11
+
if [[ ${INFO} = yes ]]; then
einfo "You should consider reading upgrade guide for this release:"
einfo " http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"