summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-09-18 14:10:44 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-09-18 14:10:44 +0000
commite9c465ed8f5e264bc1daeef98c720a5a75209c4e (patch)
treed6da560239c6eca691898fc9798d95c71f97acd7 /www-servers
parentphp update (diff)
downloadgentoo-2-e9c465ed8f5e264bc1daeef98c720a5a75209c4e.tar.gz
gentoo-2-e9c465ed8f5e264bc1daeef98c720a5a75209c4e.tar.bz2
gentoo-2-e9c465ed8f5e264bc1daeef98c720a5a75209c4e.zip
fix for -r5 conf file installed in -r4 ebuild
(Portage version: 2.0.52-r1)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/files/5.0.28/tomcat.conf4
-rw-r--r--www-servers/tomcat/files/5.0.28/tomcat.conf-r176
-rw-r--r--www-servers/tomcat/tomcat-5.0.28-r5.ebuild8
3 files changed, 83 insertions, 5 deletions
diff --git a/www-servers/tomcat/files/5.0.28/tomcat.conf b/www-servers/tomcat/files/5.0.28/tomcat.conf
index c46ca201aab4..c2e686472f45 100644
--- a/www-servers/tomcat/files/5.0.28/tomcat.conf
+++ b/www-servers/tomcat/files/5.0.28/tomcat.conf
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.0.28/tomcat.conf,v 1.3 2005/09/14 19:11:37 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.0.28/tomcat.conf,v 1.4 2005/09/18 14:10:44 humpback Exp $
# JVM Runtime
# Using the default setting, it will determine your JVM from the system-vm
@@ -50,7 +50,7 @@ TOMCAT_STOP="stop"
# (Optional) Java runtime options used when the "start", "stop", or "run"
# commands are executed.
-CATALINA_OPTS="-Dlog4j.configuration=file:/etc/tomcat-5/log4j.properties"
+#CATALINA_OPTS="-Dlog4j.configuration=file:/etc/tomcat-5/log4j.properties"
# Java Platform Debugger Architecture (JPDA)
# http://java.sun.com/products/jpda/
diff --git a/www-servers/tomcat/files/5.0.28/tomcat.conf-r1 b/www-servers/tomcat/files/5.0.28/tomcat.conf-r1
new file mode 100644
index 000000000000..0108f3c3f35e
--- /dev/null
+++ b/www-servers/tomcat/files/5.0.28/tomcat.conf-r1
@@ -0,0 +1,76 @@
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.0.28/tomcat.conf-r1,v 1.1 2005/09/18 14:10:44 humpback Exp $
+
+# JVM Runtime
+# Using the default setting, it will determine your JVM from the system-vm
+# set using java-config.
+# See java-config(1) manual page for assistance in determining this value.
+#
+# You can override this value with whatever path you wish.
+# Example: JAVA_HOME=/opt/sun-jdk-1.4.2.05
+
+#JAVA_HOME=`java-config -O`
+
+# (Optional) Java runtime options used when the "start", "stop", or "run"
+# commands are executed.
+# JAVA_OPTS=""
+
+# profile
+PROFILE=default
+
+# Where your web applications are located
+CATALINA_HOME=/usr/share/tomcat-5
+CATALINA_BASE=/var/lib/tomcat-5/${PROFILE}
+
+# Tomcat's User
+CATALINA_USER=tomcat
+
+# Location of the Tomcat JARs and classes
+CATALINA_LIBDIR=/usr/share/tomcat-5/server/lib
+
+# The CLASSPATH for Tomcat to use, plus any others you need.
+#CLASSPATH=${CLASSPATH}:${CATALINA_LIBDIR}
+
+# (Optional) Directory path location of temporary directory the JVM should
+# use (java.io.tmpdir). Defaults to $CATALINA_BASE/temp.
+CATALINA_TMPDIR="/var/tmp/tomcat-5/${PROFILE}"
+
+# TOMCAT STARTUP/SHUTDOWN
+# debug Start Catalina in a debugger
+# debug -security Debug Catalina with a security manager
+# embedded Start Catalina in embedded mode
+# jpda start Start Catalina under JPDA debugger
+# start Start Catalina in a separate window
+# start -security Start in a separate window with security manager
+# stop Stop Catalina"
+#
+# NOTE: -security requires JSSE (see below)
+# NOTE: jpda requires JPDA (see below)
+TOMCAT_START="start"
+TOMCAT_STOP="stop"
+
+# (Optional) Java runtime options used when the "start", "stop", or "run"
+# commands are executed.
+CATALINA_OPTS="-Dlog4j.configuration=file:/etc/tomcat-5/log4j.properties"
+
+# Java Platform Debugger Architecture (JPDA)
+# http://java.sun.com/products/jpda/
+# Included with Java SDK 1.3 and later. No need to specify location.
+#
+# JPDA_TRANSPORT (Optional) JPDA transport used when the "jpda start"
+# command is executed. The default is "dt_socket".
+#
+# JPDA_ADDRESS (Optional) Java runtime options used when the "jpda start"
+# command is executed. The default is 8000.
+#
+# JPDA_TRANSPORT="dt_socket"
+# JPDA_ADDRESS="8000"
+
+# Java Secure Socket Extension (JSSE)
+# http://java.sun.com/products/jsse/
+# Included with Java SDK 1.4 and later.
+#
+# JSSE_HOME (Optional) May point at your Java Secure Sockets Extension
+# (JSSE) installation, whose JAR files will be added to the
+# system class path used to start Tomcat.
+#
+# JSSE_HOME="/opt/sun-jdk-1.4.1.02/jre/lib/"
diff --git a/www-servers/tomcat/tomcat-5.0.28-r5.ebuild b/www-servers/tomcat/tomcat-5.0.28-r5.ebuild
index 9fa924ce0dd1..0aa0cbe00935 100644
--- a/www-servers/tomcat/tomcat-5.0.28-r5.ebuild
+++ b/www-servers/tomcat/tomcat-5.0.28-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.0.28-r5.ebuild,v 1.1 2005/09/14 19:11:37 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.0.28-r5.ebuild,v 1.2 2005/09/18 14:10:44 humpback Exp $
inherit eutils java-pkg
@@ -127,9 +127,8 @@ src_install() {
# init.d, env.d, conf.d
newinitd ${FILESDIR}/${PV}/tomcat.init ${TOMCAT_NAME}
- newconfd ${FILESDIR}/${PV}/tomcat.conf ${TOMCAT_NAME}
+ newconfd ${FILESDIR}/${PV}/tomcat.conf-r1 ${TOMCAT_NAME}
newenvd ${FILESDIR}/${PV}/${PN}.env 21${PN}
- cp ${FILESDIR}/${PV}/log4j.properties ${D}/etc/tomcat-5/
if use jikes; then
sed -e "\cCATALINA_OPTScaCATALINA_OPTS=\"-Dbuild.compiler.emacs=true\"" \
@@ -217,6 +216,9 @@ src_install() {
dosym /var/tmp/${TOMCAT_NAME}/default /var/lib/${TOMCAT_NAME}/default/temp
dosym /var/run/${TOMCAT_NAME}/default /var/lib/${TOMCAT_NAME}/default/work
+ cp ${FILESDIR}/${PV}/log4j.properties ${D}/etc/${TOMCAT_NAME}/
+ chown tomcat:tomcat ${D}/etc/${TOMCAT_NAME}/log4j.properties
+
use doc && dodoc ${S}/jakarta-tomcat-5/{LICENSE,RELEASE-NOTES,RUNNING.txt}
fperms 640 /etc/${TOMCAT_NAME}/default/tomcat-users.xml
}