summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-21 17:50:39 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-21 17:50:39 +0000
commite56b970def138e5d8e89f8ee1a5b150535588681 (patch)
treed83fd7f95a860b415c34fca2cad8a597810eaf6f /www-servers
parentBumping to 1.4_pre20090921 and removing old version (diff)
downloadgentoo-2-e56b970def138e5d8e89f8ee1a5b150535588681.tar.gz
gentoo-2-e56b970def138e5d8e89f8ee1a5b150535588681.tar.bz2
gentoo-2-e56b970def138e5d8e89f8ee1a5b150535588681.zip
- cleanup
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/nginx-0.5.37.ebuild102
-rw-r--r--www-servers/nginx/nginx-0.6.38.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.7.61.ebuild109
-rw-r--r--www-servers/nginx/nginx-0.8.13.ebuild116
-rw-r--r--www-servers/nginx/nginx-0.8.4-r1.ebuild117
-rw-r--r--www-servers/nginx/nginx-0.8.4.ebuild109
7 files changed, 6 insertions, 658 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index faa94ee259ea..b9a1813d1ead 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.227 2009/09/18 19:22:29 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.228 2009/09/21 17:50:39 voxus Exp $
+
+ 21 Sep 2009; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.37.ebuild, -nginx-0.6.38.ebuild, -nginx-0.7.61.ebuild,
+ -nginx-0.8.4.ebuild, -nginx-0.8.4-r1.ebuild, -nginx-0.8.13.ebuild:
+ Cleanup.
18 Sep 2009; Tobias Heinlein <keytoaster@gentoo.org> nginx-0.5.38.ebuild,
nginx-0.6.39.ebuild, nginx-0.7.62.ebuild:
diff --git a/www-servers/nginx/nginx-0.5.37.ebuild b/www-servers/nginx/nginx-0.5.37.ebuild
deleted file mode 100644
index b8e946f0fc9b..000000000000
--- a/www-servers/nginx/nginx-0.5.37.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.37.ebuild,v 1.2 2008/10/25 17:36:52 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.6.38.ebuild b/www-servers/nginx/nginx-0.6.38.ebuild
deleted file mode 100644
index e35c319d5bf4..000000000000
--- a/www-servers/nginx/nginx-0.6.38.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.38.ebuild,v 1.2 2009/07/09 13:44:57 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.7.61.ebuild b/www-servers/nginx/nginx-0.7.61.ebuild
deleted file mode 100644
index 7ba7f77c7725..000000000000
--- a/www-servers/nginx/nginx-0.7.61.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.61.ebuild,v 1.2 2009/07/09 13:44:57 voxus Exp $
-
-inherit eutils ssl-cert toolchain-funcs
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap pcre perl random-index ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
-}
-
-src_unpack() {
- unpack ${A}
- sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
- use random-index && myconf="${myconf} --with-http_random_index_module"
-
- tc-export CC
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- install_cert /etc/ssl/${PN}/${PN}
- chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.8.13.ebuild b/www-servers/nginx/nginx-0.8.13.ebuild
deleted file mode 100644
index 68fa84cf0a8f..000000000000
--- a/www-servers/nginx/nginx-0.8.13.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.13.ebuild,v 1.1 2009/09/06 19:45:39 voxus Exp $
-
-inherit eutils ssl-cert toolchain-funcs
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap ipv6 pcre perl random-index securelink ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
- if use ipv6; then
- ewarn "Note that ipv6 support in nginx is still experimental."
- ewarn "Be sure to read comments on gentoo bug #274614"
- ewarn "http://bugs.gentoo.org/show_bug.cgi?id=274614"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use ipv6 && myconf="${myconf} --with-ipv6"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
- use random-index && myconf="${myconf} --with-http_random_index_module"
- use securelink && myconf="${myconf} --with-http_secure_link_module"
-
- tc-export CC
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- install_cert /etc/ssl/${PN}/${PN}
- chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.8.4-r1.ebuild b/www-servers/nginx/nginx-0.8.4-r1.ebuild
deleted file mode 100644
index 1d89f2b9c268..000000000000
--- a/www-servers/nginx/nginx-0.8.4-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.4-r1.ebuild,v 1.1 2009/07/19 14:56:33 cla Exp $
-
-inherit eutils ssl-cert toolchain-funcs
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap ipv6 pcre perl random-index securelink ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
- if use ipv6; then
- ewarn "Note that ipv6 support in nginx is still experimental."
- ewarn "Be sure to read comments on gentoo bug #274614"
- ewarn "http://bugs.gentoo.org/show_bug.cgi?id=274614"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
- epatch "${FILESDIR}"/${PN}-secure-link-timeout.patch
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use ipv6 && myconf="${myconf} --with-ipv6"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
- use random-index && myconf="${myconf} --with-http_random_index_module"
- use securelink && myconf="${myconf} --with-http_secure_link_module"
-
- tc-export CC
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- install_cert /etc/ssl/${PN}/${PN}
- chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.8.4.ebuild b/www-servers/nginx/nginx-0.8.4.ebuild
deleted file mode 100644
index 4f17af152b01..000000000000
--- a/www-servers/nginx/nginx-0.8.4.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.4.ebuild,v 1.1 2009/06/22 10:06:39 voxus Exp $
-
-inherit eutils ssl-cert toolchain-funcs
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap pcre perl random-index ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
-}
-
-src_unpack() {
- unpack ${A}
- sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
- use random-index && myconf="${myconf} --with-http_random_index_module"
-
- tc-export CC
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- install_cert /etc/ssl/${PN}/${PN}
- chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
- fi
- }
-}