summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-14 19:40:21 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-14 19:40:21 +0000
commit85fd229bac951413d58c1c78d690000f2bd091cd (patch)
tree99a605cd9a405bdfd71acea50513c52b0b09da4b /www-servers
parentUpdate old selinux base policy to support ext4. (diff)
downloadgentoo-2-85fd229bac951413d58c1c78d690000f2bd091cd.tar.gz
gentoo-2-85fd229bac951413d58c1c78d690000f2bd091cd.tar.bz2
gentoo-2-85fd229bac951413d58c1c78d690000f2bd091cd.zip
* bump wrt bug #283802
- unsupported versions (Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog13
-rw-r--r--www-servers/nginx/nginx-0.1.45.ebuild70
-rw-r--r--www-servers/nginx/nginx-0.2.6.ebuild70
-rw-r--r--www-servers/nginx/nginx-0.4.14.ebuild79
-rw-r--r--www-servers/nginx/nginx-0.5.38.ebuild (renamed from www-servers/nginx/nginx-0.3.61.ebuild)65
-rw-r--r--www-servers/nginx/nginx-0.6.39.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.7.62.ebuild109
-rw-r--r--www-servers/nginx/nginx-0.8.15.ebuild116
8 files changed, 385 insertions, 241 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index d457d737c823..c7c69ca60fcf 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.224 2009/09/06 19:45:39 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.225 2009/09/14 19:40:21 voxus Exp $
+
+*nginx-0.8.15 (14 Sep 2009)
+*nginx-0.7.62 (14 Sep 2009)
+*nginx-0.6.39 (14 Sep 2009)
+*nginx-0.5.38 (14 Sep 2009)
+
+ 14 Sep 2009; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.1.45.ebuild, -nginx-0.2.6.ebuild, -nginx-0.3.61.ebuild,
+ -nginx-0.4.14.ebuild, +nginx-0.5.38.ebuild, +nginx-0.6.39.ebuild,
+ +nginx-0.7.62.ebuild, +nginx-0.8.15.ebuild:
+ Version bump, wrt bug #283802. Unsupported versions are dropped.
*nginx-0.8.13 (06 Sep 2009)
diff --git a/www-servers/nginx/nginx-0.1.45.ebuild b/www-servers/nginx/nginx-0.1.45.ebuild
deleted file mode 100644
index 6a66cf8a3454..000000000000
--- a/www-servers/nginx/nginx-0.1.45.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.45.ebuild,v 1.2 2005/09/23 21:21:28 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi imap pcre threads ssl zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-
-src_compile() {
- local myconf
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dodir /etc/${PN}
-
- dosbin objs/nginx
- doinitd ${FILESDIR}/nginx
-
- insinto /etc/${PN}
- rm conf/nginx.conf
- doins -r conf/*
- doins ${FILESDIR}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-}
diff --git a/www-servers/nginx/nginx-0.2.6.ebuild b/www-servers/nginx/nginx-0.2.6.ebuild
deleted file mode 100644
index 26ddee15e358..000000000000
--- a/www-servers/nginx/nginx-0.2.6.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.2.6.ebuild,v 1.2 2005/10/22 22:28:47 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi imap pcre threads ssl zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-
-src_compile() {
- local myconf
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dodir /etc/${PN}
-
- dosbin objs/nginx
- doinitd ${FILESDIR}/nginx
-
- insinto /etc/${PN}
- rm conf/nginx.conf
- doins -r conf/*
- doins ${FILESDIR}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-}
diff --git a/www-servers/nginx/nginx-0.4.14.ebuild b/www-servers/nginx/nginx-0.4.14.ebuild
deleted file mode 100644
index 32fa327eecc4..000000000000
--- a/www-servers/nginx/nginx-0.4.14.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.14.ebuild,v 1.2 2007/02/13 14:23:31 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi imap pcre perl threads ssl zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-src_compile() {
- local myconf
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp ${FILESDIR}/nginx-r1 ${T}/nginx
- doinitd ${T}/nginx
-
- rm conf/nginx.conf
- cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/* ${T}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd ${S}/objs/src/http/modules/perl/
- make DESTDIR=${D} install || die "failed to install perl stuff"
- }
-}
diff --git a/www-servers/nginx/nginx-0.3.61.ebuild b/www-servers/nginx/nginx-0.5.38.ebuild
index bf87e1f49519..e9dacfbc1399 100644
--- a/www-servers/nginx/nginx-0.3.61.ebuild
+++ b/www-servers/nginx/nginx-0.5.38.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.2 2006/10/31 18:22:37 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.38.ebuild,v 1.1 2009/09/14 19:40:21 voxus Exp $
-inherit eutils
+inherit eutils ssl-cert
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
@@ -10,8 +10,8 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl
pcre? ( >=dev-libs/libpcre-4.2 )
@@ -19,19 +19,29 @@ DEPEND="dev-lang/perl
zlib? ( sys-libs/zlib )
perl? ( >=dev-lang/perl-5.8 )"
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
src_compile() {
local myconf
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use flv && myconf="${myconf} --with-http_flv_module"
use zlib || myconf="${myconf} --without-http_gzip_module"
use pcre || {
myconf="${myconf} --without-pcre --without-http_rewrite_module"
@@ -40,6 +50,9 @@ src_compile() {
use ssl && myconf="${myconf} --with-http_ssl_module"
use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+ use sub && myconf="${myconf} --with-http_sub_module"
./configure \
--prefix=/usr \
@@ -60,20 +73,30 @@ src_install() {
keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
dosbin objs/nginx
- cp ${FILESDIR}/nginx-r1 ${T}/nginx
- doinitd ${T}/nginx
+ cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
+ doinitd "${T}"/nginx
- rm conf/nginx.conf
- cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/* ${T}/nginx.conf
+ dodir "${ROOT}"/etc/${PN}
+ insinto "${ROOT}"/etc/${PN}
+ doins conf/*
dodoc CHANGES{,.ru} LICENSE README
use perl && {
- cd ${S}/objs/src/http/modules/perl/
- make DESTDIR=${D} install || die "failed to install perl stuff"
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ }
+}
+
+pkg_postinst() {
+ use ssl && {
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ dodir "${ROOT}"/etc/ssl/${PN}
+ insinto "${ROOT}"etc/ssl/${PN}/
+ insopts -m0644 -o nginx -g nginx
+ install_cert /etc/ssl/nginx/nginx
+ fi
}
}
diff --git a/www-servers/nginx/nginx-0.6.39.ebuild b/www-servers/nginx/nginx-0.6.39.ebuild
new file mode 100644
index 000000000000..c6d10011d508
--- /dev/null
+++ b/www-servers/nginx/nginx-0.6.39.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.39.ebuild,v 1.1 2009/09/14 19:40:21 voxus Exp $
+
+inherit eutils ssl-cert
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://nginx.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
+
+ use addition && myconf="${myconf} --with-http_addition_module"
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use flv && myconf="${myconf} --with-http_flv_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+ use sub && myconf="${myconf} --with-http_sub_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ --with-sha1-asm --with-sha1=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
+ doinitd "${T}"/nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+
+ dodir "${ROOT}"/etc/${PN}
+ insinto "${ROOT}"/etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ }
+}
+
+pkg_postinst() {
+ use ssl && {
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ dodir "${ROOT}"/etc/ssl/${PN}
+ insinto "${ROOT}"etc/ssl/${PN}/
+ insopts -m0644 -o nginx -g nginx
+ install_cert /etc/ssl/nginx/nginx
+ fi
+ }
+}
diff --git a/www-servers/nginx/nginx-0.7.62.ebuild b/www-servers/nginx/nginx-0.7.62.ebuild
new file mode 100644
index 000000000000..307fc3ad0443
--- /dev/null
+++ b/www-servers/nginx/nginx-0.7.62.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.62.ebuild,v 1.1 2009/09/14 19:40:21 voxus Exp $
+
+inherit eutils ssl-cert toolchain-funcs
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://nginx.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="addition debug fastcgi flv imap pcre perl random-index ssl status sub webdav zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend ${?}
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
+}
+
+src_compile() {
+ local myconf
+
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
+
+ use addition && myconf="${myconf} --with-http_addition_module"
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use flv && myconf="${myconf} --with-http_flv_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+ use sub && myconf="${myconf} --with-http_sub_module"
+ use random-index && myconf="${myconf} --with-http_random_index_module"
+
+ tc-export CC
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ --with-sha1-asm --with-sha1=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
+ doinitd "${T}"/nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} README
+
+ use perl && {
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ }
+}
+
+pkg_postinst() {
+ use ssl && {
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ install_cert /etc/ssl/${PN}/${PN}
+ chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ fi
+ }
+}
diff --git a/www-servers/nginx/nginx-0.8.15.ebuild b/www-servers/nginx/nginx-0.8.15.ebuild
new file mode 100644
index 000000000000..8ee3ba735f02
--- /dev/null
+++ b/www-servers/nginx/nginx-0.8.15.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.15.ebuild,v 1.1 2009/09/14 19:40:21 voxus Exp $
+
+inherit eutils ssl-cert toolchain-funcs
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://nginx.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="addition debug fastcgi flv imap ipv6 pcre perl random-index securelink ssl status sub webdav zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend ${?}
+ if use ipv6; then
+ ewarn "Note that ipv6 support in nginx is still experimental."
+ ewarn "Be sure to read comments on gentoo bug #274614"
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=274614"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
+}
+
+src_compile() {
+ local myconf
+
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
+
+ use addition && myconf="${myconf} --with-http_addition_module"
+ use ipv6 && myconf="${myconf} --with-ipv6"
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use flv && myconf="${myconf} --with-http_flv_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+ use sub && myconf="${myconf} --with-http_sub_module"
+ use random-index && myconf="${myconf} --with-http_random_index_module"
+ use securelink && myconf="${myconf} --with-http_secure_link_module"
+
+ tc-export CC
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ --with-sha1-asm --with-sha1=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
+ doinitd "${T}"/nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} README
+
+ use perl && {
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ }
+}
+
+pkg_postinst() {
+ use ssl && {
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ install_cert /etc/ssl/${PN}/${PN}
+ chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ fi
+ }
+}