summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2013-09-22 02:50:27 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2013-09-22 02:50:27 +0000
commit6bb7df92b123aae416599287ec981872eec3ebcc (patch)
treead64f648d13175fd6c200e365955550739991e46 /www-servers
parentPrefix support for env.d files, bug 485580. (diff)
downloadgentoo-2-6bb7df92b123aae416599287ec981872eec3ebcc.tar.gz
gentoo-2-6bb7df92b123aae416599287ec981872eec3ebcc.tar.bz2
gentoo-2-6bb7df92b123aae416599287ec981872eec3ebcc.zip
Version bump. Bug #484638.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-18.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 1199a5e8381d..edf43e429605 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.31 2013/05/02 04:05:08 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.32 2013/09/22 02:50:27 rafaelmartins Exp $
+
+*gunicorn-18.0 (22 Sep 2013)
+
+ 22 Sep 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-18.0.ebuild:
+ Version bump. Bug #484638.
*gunicorn-0.17.4 (02 May 2013)
diff --git a/www-servers/gunicorn/gunicorn-18.0.ebuild b/www-servers/gunicorn/gunicorn-18.0.ebuild
new file mode 100644
index 000000000000..6ac66f024a32
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-18.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-18.0.ebuild,v 1.1 2013/09/22 02:50:27 rafaelmartins Exp $
+
+EAPI="5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest )"
+
+DOCS="README.rst"
+
+src_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ sphinx-build -b html source build || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/
+}