summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-06-29 22:59:33 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-06-29 22:59:33 +0000
commit551dd74d93c2c0e98b1caa8d53ce821870eaac82 (patch)
tree15e791ab6ae4d3d817b70a57e8b7dd1281e961f4 /www-servers
parentInitial import (diff)
downloadgentoo-2-551dd74d93c2c0e98b1caa8d53ce821870eaac82.tar.gz
gentoo-2-551dd74d93c2c0e98b1caa8d53ce821870eaac82.tar.bz2
gentoo-2-551dd74d93c2c0e98b1caa8d53ce821870eaac82.zip
* bump, 0.3.49 stabilization
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.503
-rw-r--r--www-servers/nginx/nginx-0.3.49.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.3.50.ebuild72
4 files changed, 85 insertions, 3 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 7030ce7e89ae..7240d5e50b2a 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.95 2006/06/01 12:31:00 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.96 2006/06/29 22:59:33 voxus Exp $
+
+*nginx-0.3.50 (30 Jun 2006)
+
+ 30 Jun 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.50.ebuild,
+ -nginx-0.3.35.ebuild, -nginx-0.3.44.ebuild, -nginx-0.3.46.ebuild,
+ nginx-0.3.49.ebuild:
+ Bump, 0.3.49 goes stable on both amd64 and x86.
*nginx-0.3.49 (01 Jun 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.50 b/www-servers/nginx/files/digest-nginx-0.3.50
new file mode 100644
index 000000000000..85ac01cbf82f
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.50
@@ -0,0 +1,3 @@
+MD5 3117157a69ea262e7aa2fd1ea9208392 nginx-0.3.50.tar.gz 405516
+RMD160 312d411a26dd113dd97b443a1a9296367364c9c3 nginx-0.3.50.tar.gz 405516
+SHA256 8b1987df7864056f2981498b65db35bef39e5c10171f36baf3a4f57c4a5369f4 nginx-0.3.50.tar.gz 405516
diff --git a/www-servers/nginx/nginx-0.3.49.ebuild b/www-servers/nginx/nginx-0.3.49.ebuild
index 05d2fdea745b..2e12d4e30323 100644
--- a/www-servers/nginx/nginx-0.3.49.ebuild
+++ b/www-servers/nginx/nginx-0.3.49.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.49.ebuild,v 1.1 2006/06/01 12:31:00 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.49.ebuild,v 1.2 2006/06/29 22:59:33 voxus Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug fastcgi imap pcre perl threads ssl zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.3.50.ebuild b/www-servers/nginx/nginx-0.3.50.ebuild
new file mode 100644
index 000000000000..5a6c0838d32e
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.50.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.50.ebuild,v 1.1 2006/06/29 22:59:33 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}