summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2008-12-19 20:48:47 +0000
committerAlistair Bush <ali_bush@gentoo.org>2008-12-19 20:48:47 +0000
commit789445c8cf92c8da274268e75c42c4137fae2ce8 (patch)
tree9197657528d4b8bc2e6db792e6843da10e0c8965 /www-servers/tomcat
parentFix bug 250420 thanks to Joel <joel_123@hotmail.com> (diff)
downloadgentoo-2-789445c8cf92c8da274268e75c42c4137fae2ce8.tar.gz
gentoo-2-789445c8cf92c8da274268e75c42c4137fae2ce8.tar.bz2
gentoo-2-789445c8cf92c8da274268e75c42c4137fae2ce8.zip
Bump to fix #246362.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/ChangeLog10
-rw-r--r--www-servers/tomcat/files/5.5/tomcat.conf.24
-rwxr-xr-xwww-servers/tomcat/files/5.5/tomcat.init.29
-rw-r--r--www-servers/tomcat/files/6/tomcat.conf4
-rwxr-xr-xwww-servers/tomcat/files/6/tomcat.init9
-rw-r--r--www-servers/tomcat/tomcat-5.5.27-r2.ebuild343
-rw-r--r--www-servers/tomcat/tomcat-6.0.18-r2.ebuild200
7 files changed, 574 insertions, 5 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 8483caea6356..bfe31fd61eb9 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.202 2008/12/10 19:29:54 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.203 2008/12/19 20:48:47 ali_bush Exp $
+
+*tomcat-6.0.18-r2 (19 Dec 2008)
+*tomcat-5.5.27-r2 (19 Dec 2008)
+
+ 19 Dec 2008; Alistair Bush <ali_bush@gentoo.org> files/5.5/tomcat.conf.2,
+ files/6/tomcat.conf, files/5.5/tomcat.init.2, files/6/tomcat.init,
+ +tomcat-5.5.27-r2.ebuild, +tomcat-6.0.18-r2.ebuild:
+ Bump tomcat. Update init script to test for temp dir to fix #246362.
10 Dec 2008; Petteri Räty <betelgeuse@gentoo.org> metadata.xml:
Add weisso as proxy maintainer.
diff --git a/www-servers/tomcat/files/5.5/tomcat.conf.2 b/www-servers/tomcat/files/5.5/tomcat.conf.2
index ea32decf3cc2..88e00c7d613b 100644
--- a/www-servers/tomcat/files/5.5/tomcat.conf.2
+++ b/www-servers/tomcat/files/5.5/tomcat.conf.2
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5/tomcat.conf.2,v 1.3 2007/05/31 23:01:57 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5/tomcat.conf.2,v 1.4 2008/12/19 20:48:47 ali_bush Exp $
# JVM Runtime
# Using the default setting, it will determine your JVM from the system-vm
@@ -34,6 +34,8 @@ CLASSPATH=${CATALINA_LIBDIR}
# (Optional) Directory path location of temporary directory the JVM should
# use (java.io.tmpdir). Defaults to $CATALINA_BASE/temp.
+# Note: This directory must exist and be read/writable by tomcat.
+# See #246362 as an example where /var/tmp was deleted on shutdown.
CATALINA_TMPDIR="/var/tmp/tomcat-5.5/"
# TOMCAT STARTUP/SHUTDOWN
diff --git a/www-servers/tomcat/files/5.5/tomcat.init.2 b/www-servers/tomcat/files/5.5/tomcat.init.2
index 43cf79b0d665..6211c9baa85d 100755
--- a/www-servers/tomcat/files/5.5/tomcat.init.2
+++ b/www-servers/tomcat/files/5.5/tomcat.init.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5/tomcat.init.2,v 1.6 2007/05/20 23:24:56 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5/tomcat.init.2,v 1.7 2008/12/19 20:48:47 ali_bush Exp $
init_env_vars() {
if [ "$(gjl -p tomcat-5.5 --get-vm)" ] ; then
@@ -69,6 +69,13 @@ depend() {
start() {
ebegin "Starting Tomcat"
init_env_vars
+
+ if [ ! -e "${CATALINA_TMPDIR}" ]; then
+ eerror "CATALINA_TMPDIR does not exist. Unable to start tomcat."
+ eerror "Please see /etc/conf.d/tomcat-6 for more information."
+ eend 1
+ fi
+
# Figure out what arguments to pass start_helper based on TOMCAT_START
if [ "${TOMCAT_START}" = "debug" ] ; then
start_helper ${JAVA_HOME}/bin/jdb \
diff --git a/www-servers/tomcat/files/6/tomcat.conf b/www-servers/tomcat/files/6/tomcat.conf
index 0e270c6345d7..5fc22e3a921e 100644
--- a/www-servers/tomcat/files/6/tomcat.conf
+++ b/www-servers/tomcat/files/6/tomcat.conf
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.conf,v 1.4 2007/05/31 23:01:57 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.conf,v 1.5 2008/12/19 20:48:47 ali_bush Exp $
# JVM Runtime
# Using the default setting, it will determine your JVM from the system-vm
@@ -34,6 +34,8 @@ CLASSPATH=${CATALINA_LIBDIR}
# (Optional) Directory path location of temporary directory the JVM should
# use (java.io.tmpdir). Defaults to $CATALINA_BASE/temp.
+# Note: This directory must exist and be read/writable by tomcat.
+# See #246362 as an example where /var/tmp was deleted on shutdown.
CATALINA_TMPDIR="/var/tmp/tomcat-6/"
# TOMCAT STARTUP/SHUTDOWN
diff --git a/www-servers/tomcat/files/6/tomcat.init b/www-servers/tomcat/files/6/tomcat.init
index 24fbea7901c5..34178058e203 100755
--- a/www-servers/tomcat/files/6/tomcat.init
+++ b/www-servers/tomcat/files/6/tomcat.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.8 2007/05/17 21:15:05 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.9 2008/12/19 20:48:47 ali_bush Exp $
init_env_vars() {
# Populate JAVA_HOME
@@ -60,6 +60,13 @@ depend() {
start() {
ebegin "Starting Tomcat"
init_env_vars
+
+ if [ ! -e "${CATALINA_TMPDIR}" ]; then
+ eerror "CATALINA_TMPDIR does not exist. Unable to start tomcat."
+ eerror "Please see /etc/conf.d/tomcat-6 for more information."
+ eend 1
+ fi
+
# Figure out what arguments to pass start_helper based on TOMCAT_START
if [ "${TOMCAT_START}" = "debug" ] ; then
start_helper ${JAVA_HOME}/bin/jdb \
diff --git a/www-servers/tomcat/tomcat-5.5.27-r2.ebuild b/www-servers/tomcat/tomcat-5.5.27-r2.ebuild
new file mode 100644
index 000000000000..6c8f1230d0ff
--- /dev/null
+++ b/www-servers/tomcat/tomcat-5.5.27-r2.ebuild
@@ -0,0 +1,343 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.27-r2.ebuild,v 1.1 2008/12/19 20:48:47 ali_bush Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc source"
+WANT_ANT_TASKS="ant-trax"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Tomcat Servlet-2.4/JSP-2.0 Container"
+
+MY_P="apache-${P}-src"
+SLOT="5.5"
+SRC_URI="mirror://apache/${PN}/${PN}-5/v${PV}/src/${MY_P}.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 -ppc -ppc64 ~x86 ~x86-fbsd"
+LICENSE="Apache-2.0"
+
+IUSE="admin java5 examples test"
+
+SERVLET_API="~dev-java/tomcat-servlet-api-${PV}"
+RDEPEND="dev-java/eclipse-ecj:3.3
+ dev-java/ant-eclipse-ecj:3.3
+ dev-java/commons-beanutils:1.7
+ >=dev-java/commons-collections-3.1
+ >=dev-java/commons-daemon-1.0.1
+ >=dev-java/commons-dbcp-1.2.1
+ >=dev-java/commons-digester-1.7
+ >=dev-java/commons-fileupload-1.1
+ dev-java/commons-httpclient:0
+ >=dev-java/commons-io-1.1
+ >=dev-java/commons-el-1.0
+ >=dev-java/commons-launcher-0.9
+ >=dev-java/commons-logging-1.0.4
+ >=dev-java/commons-modeler-2.0
+ >=dev-java/commons-pool-1.2
+ =dev-java/junit-3*
+ >=dev-java/log4j-1.2.9
+ >=dev-java/saxpath-1.0
+ ${SERVLET_API}
+ dev-java/ant-core
+ admin? ( dev-java/struts:1.2 )
+ dev-java/sun-javamail
+ java5? (
+ >=virtual/jre-1.5
+ )
+ !java5? (
+ =virtual/jre-1.4*
+ dev-java/sun-jaf
+ dev-java/mx4j-core:3.0
+ dev-java/xerces:2
+ dev-java/xml-commons-external:1.3
+ )"
+DEPEND="java5? ( >=virtual/jdk-1.5 )
+ !java5? ( =virtual/jdk-1.4* )
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+TOMCAT_NAME="${PN}-${SLOT}"
+WEBAPPS_DIR="/var/lib/${TOMCAT_NAME}/webapps"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ # new user for tomcat
+ enewgroup tomcat
+ enewuser tomcat -1 -1 /dev/null tomcat
+
+ java-pkg_filter-compiler ecj-3.1 ecj-3.2
+ if use !java5 && built_with_use ${SERVLET_API} java5;
+ then
+ eerror "With USE=\"-java5\" ${SERVLET_API} must also"
+ eerror "be built without java5 support"
+ die "Rebuild ${SERVLET_API} without java5 support"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${SLOT}/26-main_tomcat_catalina_jasper_build_xml.patch"
+ # https://issues.apache.org/bugzilla/show_bug.cgi?id=45827
+ epatch "${FILESDIR}/${SLOT}/5.5.27-dynamic-JSSE13Factory.patch"
+
+ use examples && epatch "${FILESDIR}/${SLOT}/jsr152_jsr154_examples_build_xml.patch"
+
+ sed -i -e 's:${struts.lib}:/usr/share/struts-1.2:' \
+ "${S}/container/webapps/admin/build.xml"
+
+ einfo "Removing 1.3 factories to so we don't need com.sun.*"
+ rm -v connectors/util/java/org/apache/tomcat/util/net/jsse/*13* || die
+
+ # avoid packed jars :-)
+ mkdir -p "${S}"/build/build/common
+ cd "${S}"/build/build
+
+ mkdir ./bin && cd ./bin
+ java-pkg_jar-from commons-logging commons-logging-api.jar
+ java-pkg_jar-from commons-daemon
+ if ! use java5; then
+ java-pkg_jar-from mx4j-core-3.0 mx4j.jar jmx.jar
+ java-pkg_jar-from mx4j-core-3.0 mx4j-rjmx.jar jmx-remote.jar
+ mkdir "${S}"/build/build/common/endorsed && cd "${S}"/build/build/common/endorsed
+ java-pkg_jar-from xml-commons-external-1.3 xml-apis.jar
+ java-pkg_jar-from xerces-2 xercesImpl.jar
+ fi
+
+ mkdir "${S}"/build/build/common/lib && cd "${S}"/build/build/common/lib
+ java-pkg_jar-from ant-core
+ java-pkg_jar-from commons-collections
+ java-pkg_jar-from commons-dbcp
+ java-pkg_jar-from commons-el
+ java-pkg_jar-from commons-pool
+ java-pkg_jar-from tomcat-servlet-api-2.4
+
+ mkdir -p "${S}"/build/build/server/lib && cd "${S}"/build/build/server/lib
+ java-pkg_jar-from commons-beanutils-1.7 commons-beanutils.jar
+ java-pkg_jar-from commons-digester
+ java-pkg_jar-from commons-modeler
+
+}
+
+src_compile(){
+ local antflags="-Dbase.path=${T}"
+
+ antflags="${antflags} -Dservletapi.build.notrequired=true"
+ antflags="${antflags} -Djspapi.build.notrequired=true"
+ antflags="${antflags} -Dcommons-beanutils.jar=$(java-pkg_getjar commons-beanutils-1.7 commons-beanutils.jar)"
+ antflags="${antflags} -Dcommons-collections.jar=$(java-pkg_getjars commons-collections)"
+ antflags="${antflags} -Dcommons-daemon.jar=$(java-pkg_getjars commons-daemon)"
+ antflags="${antflags} -Dcommons-digester.jar=$(java-pkg_getjars commons-digester)"
+ antflags="${antflags} -Dcommons-dbcp.jar=$(java-pkg_getjars commons-dbcp)"
+ antflags="${antflags} -Dcommons-el.jar=$(java-pkg_getjars commons-el)"
+ antflags="${antflags} -Dcommons-fileupload.jar=$(java-pkg_getjars commons-fileupload)"
+ antflags="${antflags} -Dcommons-httpclient.jar=$(java-pkg_getjars commons-httpclient)"
+ antflags="${antflags} -Dcommons-io.jar=$(java-pkg_getjars commons-io-1)"
+ antflags="${antflags} -Dcommons-launcher.jar=$(java-pkg_getjars commons-launcher)"
+ antflags="${antflags} -Dcommons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)"
+ antflags="${antflags} -Dcommons-logging-api.jar=$(java-pkg_getjar commons-logging commons-logging-api.jar)"
+ antflags="${antflags} -Dcommons-pool.jar=$(java-pkg_getjars commons-pool)"
+ antflags="${antflags} -Dcommons-modeler.jar=$(java-pkg_getjars commons-modeler)"
+ antflags="${antflags} -Djdt.jar=$(java-pkg_getjar eclipse-ecj-3.3 ecj.jar)"
+ antflags="${antflags} -Djsp-api.jar=$(java-pkg_getjar tomcat-servlet-api-2.4 jsp-api.jar)"
+ antflags="${antflags} -Djunit.jar=$(java-pkg_getjars junit)"
+ antflags="${antflags} -Dlog4j.jar=$(java-pkg_getjars log4j)"
+ antflags="${antflags} -Dmail.jar=$(java-pkg_getjar sun-javamail mail.jar)"
+ antflags="${antflags} -Dsaxpath.jar=$(java-pkg_getjar saxpath saxpath.jar)"
+ antflags="${antflags} -Dservlet-api.jar=$(java-pkg_getjar tomcat-servlet-api-2.4 servlet-api.jar)"
+ if use admin; then
+ antflags="${antflags} -Dstruts.jar=$(java-pkg_getjar struts-1.2 struts.jar)"
+ antflags="${antflags} -Dstruts.home=/usr/share/struts"
+ else
+ antflags="${antflags} -Dadmin.build.notrequired=true"
+ antflags="${antflags} -Dadmin.precompile.notrequired=true"
+ fi
+ if ! use examples; then
+ antflags="${antflags} -Dexamples.build.notrequired=true"
+ antflags="${antflags} -Dexamples.precompile.notrequired=true"
+ fi
+ antflags="${antflags} -Djasper.home=${S}/jasper"
+ if ! use java5; then
+ antflags="${antflags} -Dactivation.jar=$(java-pkg_getjars sun-jaf)"
+ antflags="${antflags} -Djmx.jar=$(java-pkg_getjar mx4j-core-3.0 mx4j.jar)"
+ antflags="${antflags} -Djmx-remote.jar=$(java-pkg_getjar mx4j-core-3.0 mx4j-rjmx.jar)"
+ antflags="${antflags} -DxercesImpl.jar=$(java-pkg_getjar xerces-2 xercesImpl.jar)"
+ antflags="${antflags} -Dxml-apis.jar=$(java-pkg_getjar xml-commons-external-1.3 xml-apis.jar)"
+ fi
+
+ eant ${antflags}
+}
+
+src_install() {
+ cd "${S}"/build/build
+
+ # init.d, conf.d
+ newinitd "${FILESDIR}"/${SLOT}/tomcat.init.2 ${TOMCAT_NAME}
+ newconfd "${FILESDIR}"/${SLOT}/tomcat.conf.2 ${TOMCAT_NAME}
+
+ # create dir structure
+ diropts -m755 -o tomcat -g tomcat
+ dodir /usr/share/${TOMCAT_NAME}
+ keepdir /var/log/${TOMCAT_NAME}/
+ keepdir /var/tmp/${TOMCAT_NAME}/
+ keepdir /var/run/${TOMCAT_NAME}/
+
+ local CATALINA_BASE=/var/lib/${TOMCAT_NAME}/
+ dodir ${CATALINA_BASE}
+ keepdir ${CATALINA_BASE}/shared/lib
+ keepdir ${CATALINA_BASE}/shared/classes
+
+ keepdir /usr/share/${TOMCAT_NAME}/common/lib
+
+ dodir /etc/${TOMCAT_NAME}
+ fperms 750 /etc/${TOMCAT_NAME}
+
+ diropts -m0755
+
+ # we don't need dos scripts
+ rm -f bin/*.bat
+
+ # copy the manager and admin context's to the right position
+ mkdir -p conf/Catalina/localhost
+ if use admin; then
+ cp "${S}"/container/webapps/admin/admin.xml \
+ conf/Catalina/localhost
+ fi
+ cp "${S}"/container/webapps/manager/manager.xml \
+ conf/Catalina/localhost
+
+ # make the jars available via java-pkg_getjar and jar-from, etc
+ base=$(pwd)
+ libdirs="common/lib server/lib"
+ for dir in ${libdirs}
+ do
+ cd "${dir}"
+
+ for jar in *.jar;
+ do
+ # replace the file with a symlink
+ if [ ! -L ${jar} ]; then
+ java-pkg_dojar ${jar}
+ rm -f ${jar}
+ ln -s ${DESTTREE}/share/${TOMCAT_NAME}/lib/${jar} ${jar}
+ fi
+ done
+
+ cd ${base}
+ done
+
+ # replace a packed struts.jar
+ if use admin; then
+ cd server/webapps/admin/WEB-INF/lib
+ rm -f struts.jar
+ java-pkg_jar-from struts-1.2 struts.jar
+ cd ${base}
+ else
+ rm -fR server/webapps/admin
+ fi
+
+ cd server/webapps/manager/WEB-INF/lib
+ java-pkg_jar-from commons-fileupload
+ java-pkg_jar-from commons-io-1
+ cd ${base}
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -e s:SHUTDOWN:${randpw}: -i conf/{server,server-minimal}.xml
+
+ # copy over the directories
+ chown -R tomcat:tomcat webapps/* conf/*
+ cp -pR conf/* "${D}"/etc/${TOMCAT_NAME} || die "failed to copy conf"
+ cp -HR bin common server "${D}"/usr/share/${TOMCAT_NAME} || die "failed to copy"
+
+ # replace catalina.policy with gentoo specific one bug #176701
+ cp "${FILESDIR}"/${SLOT}/catalina.policy "${D}"/etc/${TOMCAT_NAME} || die "failed to replace catalina.policy"
+
+ keepdir ${WEBAPPS_DIR}
+ set_webapps_perms "${D}"/${WEBAPPS_DIR}
+
+ # Copy over webapps, some controlled by use flags
+ cp -p ../RELEASE-NOTES webapps/ROOT/RELEASE-NOTES.txt
+ cp -pr webapps/ROOT "${D}"${CATALINA_BASE}/webapps
+ if use doc; then
+ cp -pr webapps/tomcat-docs "${D}"${CATALINA_BASE}/webapps
+ fi
+ if use examples; then
+ cp -pr webapps/{jsp-examples,servlets-examples,webdav} \
+ "${D}"${CATALINA_BASE}/webapps
+ fi
+
+ # symlink the directories to make CATALINA_BASE possible
+ dosym /etc/${TOMCAT_NAME} ${CATALINA_BASE}/conf
+ dosym /var/log/${TOMCAT_NAME} ${CATALINA_BASE}/logs
+ dosym /var/tmp/${TOMCAT_NAME} ${CATALINA_BASE}/temp
+ dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
+
+ dodoc "${S}"/build/{RELEASE-NOTES,RUNNING.txt}
+ fperms 640 /etc/${TOMCAT_NAME}/tomcat-users.xml
+}
+
+pkg_postinst() {
+ #due to previous ebuild bloopers, make sure everything is correct
+ chown root:root /etc/init.d/${TOMCAT_NAME}
+ chown root:root /etc/conf.d/${TOMCAT_NAME}
+
+ elog
+ elog " This ebuild implements a new filesystem layout for tomcat"
+ elog " please read http://www.gentoo.org/proj/en/java/tomcat-guide.xml"
+ elog " for more information!."
+ elog
+ ewarn "naming-factory-dbcp.jar is not built at this time. Please fetch"
+ ewarn "jar from upstream binary if you need it. Gentoo Bug # 144276"
+ elog
+ elog " Please file any bugs at http://bugs.gentoo.org/ or else it"
+ elog " may not get seen. Thank you."
+ elog
+}
+
+#helpers
+set_webapps_perms() {
+ chown tomcat:tomcat ${1} || die "Failed to change owner off ${1}."
+ chmod 750 ${1} || die "Failed to change permissions off ${1}."
+}
+
+pkg_config() {
+ # Better suggestions are welcome
+ local currentdir="$(getent passwd tomcat | gawk -F':' '{ print $6 }')"
+
+ elog "The default home directory for Tomcat is /dev/null."
+ elog "You need to change it if your applications needs it to"
+ elog "be an actual directory. Current home directory:"
+ elog "${currentdir}"
+ elog ""
+ elog "Do you want to change it [yes/no]?"
+
+ local answer
+ read answer
+
+ if [[ "${answer}" == "yes" ]]; then
+ elog ""
+ elog "Suggestions:"
+ elog "${WEBAPPS_DIR}"
+ elog ""
+ elog "If you want to suggest a directory, file a bug to"
+ elog "http://bugs.gentoo.org"
+ elog ""
+ elog "Enter home directory:"
+
+ local homedir
+ read homedir
+
+ elog ""
+ elog "Setting home directory to: ${homedir}"
+
+ /usr/sbin/usermod -d"${homedir}" tomcat
+
+ elog "You can run emerge --config =${PF}"
+ elog "again to change to homedir"
+ elog "at any time."
+ fi
+}
diff --git a/www-servers/tomcat/tomcat-6.0.18-r2.ebuild b/www-servers/tomcat/tomcat-6.0.18-r2.ebuild
new file mode 100644
index 000000000000..f56cd99b9633
--- /dev/null
+++ b/www-servers/tomcat/tomcat-6.0.18-r2.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.18-r2.ebuild,v 1.1 2008/12/19 20:48:47 ali_bush Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc source"
+WANT_ANT_TASKS="ant-trax"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Tomcat Servlet-2.5/JSP-2.1 Container"
+
+MY_P="apache-${P}-src"
+SLOT="6"
+SRC_URI="mirror://apache/${PN}/${PN}-6/v${PV/_/-}/src/${MY_P}.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+LICENSE="Apache-2.0"
+
+IUSE="examples test"
+
+COMMON_DEPEND="dev-java/eclipse-ecj:3.3
+ dev-java/ant-eclipse-ecj:3.3
+ >=dev-java/commons-daemon-1.0.1
+ >=dev-java/commons-dbcp-1.2.1
+ >=dev-java/commons-logging-1.1
+ >=dev-java/commons-pool-1.2
+ ~dev-java/tomcat-servlet-api-${PV}
+ examples? ( dev-java/jakarta-jstl )"
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/ant-core
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ test? ( =dev-java/junit-3.8* )"
+
+S=${WORKDIR}/${MY_P}
+
+TOMCAT_NAME="${PN}-${SLOT}"
+TOMCAT_HOME="/usr/share/${TOMCAT_NAME}"
+WEBAPPS_DIR="/var/lib/${TOMCAT_NAME}/webapps"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ enewgroup tomcat 265
+ enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${SLOT}/build-xml.patch"
+
+ cd webapps/examples/WEB-INF/lib/
+ rm -v *.jar
+}
+
+src_compile(){
+ # Fix for bug # 178980
+ if use amd64 && [[ "${GENTOO_VM}" = "sun-jdk-1.5" ]] ; then
+ java-pkg_force-compiler ecj-3.3
+ fi
+
+ local antflags="build-jasper-jdt deploy -Dbase.path=${T}"
+ antflags="${antflags} -Dcompile.debug=false"
+ if ! use doc; then
+ antflags="${antflags} -Dnobuild.docs=true"
+ fi
+ antflags="${antflags} -Dant.jar=$(java-pkg_getjar ant-core ant.jar)"
+ antflags="${antflags} -Dcommons-daemon.jar=$(java-pkg_getjar commons-daemon commons-daemon.jar)"
+ antflags="${antflags} -Djdt.jar=$(java-pkg_getjar eclipse-ecj-3.3 ecj.jar)"
+ antflags="${antflags} -Djsp-api.jar=$(java-pkg_getjar tomcat-servlet-api-2.5 jsp-api.jar)"
+ antflags="${antflags} -Dservlet-api.jar=$(java-pkg_getjar tomcat-servlet-api-2.5 servlet-api.jar)"
+ antflags="${antflags} -Dversion=${PV} -Dversion.number=${PV}"
+ eant ${antflags}
+}
+
+src_install() {
+ cd "${S}/output/build/bin"
+ rm -f *.bat commons-daemon.jar
+ java-pkg_jar-from commons-daemon
+ chmod 755 *.sh
+
+ # register jars per bug #171496
+ cd "${S}/output/build/lib/"
+ for jar in *.jar; do
+ java-pkg_dojar ${jar}
+ done
+
+ local CATALINA_BASE=/var/lib/${TOMCAT_NAME}/
+
+ # init.d, conf.d
+ newinitd "${FILESDIR}"/${SLOT}/tomcat.init ${TOMCAT_NAME}
+ newconfd "${FILESDIR}"/${SLOT}/tomcat.conf ${TOMCAT_NAME}
+
+ # create dir structure
+ dodir /usr/share/${TOMCAT_NAME}
+
+ diropts -m750 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}
+ keepdir ${WEBAPPS_DIR}
+
+ diropts -m755 -o tomcat -g tomcat
+ dodir ${CATALINA_BASE}
+
+ diropts -m775 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}/Catalina/localhost
+ keepdir /var/log/${TOMCAT_NAME}/
+ keepdir /var/run/${TOMCAT_NAME}/
+ keepdir /var/tmp/${TOMCAT_NAME}/
+
+ cd "${S}"
+ # fix context's so webapps will be deployed
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/host-manager" a:' "${S}"/webapps/host-manager/META-INF/context.xml
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/manager" a:' "${S}"/webapps/manager/META-INF/context.xml
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -e s:SHUTDOWN:${randpw}: -i conf/server.xml
+
+ # copy over the directories
+ chown -R tomcat:tomcat webapps/* conf/*
+ cp -pR conf/* "${D}"/etc/${TOMCAT_NAME} || die "failed to copy conf"
+ cp -pPR output/build/bin "${D}"/usr/share/${TOMCAT_NAME} \
+ || die "failed to copy"
+
+ # replace catalina.policy with gentoo specific one bug #176701
+# cp ${FILESDIR}/${SLOT}/catalina.policy "${D}"/etc/${TOMCAT_NAME} \
+# || die "failed to replace catalina.policy"
+
+ cp "${T}"/tomcat6-deps/jdt/jasper-jdt.jar "${D}"/usr/share/${TOMCAT_NAME}/lib \
+ || die "failed to copy"
+
+ cd "${D}/usr/share/${TOMCAT_NAME}/lib"
+ java-pkg_jar-from tomcat-servlet-api-2.5
+
+ cd "${S}"
+
+ # Copy over webapps, some controlled by use flags
+ cp -p RELEASE-NOTES webapps/ROOT/RELEASE-NOTES.txt
+ cp -pr webapps/ROOT "${D}"${CATALINA_BASE}/webapps
+
+ diropts -m755 -o tomcat -g tomcat
+ dodir ${TOMCAT_HOME}/webapps
+ cp -pr webapps/host-manager "${D}"${TOMCAT_HOME}/webapps
+ cp -pr webapps/manager "${D}"${TOMCAT_HOME}/webapps
+
+ if use doc; then
+ cp -pr output/build/webapps/docs "${D}"${CATALINA_BASE}/webapps
+ fi
+ if use examples; then
+ cd output/build/webapps/examples/WEB-INF/lib
+ java-pkg_jar-from jakarta-jstl jstl.jar
+ java-pkg_jar-from jakarta-jstl standard.jar
+ cd "${S}"
+ cp -pPr output/build/webapps/examples "${D}"${CATALINA_BASE}/webapps
+ fi
+
+ # symlink the directories to make CATALINA_BASE possible
+ dosym /etc/${TOMCAT_NAME} ${CATALINA_BASE}/conf
+ dosym /var/log/${TOMCAT_NAME} ${CATALINA_BASE}/logs
+ dosym /var/tmp/${TOMCAT_NAME} ${CATALINA_BASE}/temp
+ dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
+
+ # link the manager's context to the right position
+ dosym ${TOMCAT_HOME}/webapps/host-manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/host-manager.xml
+ dosym ${TOMCAT_HOME}/webapps/manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/manager.xml
+
+ dodoc "${S}"/{RELEASE-NOTES,RUNNING.txt}
+ fperms 640 /etc/${TOMCAT_NAME}/tomcat-users.xml
+}
+
+pkg_postinst() {
+ ewarn "Changing ownership recursively on /etc/${TOMCAT_NAME}"
+ # temp fix for bug #176097
+ chown -fR tomcat:tomcat /etc/${TOMCAT_NAME}
+ ewarn "Owner ship changed to tomcat:tomcat. Temp hack/fix."
+
+ elog
+ elog " This ebuild implements a FHS compliant layout for tomcat"
+ elog " Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml"
+ elog " for more information."
+ elog
+ ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+ ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+ elog
+ ewarn "The manager webapps have known exploits, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2450"
+ if use examples ; then
+ elog
+ ewarn "The examples webapp has a known exploit, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2449"
+ fi
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}