summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-04-04 12:24:20 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-04-04 12:24:20 +0000
commit4749362f1633a6b5bddf570ae6d50976ae343d26 (patch)
tree222faf757477830cfea55b329748432edc5e4ee7 /www-servers/thttpd
parentadd another patch tto mksedscript to fix bug #410695 (diff)
downloadgentoo-2-4749362f1633a6b5bddf570ae6d50976ae343d26.tar.gz
gentoo-2-4749362f1633a6b5bddf570ae6d50976ae343d26.tar.bz2
gentoo-2-4749362f1633a6b5bddf570ae6d50976ae343d26.zip
Version bump after I forked the code
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/thttpd')
-rw-r--r--www-servers/thttpd/ChangeLog7
-rw-r--r--www-servers/thttpd/thttpd-2.26.2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/www-servers/thttpd/ChangeLog b/www-servers/thttpd/ChangeLog
index 6bf4a9ee86cd..d7cd7a736990 100644
--- a/www-servers/thttpd/ChangeLog
+++ b/www-servers/thttpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/thttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.35 2012/03/24 02:59:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.36 2012/04/04 12:24:20 blueness Exp $
+
+*thttpd-2.26.2 (04 Apr 2012)
+
+ 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org> +thttpd-2.26.2.ebuild:
+ Version bump after I forked the code
*thttpd-2.25b-r9 (24 Mar 2012)
diff --git a/www-servers/thttpd/thttpd-2.26.2.ebuild b/www-servers/thttpd/thttpd-2.26.2.ebuild
new file mode 100644
index 000000000000..ea0fcafc1f22
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.26.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.26.2.ebuild,v 1.1 2012/04/04 12:24:20 blueness Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="s${P}"
+
+DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver."
+HOMEPAGE="http://opensource.dyc.edu/sthttpd"
+SRC_URI="http://opensource.dyc.edu/pub/sthttpd/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+THTTPD_USER=thttpd
+THTTPD_GROUP=thttpd
+THTTPD_DOCROOT="/var/www/localhost/htdocs"
+
+DOCS=( README TODO )
+
+pkg_setup() {
+ ebegin "Creating thttpd user and group"
+ enewgroup ${THTTPD_GROUP}
+ enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
+}
+
+src_configure() {
+ econf WEBDIR=${THTTPD_DOCROOT}
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}"/thttpd.init thttpd
+ newconfd "${FILESDIR}"/thttpd.confd thttpd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/thttpd.logrotate" thttpd
+
+ insinto /etc/thttpd
+ doins "${FILESDIR}"/thttpd.conf.sample
+}
+
+pkg_postinst() {
+ chown root:${THTTPD_GROUP} "${ROOT}/usr/sbin/makeweb" \
+ || die "Failed chown makeweb"
+ chmod 2751 "${ROOT}/usr/sbin/makeweb" \
+ || die "Failed chmod makeweb"
+ chmod 755 "${THTTPD_DOCROOT}/cgi-bin/printenv" \
+ || die "Failed chmod printenv"
+ elog "Adjust THTTPD_DOCROOT in /etc/conf.d/thttpd !"
+}