summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-08 18:14:47 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-08 18:14:47 +0000
commitb9b3c254b5026d9b7698e3a078a614af5c9bc17e (patch)
treea082149f1d4af7d910edc381e1cc11ed645c730a /www-servers/publicfile/publicfile-0.52.ebuild
parentStable on sparc wrt bug #58918. (Manifest recommit) (diff)
downloadgentoo-2-b9b3c254b5026d9b7698e3a078a614af5c9bc17e.tar.gz
gentoo-2-b9b3c254b5026d9b7698e3a078a614af5c9bc17e.tar.bz2
gentoo-2-b9b3c254b5026d9b7698e3a078a614af5c9bc17e.zip
Moved from net-www/publicfile to www-servers/publicfile.
Diffstat (limited to 'www-servers/publicfile/publicfile-0.52.ebuild')
-rw-r--r--www-servers/publicfile/publicfile-0.52.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/www-servers/publicfile/publicfile-0.52.ebuild b/www-servers/publicfile/publicfile-0.52.ebuild
new file mode 100644
index 000000000000..ac88c67b8132
--- /dev/null
+++ b/www-servers/publicfile/publicfile-0.52.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/publicfile/publicfile-0.52.ebuild,v 1.1 2004/08/08 18:14:47 stuart Exp $
+
+inherit eutils
+
+IUSE="selinux"
+S=${WORKDIR}/${P}
+DESCRIPTION="publish files through FTP and HTTP"
+SRC_URI="http://cr.yp.to/publicfile/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/publicfile.html"
+KEYWORDS="x86 ppc sparc"
+SLOT="0"
+
+LICENSE="as-is"
+
+RDEPEND=">=sys-apps/daemontools-0.70
+ >=sys-apps/ucspi-tcp-0.83
+ selinux? ( sec-policy/selinux-publicfile )"
+
+src_compile() {
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ echo "/usr" > conf-home
+
+ # fix for glibc-2.3.2 errno issue
+ mv error.h error.h.orig
+ sed -e 's|extern int errno;|#include <errno.h>|' <error.h.orig >error.h
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ftpd httpd
+ newexe configure publicfile-conf
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}
+
+pkg_preinst() {
+ enewgroup nofiles
+ enewuser ftp -1 /bin/false /home/public nofiles
+ enewuser ftplog -1 /bin/false /home/public nofiles
+}
+
+pkg_postinst() {
+ /usr/bin/publicfile-conf ftp ftplog /home/public `hostname`
+ echo
+ echo -e "\e[32;01m httpd and ftpd are serving out of /home/public.\033[0m"
+ echo -e "\e[32;01m remember to start the servers with:\033[0m"
+ echo -e "\e[32;01m ln -s /home/public/httpd /home/public/home/ftpd /service\033[0m"
+ echo
+}
+
+pkg_postrm() {
+ userdel ftplog
+}