summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-25 12:57:55 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-25 12:57:55 +0000
commited76c48ae4f0eefb6e231ba2f3d8f7d2e626d711 (patch)
tree0ee10062b40bdc24a151958de9ce74374f0222d6 /www-servers/nginx
parentStable on x86, bug #158836. (diff)
downloadgentoo-2-ed76c48ae4f0eefb6e231ba2f3d8f7d2e626d711.tar.gz
gentoo-2-ed76c48ae4f0eefb6e231ba2f3d8f7d2e626d711.tar.bz2
gentoo-2-ed76c48ae4f0eefb6e231ba2f3d8f7d2e626d711.zip
* bump
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.53
-rw-r--r--www-servers/nginx/nginx-0.5.5.ebuild86
3 files changed, 96 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 549f00c8bf39..75b7eac41c08 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.126 2006/12/17 18:23:21 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.127 2006/12/25 12:57:55 voxus Exp $
+
+*nginx-0.5.5 (25 Dec 2006)
+
+ 25 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.4.ebuild, -nginx-0.5.4-r1.ebuild, +nginx-0.5.5.ebuild:
+ Version bump.
*nginx-0.5.4-r1 (17 Dec 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.5 b/www-servers/nginx/files/digest-nginx-0.5.5
new file mode 100644
index 000000000000..77a2fc4470b3
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.5
@@ -0,0 +1,3 @@
+MD5 7a09077dae1700eb8f3717211b95318d nginx-0.5.5.tar.gz 443942
+RMD160 09a917a6b1f124a2a48247838738c8c74c4466a8 nginx-0.5.5.tar.gz 443942
+SHA256 e02abc19b42c75e80f29933cc916a09e7ef0fe16b3fdcbae7414725f86e14f36 nginx-0.5.5.tar.gz 443942
diff --git a/www-servers/nginx/nginx-0.5.5.ebuild b/www-servers/nginx/nginx-0.5.5.ebuild
new file mode 100644
index 000000000000..f5c7e0e0a105
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.5.ebuild,v 1.1 2006/12/25 12:57:55 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl status zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ cp ${FILESDIR}/nginx.conf-r3 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}