summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-10-17 15:39:49 +0000
committerAlex Legler <a3li@gentoo.org>2009-10-17 15:39:49 +0000
commit00dcbe319d8512d3db99ca6a0b3d5466703ef05a (patch)
tree1b847a77c4d448dba38a4d175cd45d1548049d53 /www-servers/gorg
parentbump (diff)
downloadgentoo-2-00dcbe319d8512d3db99ca6a0b3d5466703ef05a.tar.gz
gentoo-2-00dcbe319d8512d3db99ca6a0b3d5466703ef05a.tar.bz2
gentoo-2-00dcbe319d8512d3db99ca6a0b3d5466703ef05a.zip
Version bump, fixes caching, bug 289391
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/gorg')
-rw-r--r--www-servers/gorg/ChangeLog7
-rw-r--r--www-servers/gorg/gorg-0.6.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/www-servers/gorg/ChangeLog b/www-servers/gorg/ChangeLog
index 4ff613ec01df..2b98bca7f773 100644
--- a/www-servers/gorg/ChangeLog
+++ b/www-servers/gorg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/gorg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/ChangeLog,v 1.21 2009/08/24 16:43:06 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/ChangeLog,v 1.22 2009/10/17 15:39:49 a3li Exp $
+
+*gorg-0.6.4 (17 Oct 2009)
+
+ 17 Oct 2009; Alex Legler <a3li@gentoo.org> +gorg-0.6.4.ebuild:
+ Version bump, fixes caching, bug 289391
*gorg-0.6.3-r3 (24 Aug 2009)
diff --git a/www-servers/gorg/gorg-0.6.4.ebuild b/www-servers/gorg/gorg-0.6.4.ebuild
new file mode 100644
index 000000000000..cdb5a11bf561
--- /dev/null
+++ b/www-servers/gorg/gorg-0.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/gorg-0.6.4.ebuild,v 1.1 2009/10/17 15:39:49 a3li Exp $
+
+EAPI=2
+
+inherit ruby eutils
+
+DESCRIPTION="Back-end XSLT processor for an XML-based web site"
+HOMEPAGE="http://gentoo.neysx.org/mystuff/gorg/gorg.xml"
+SRC_URI="http://gentoo.neysx.org/mystuff/gorg/${P}.tgz"
+IUSE="apache2 fastcgi mysql"
+
+SLOT="0"
+USE_RUBY="ruby18"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/ruby
+ >=dev-libs/libxml2-2.6.16
+ >=dev-libs/libxslt-1.1.12"
+RDEPEND="${DEPEND}
+ mysql? ( >=dev-ruby/ruby-dbi-0.0.21[mysql] )
+ apache2? ( www-servers/apache
+ fastcgi? ( www-apache/mod_fcgid ) )
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.5-r1 )"
+
+pkg_setup() {
+ enewgroup gorg
+ enewuser gorg -1 -1 -1 gorg
+}
+
+src_install() {
+ ruby_einstall
+
+ # install doesn't seem to chmod these correctly, forcing it here
+ SITE_LIB_DIR=`$RUBY -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ chmod +x "${D}"/${SITE_LIB_DIR}/gorg/cgi-bin/*.cgi
+ chmod +x "${D}"/${SITE_LIB_DIR}/gorg/fcgi-bin/*.fcgi
+
+ keepdir /etc/gorg; insinto /etc/gorg ; doins etc/gorg/*
+ diropts -m0770 -o gorg -g gorg; keepdir /var/cache/gorg
+
+ dodoc Changelog README
+}