summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-04-24 20:12:46 +0000
committerJim Ramsay <lack@gentoo.org>2012-04-24 20:12:46 +0000
commitd73e990717c19f5f70e251857ce8da20b1593c6e (patch)
tree68667e6d09b72c008d8d453302b1884955791d73 /www-plugins
parentVersion bump to Thunderbird 12. (diff)
downloadgentoo-2-d73e990717c19f5f70e251857ce8da20b1593c6e.tar.gz
gentoo-2-d73e990717c19f5f70e251857ce8da20b1593c6e.tar.bz2
gentoo-2-d73e990717c19f5f70e251857ce8da20b1593c6e.zip
On darkside's suggestion, providing a USE flag (IUSE=+sse2check) that can be turned off to allow binpkg users to override this check (or at least reduce its fatality)
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/ChangeLog8
-rw-r--r--www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild26
-rw-r--r--www-plugins/adobe-flash/metadata.xml10
3 files changed, 33 insertions, 11 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 6caee9024f5b..9862887e827e 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.126 2012/04/24 15:29:29 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.127 2012/04/24 20:12:46 lack Exp $
+
+ 24 Apr 2012; Jim Ramsay <jim_ramsay@gentoo.org>
+ adobe-flash-11.2.202.228.ebuild, metadata.xml:
+ On darkside's suggestion, providing a USE flag (IUSE=+sse2check) that can be
+ turned off to allow binpkg users to override this check (or at least reduce
+ its fatality)
24 Apr 2012; Jim Ramsay <jim_ramsay@gentoo.org>
adobe-flash-11.2.202.228.ebuild:
diff --git a/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild b/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
index 3c6c53848975..79aceb5f34d0 100644
--- a/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild,v 1.4 2012/04/24 15:29:29 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild,v 1.5 2012/04/24 20:12:46 lack Exp $
EAPI=4
inherit nsplugins multilib toolchain-funcs versionator
@@ -18,7 +18,7 @@ amd64? (
!multilib? ( ${MY_64B_URI} )
)"
HOMEPAGE="http://www.adobe.com/products/flashplayer.html"
-IUSE="multilib -32bit +64bit vdpau kde"
+IUSE="multilib -32bit +64bit vdpau kde +sse2check"
SLOT="0"
KEYWORDS="-* amd64 x86"
@@ -63,16 +63,26 @@ any_cpu_missing_flag() {
}
pkg_pretend() {
- if any_cpu_missing_flag 'sse2'; then
+ if any_cpu_missing_flag 'BAADsse2'; then
eerror "This version of adobe-flash requires a CPU that supports the"
eerror "SSE2 instruction set, and at least one of your CPUs does not"
eerror "support this feature."
eerror ""
- eerror "You should mask this version and use adobe-flash-10.3.* instead."
- eerror "To do so, add the following line to your package.mask file:"
- eerror " =${CATEGORY}/${P}"
- eerror ""
- die "${P} requires CPU with SSE2"
+ if use sse2check; then
+ eerror "You should mask this version and use adobe-flash-10.3.* instead."
+ eerror "To do so, add the following line to your package.mask file:"
+ eerror " =${CATEGORY}/${P}"
+ eerror ""
+ eerror "Or if you are trying to build a binary package for another host"
+ eerror "that does support SSE2 instructions, you may override this"
+ eerror "check by setting USE=\"-sse2check\""
+ eerror ""
+ die "${P} requires CPU with SSE2"
+ else
+ eerror "Continuing anyway due to USE=\"-sse2check\", but be aware that flash"
+ eerror "will not function unless all of the CPUs on the system where it"
+ eerror "is installed support the SSE2 instruction set."
+ fi
fi
}
diff --git a/www-plugins/adobe-flash/metadata.xml b/www-plugins/adobe-flash/metadata.xml
index 36a43e10bea0..b6c2d857e1f6 100644
--- a/www-plugins/adobe-flash/metadata.xml
+++ b/www-plugins/adobe-flash/metadata.xml
@@ -15,8 +15,14 @@
<flag name='vdpau'>Enables VDPAU support to offload video processing
(32-bit flash player only)</flag>
- <!-- www-plugins/adobe-flash-10.3 has a KDE KCM thingy -->
+ <!-- www-plugins/adobe-flash-10.3 and later has a KDE KCM thingy -->
<flag name='kde'>Enables a KCM plugin for configuring flash player
- preferences (32-bit KDE4 only)</flag>
+ preferences</flag>
+
+ <!-- www-plugins/adobe-flash-11.2 requries SSE2 instructions (Bug #410547) -->
+ <flag name='sse2check'>This flag, enabled by default, will check for sse2
+ support on your cpu and die if not found. If you are remote-building
+ this package, you can disable this flag but you have been
+ warned</flag>
</use>
</pkgmetadata>