summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-05-31 00:47:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-05-31 00:47:11 +0000
commit7f26b6e6a1c545ed0bae07b7ec8b2ea78bf7d1b9 (patch)
tree604defce1dd5132e052a76807875d3a86ad4a32e /www-plugins
parentVersion bump. This release fixes parallel make issues, bug 271240. (diff)
downloadgentoo-2-7f26b6e6a1c545ed0bae07b7ec8b2ea78bf7d1b9.tar.gz
gentoo-2-7f26b6e6a1c545ed0bae07b7ec8b2ea78bf7d1b9.tar.bz2
gentoo-2-7f26b6e6a1c545ed0bae07b7ec8b2ea78bf7d1b9.zip
Add patch from en.ABCD fixing build with glibc 2.10. (bug #271843)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/mplayerplug-in/ChangeLog6
-rw-r--r--www-plugins/mplayerplug-in/files/mplayerplug-in-3.55-glibc210.patch48
-rw-r--r--www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild3
3 files changed, 55 insertions, 2 deletions
diff --git a/www-plugins/mplayerplug-in/ChangeLog b/www-plugins/mplayerplug-in/ChangeLog
index e5ebacf96412..84a165362ff1 100644
--- a/www-plugins/mplayerplug-in/ChangeLog
+++ b/www-plugins/mplayerplug-in/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/mplayerplug-in
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/ChangeLog,v 1.2 2009/05/29 21:04:47 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/ChangeLog,v 1.3 2009/05/31 00:47:07 dirtyepic Exp $
+
+ 31 May 2009; Ryan Hill <dirtyepic@gentoo.org>
+ mplayerplug-in-3.55-r1.ebuild, +files/mplayerplug-in-3.55-glibc210.patch:
+ Add patch from en.ABCD fixing build with glibc 2.10. (bug #271843)
*mplayerplug-in-3.55-r1 (29 May 2009)
diff --git a/www-plugins/mplayerplug-in/files/mplayerplug-in-3.55-glibc210.patch b/www-plugins/mplayerplug-in/files/mplayerplug-in-3.55-glibc210.patch
new file mode 100644
index 000000000000..54a1a791bb73
--- /dev/null
+++ b/www-plugins/mplayerplug-in/files/mplayerplug-in-3.55-glibc210.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/show_bug.cgi?id=271843
+
+--- mplayerplug-in-3.55-orig/Source/plugin-list.cpp
++++ mplayerplug-in-3.55/Source/plugin-list.cpp
+@@ -132,9 +132,9 @@ void insert_area(Node * parent, char *ta
+
+ void find_area_tags(const char *smilbuffer, Node * parent)
+ {
+- char *startarea;
+- char *endvideo;
+- char *start;
++ const char *startarea;
++ const char *endvideo;
++ const char *start;
+
+ int tagtime = 0;
+ char tagtarget[128];
+--- mplayerplug-in-3.55-orig/Source/plugin-setup.h
++++ mplayerplug-in-3.55/Source/plugin-setup.h
+@@ -174,7 +174,7 @@ char *getURLHostname(char *url);
+ char *getURLFilename(const char *url);
+ int isMms(char *url, int nomediacache);
+ void mmsToHttp(char *dest, char *src);
+-int sendCommand(nsPluginInstance * instance, char *command);
++int sendCommand(nsPluginInstance * instance, const char *command);
+ int URLcmp(const char *url1, const char *url2);
+ extern void remove_quotes(char *url);
+ void killmplayer(nsPluginInstance * instance);
+--- mplayerplug-in-3.55-orig/Source/plugin-support.cpp
++++ mplayerplug-in-3.55/Source/plugin-support.cpp
+@@ -109,7 +109,7 @@ char *getURLFilename(const char *url)
+ {
+
+ char *filename;
+- char *tmp;
++ const char *tmp;
+ int len;
+
+ if (DEBUG > 1)
+@@ -454,7 +454,7 @@ void remove_quotes(char *url)
+ // in cleanup routines (like destroyCB and shut), when we know that
+ // the player thread is not running, it is safe to call without locking
+
+-int sendCommand(nsPluginInstance * instance, char *command)
++int sendCommand(nsPluginInstance * instance, const char *command)
+ {
+ int retval;
+ char buffer[1024];
diff --git a/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild b/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
index bf1c49bdb69d..b7235d5bd56d 100644
--- a/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
+++ b/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild,v 1.1 2009/05/29 21:04:47 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild,v 1.2 2009/05/31 00:47:07 dirtyepic Exp $
inherit eutils multilib autotools flag-o-matic
@@ -48,6 +48,7 @@ src_unpack() {
#epatch "${FILESDIR}/${PN}_xulrunner-1.9.patch"
#epatch "${FILESDIR}/${PN}-3.50-seamonkey.patch"
epatch "${FILESDIR}/${PN}-min-cache-size.patch"
+ epatch "${FILESDIR}"/${P}-glibc210.patch
eautoreconf
}