summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-04-24 15:29:29 +0000
committerJim Ramsay <lack@gentoo.org>2012-04-24 15:29:29 +0000
commit0a3bd925f07029128e4d7e00e0c04769dabf3f88 (patch)
tree6143a45e206c0e7e14f863483bd87fe5a4b4f5a6 /www-plugins
parentClean up old versions (diff)
downloadgentoo-2-0a3bd925f07029128e4d7e00e0c04769dabf3f88.tar.gz
gentoo-2-0a3bd925f07029128e4d7e00e0c04769dabf3f88.tar.bz2
gentoo-2-0a3bd925f07029128e4d7e00e0c04769dabf3f88.zip
Bug #410547: Fail pkg_pretend if any CPU on the local machine does not support SSE2, and recommend falling back to 10.3 instead
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/ChangeLog7
-rw-r--r--www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild24
2 files changed, 27 insertions, 4 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 62bca1bd6e01..6caee9024f5b 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.125 2012/04/24 15:08:09 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.126 2012/04/24 15:29:29 lack Exp $
+
+ 24 Apr 2012; Jim Ramsay <jim_ramsay@gentoo.org>
+ adobe-flash-11.2.202.228.ebuild:
+ Bug #410547: Fail pkg_pretend if any CPU on the local machine does not
+ support SSE2, and recommend falling back to 10.3 instead
24 Apr 2012; Jim Ramsay <jim_ramsay@gentoo.org>
-adobe-flash-11.0.1.152.ebuild, -adobe-flash-11.1.102.55.ebuild,
diff --git a/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild b/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
index 7cbd25f69297..3c6c53848975 100644
--- a/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild,v 1.3 2012/04/05 21:14:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-11.2.202.228.ebuild,v 1.4 2012/04/24 15:29:29 lack Exp $
EAPI=4
inherit nsplugins multilib toolchain-funcs versionator
@@ -57,6 +57,25 @@ INSTALL_BASE="opt/Adobe/flash-player"
# Ignore QA warnings in these closed-source binaries, since we can't fix them:
QA_PREBUILT="opt/*"
+any_cpu_missing_flag() {
+ local value=$1
+ grep '^flags' /proc/cpuinfo | grep -qv "$value"
+}
+
+pkg_pretend() {
+ if any_cpu_missing_flag 'sse2'; then
+ eerror "This version of adobe-flash requires a CPU that supports the"
+ eerror "SSE2 instruction set, and at least one of your CPUs does not"
+ eerror "support this feature."
+ eerror ""
+ eerror "You should mask this version and use adobe-flash-10.3.* instead."
+ eerror "To do so, add the following line to your package.mask file:"
+ eerror " =${CATEGORY}/${P}"
+ eerror ""
+ die "${P} requires CPU with SSE2"
+ fi
+}
+
pkg_setup() {
if use x86; then
export native_install=1
@@ -84,8 +103,7 @@ pkg_setup() {
unset need_lahf_wrapper
if [[ $native_install ]]; then
# 64bit flash requires the 'lahf' instruction (bug #268336)
- # Also, check if *any* of the processors are affected (bug #286159)
- if grep '^flags' /proc/cpuinfo | grep -qv 'lahf_lm'; then
+ if any_cpu_missing_flag 'lahf_lm'; then
export need_lahf_wrapper=1
fi
fi