summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-28 17:43:32 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-28 17:43:32 +0000
commit854989585844114c6ea048b732b065c1ee558765 (patch)
tree530dd78f63bf6f25f3ee678c1314f984543f73b4 /www-misc
parentInstall documentation in the proper directory, bug #296110 (diff)
downloadgentoo-2-854989585844114c6ea048b732b065c1ee558765.tar.gz
gentoo-2-854989585844114c6ea048b732b065c1ee558765.tar.bz2
gentoo-2-854989585844114c6ea048b732b065c1ee558765.zip
Respect LDFLAGS (bug #335049), CC, CFLAGS. Fix dodoc path.
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/bookmarksync/ChangeLog8
-rw-r--r--www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/www-misc/bookmarksync/ChangeLog b/www-misc/bookmarksync/ChangeLog
index d0f3cf1df58f..71b3c3292ab7 100644
--- a/www-misc/bookmarksync/ChangeLog
+++ b/www-misc/bookmarksync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/bookmarksync
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/bookmarksync/ChangeLog,v 1.11 2010/07/20 18:13:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/bookmarksync/ChangeLog,v 1.12 2010/09/28 17:43:32 jer Exp $
+
+*bookmarksync-0.3.4-r2 (28 Sep 2010)
+
+ 28 Sep 2010; Jeroen Roovers <jer@gentoo.org>
+ +bookmarksync-0.3.4-r2.ebuild:
+ Respect LDFLAGS (bug #335049), CC, CFLAGS. Fix dodoc path.
20 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
-bookmarksync-0.3.1.ebuild, -bookmarksync-0.3.2.ebuild,
diff --git a/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..1bb80fed6ee1
--- /dev/null
+++ b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild,v 1.1 2010/09/28 17:43:32 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bookmarksync synchronizes various browser bookmark files"
+HOMEPAGE="http://sourceforge.net/projects/booksync/"
+SRC_URI="mirror://sourceforge/booksync/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+SLOT="0"
+
+IUSE="perl"
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|g++|$(CXX) $(CFLAGS)|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ tc-export CXX
+}
+
+src_install () {
+ dobin bookmarksync
+ if use perl ; then
+ dobin tools/bookmarksync.pl
+ dodoc tools/README.tools
+ fi
+ dodoc README TODO DEVELOPERS
+}
+
+pkg_postinst () {
+ use perl && ewarn "You will need to modify bookmarksync.pl before use"
+}