summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-24 17:08:35 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-24 17:08:35 +0000
commitd66a66afb4d7a76463e5e6d2a0b68c04078194aa (patch)
tree6a57af8d78b55d0723eb2080b710084c070cc6e8 /www-client
parentVersion bump (diff)
downloadgentoo-2-d66a66afb4d7a76463e5e6d2a0b68c04078194aa.tar.gz
gentoo-2-d66a66afb4d7a76463e5e6d2a0b68c04078194aa.tar.bz2
gentoo-2-d66a66afb4d7a76463e5e6d2a0b68c04078194aa.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-firefox/ChangeLog9
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-2.0.0.17.ebuild319
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-3.0.2.ebuild310
3 files changed, 637 insertions, 1 deletions
diff --git a/www-client/mozilla-firefox/ChangeLog b/www-client/mozilla-firefox/ChangeLog
index 420bd253407f..f7ffc4f5c4c6 100644
--- a/www-client/mozilla-firefox/ChangeLog
+++ b/www-client/mozilla-firefox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/mozilla-firefox
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.439 2008/09/09 15:51:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.440 2008/09/24 17:08:35 armin76 Exp $
+
+*mozilla-firefox-3.0.2 (24 Sep 2008)
+*mozilla-firefox-2.0.0.17 (24 Sep 2008)
+
+ 24 Sep 2008; Raúl Porcel <armin76@gentoo.org>
+ +mozilla-firefox-2.0.0.17.ebuild, +mozilla-firefox-3.0.2.ebuild:
+ Version bump
09 Sep 2008; Raúl Porcel <armin76@gentoo.org>
mozilla-firefox-3.0.1.ebuild:
diff --git a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.17.ebuild b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.17.ebuild
new file mode 100644
index 000000000000..089eaf71eb11
--- /dev/null
+++ b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.17.ebuild
@@ -0,0 +1,319 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.0.17.ebuild,v 1.1 2008/09/24 17:08:35 armin76 Exp $
+
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib fdo-mime mozextension autotools
+
+PATCH="${PN}-2.0.0.15-patches-0.1"
+LANGS="af ar be bg ca cs da de el en-GB en-US es-AR es-ES eu fi fr fy-NL ga-IE gu-IN he hu it ja ka ko ku lt mk mn nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru sk sl sv-SE tr uk zh-CN zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
+
+DESCRIPTION="Firefox Web Browser"
+HOMEPAGE="http://www.mozilla.com/firefox"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="java mozdevelop bindist xforms restrict-javascript filepicker iceweasel"
+
+MOZ_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}"
+SRC_URI="${MOZ_URI}/source/firefox-${PV}-source.tar.bz2
+ mirror://gentoo/${PATCH}.tar.bz2
+ iceweasel? ( mirror://gentoo/iceweasel-icons-2.0.0.11.tar.bz2 )"
+
+# These are in
+#
+# http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/xpi/
+#
+# for i in $LANGS $SHORTLANGS; do wget $i.xpi -O ${P}-$i.xpi; done
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+RDEPEND="java? ( virtual/jre )
+ >=www-client/mozilla-launcher-1.55
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.11.8
+ >=dev-libs/nspr-4.6.8"
+
+DEPEND="${RDEPEND}
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+PDEPEND="restrict-javascript? ( x11-plugins/noscript )"
+
+S="${WORKDIR}/mozilla"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=browser
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
+ done
+}
+
+pkg_setup(){
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Cairo is not built with X useflag."
+ eerror "Please add 'X' to your USE flags, and re-emerge cairo."
+ die "Cairo needs X"
+ fi
+
+ if ! built_with_use --missing true x11-libs/pango X; then
+ eerror "Pango is not built with X useflag."
+ eerror "Please add 'X' to your USE flags, and re-emerge pango."
+ die "Pango needs X"
+ fi
+
+ if ! use bindist && ! use iceweasel; then
+ elog "You are enabling official branding. You may not redistribute this build"
+ elog "to any users on your network or the internet. Doing so puts yourself into"
+ elog "a legal problem with Mozilla Foundation"
+ elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
+
+ fi
+
+ use moznopango && warn_mozilla_launcher_stub
+}
+
+src_unpack() {
+ unpack firefox-${PV}-source.tar.bz2 ${PATCH}.tar.bz2
+
+ if use iceweasel; then
+ unpack iceweasel-icons-2.0.0.11.tar.bz2
+
+ cp -r iceweaselicons/browser mozilla/
+ fi
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+
+ # Apply our patches
+ cd "${S}" || die "cd failed"
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patch
+
+ if use filepicker; then
+ epatch "${FILESDIR}"/mozilla-filepicker.patch
+ fi
+
+ if use iceweasel; then
+ sed -i -e "s|Bon Echo|Iceweasel|" browser/locales/en-US/chrome/branding/brand.*
+ sed -i -e "s|BonEcho|Iceweasel|" configure.in
+ fi
+
+ #Don't strip extension
+ sed -i -e 's/STRIP_/#STRIP_/g' extensions/xforms/Makefile.in
+
+ eautoreconf
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate '' --enable-application=browser
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+
+ if use xforms; then
+ mozconfig_annotate '' --enable-extensions=default,xforms,schema-validation,typeaheadfind
+ else
+ mozconfig_annotate '' --enable-extensions=default,typeaheadfind
+ fi
+
+ if use ia64; then
+ echo "ac_cv_visibility_pragma=no" >> "${S}/.mozconfig"
+ fi
+
+ if ! use bindist && ! use iceweasel; then
+ mozconfig_annotate '' --enable-official-branding
+ fi
+
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+
+ # Other ff-specific settings
+ mozconfig_use_enable mozdevelop jsd
+ mozconfig_use_enable mozdevelop xpctools
+ mozconfig_use_extension mozdevelop venkman
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # -fstack-protector breaks us
+ if gcc-version ge 4 1; then
+ gcc-specs-ssp && append-flags -fno-stack-protector
+ else
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ fi
+ filter-flags -fstack-protector -fstack-protector-all
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ "${S}"/config/autoconf.mk \
+ "${S}"/toolkit/content/buildconfig.html
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Should the build use multiprocessing? Not enabled by default, as it tends to break
+ [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
+ emake ${jobs} || die
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ einfo "Removing old installs with some really ugly code. It potentially"
+ einfo "eliminates any problems during the install, however suggestions to"
+ einfo "replace this are highly welcome. Send comments and suggestions to"
+ einfo "mozilla@gentoo.org."
+ rm -rf "${ROOT}"/"${MOZILLA_FIVE_HOME}"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ # Most of the installation happens here
+ dodir "${MOZILLA_FIVE_HOME}"
+ cp -RL "${S}"/dist/bin/* "${D}"/"${MOZILLA_FIVE_HOME}"/ || die "cp failed"
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
+ done
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox
+ install_mozilla_launcher_stub firefox "${MOZILLA_FIVE_HOME}"
+
+ # Install icon and .desktop for menu entry
+ if use iceweasel; then
+ newicon "${S}"/browser/base/branding/icon48.png iceweasel-icon.png
+ newmenu "${FILESDIR}"/icon/iceweasel.desktop \
+ mozilla-firefox-2.0.desktop
+ elif ! use bindist; then
+ newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
+ newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
+ mozilla-firefox-2.0.desktop
+ else
+ newicon "${S}"/browser/base/branding/icon48.png firefox-icon-unbranded.png
+ newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
+ mozilla-firefox-2.0.desktop
+ fi
+
+ # Fix icons to look the same everywhere
+ insinto "${MOZILLA_FIVE_HOME}"/icons
+ doins "${S}"/dist/branding/mozicon16.xpm
+ doins "${S}"/dist/branding/mozicon50.xpm
+
+ # Install files necessary for applications to build against firefox
+ einfo "Installing includes and idl files..."
+ cp -LfR "${S}"/dist/include "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
+ cp -LfR "${S}"/dist/idl "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
+
+ # Dirty hack to get some applications using this header running
+ dosym "${MOZILLA_FIVE_HOME}"/include/necko/nsIURI.h \
+ "${MOZILLA_FIVE_HOME}"/include/nsIURI.h
+
+ # Install pkgconfig files
+ insinto /usr/"$(get_libdir)"/pkgconfig
+ doins "${S}"/build/unix/*.pc
+
+ insinto "${MOZILLA_FIVE_HOME}"/greprefs
+ newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
+ insinto "${MOZILLA_FIVE_HOME}"/defaults/pref
+ newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+
+ elog "Please remember to rebuild any packages that you have built"
+ elog "against Firefox. Some packages might be broken by the upgrade; if this"
+ elog "is the case, please search at http://bugs.gentoo.org and open a new bug"
+ elog "if one does not exist. Before filing any bugs, please move or remove"
+ elog " ~/.mozilla and test with a clean profile directory."
+}
+
+pkg_postrm() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ update_mozilla_launcher_symlinks
+}
diff --git a/www-client/mozilla-firefox/mozilla-firefox-3.0.2.ebuild b/www-client/mozilla-firefox/mozilla-firefox-3.0.2.ebuild
new file mode 100644
index 000000000000..7e42ed03c4cf
--- /dev/null
+++ b/www-client/mozilla-firefox/mozilla-firefox-3.0.2.ebuild
@@ -0,0 +1,310 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-3.0.2.ebuild,v 1.1 2008/09/24 17:08:35 armin76 Exp $
+EAPI="1"
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib fdo-mime autotools mozextension
+PATCH="${P}-patches-0.1"
+
+LANGS="af ar be bn-IN ca cs da de el en-GB en-US es-AR es-ES eu fi fr fy-NL ga-IE gl gu-IN he hi-IN hu id it ja ka ko ku lt mk mn mr nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru si sk sl sq sr sv-SE th tr uk zh-CN zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-CN"
+
+MY_PV=${PV/3/}
+
+DESCRIPTION="Firefox Web Browser"
+HOMEPAGE="http://www.mozilla.com/firefox"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="java mozdevelop bindist restrict-javascript iceweasel +xulrunner"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~armin76/dist/${P}.tar.bz2
+ mirror://gentoo/${PATCH}.tar.bz2
+ http://dev.gentoo.org/~armin76/dist/${PATCH}.tar.bz2
+ iceweasel? ( mirror://gentoo/iceweasel-icons-3.0.tar.bz2 )
+ !xulrunner? ( mirror://gentoo/xulrunner-1.9${MY_PV}.tar.bz2 )"
+
+# These are in
+#
+# http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/xpi/
+#
+# for i in $LANGS $SHORTLANGS; do wget $i.xpi -O ${P}-$i.xpi; done
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+RDEPEND="java? ( virtual/jre )
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1
+ >=media-libs/lcms-1.17
+ >=app-text/hunspell-1.1.9
+ xulrunner? ( >=net-libs/xulrunner-1.9${MY_PV} )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+PDEPEND="restrict-javascript? ( x11-plugins/noscript )"
+
+S="${WORKDIR}/mozilla"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=browser
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
+ done
+}
+
+pkg_setup(){
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Cairo is not built with X useflag."
+ eerror "Please add 'X' to your USE flags, and re-emerge cairo."
+ die "Cairo needs X"
+ fi
+
+ if ! built_with_use --missing true x11-libs/pango X; then
+ eerror "Pango is not built with X useflag."
+ eerror "Please add 'X' to your USE flags, and re-emerge pango."
+ die "Pango needs X"
+ fi
+
+ if ! use bindist && ! use iceweasel; then
+ elog "You are enabling official branding. You may not redistribute this build"
+ elog "to any users on your network or the internet. Doing so puts yourself into"
+ elog "a legal problem with Mozilla Foundation"
+ elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
+
+ fi
+}
+
+src_unpack() {
+ ! use xulrunner && unpack xulrunner-1.9${MY_PV}.tar.bz2
+ unpack ${P}.tar.bz2 ${PATCH}.tar.bz2
+
+ if use iceweasel; then
+ unpack iceweasel-icons-3.0.tar.bz2
+
+ cp -r iceweaselicons/browser mozilla/
+ fi
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+
+ # Remove the patches we don't need
+ use xulrunner && rm "${WORKDIR}"/patch/*noxul* || rm "${WORKDIR}"/patch/*xulonly*
+
+ # Apply our patches
+ cd "${S}" || die "cd failed"
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patch
+
+ if use iceweasel; then
+ sed -i -e "s|Minefield|Iceweasel|" browser/locales/en-US/chrome/branding/brand.* \
+ browser/branding/nightly/configure.sh
+ fi
+
+ eautoreconf
+
+ # We need to re-patch this because autoreconf overwrites it
+ epatch "${WORKDIR}"/patch/000_flex-configure-LANG.patch
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ MEXTENSIONS="default,typeaheadfind"
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ mozconfig_annotate '' --disable-mailnews
+ mozconfig_annotate 'broken' --disable-mochitest
+ mozconfig_annotate 'broken' --disable-crashreporter
+ mozconfig_annotate '' --enable-system-hunspell
+ #mozconfig_annotate '' --enable-system-sqlite
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --enable-system-lcms
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate 'places' --enable-storage --enable-places --enable-places_bookmarks
+
+ # Other ff-specific settings
+ #mozconfig_use_enable mozdevelop jsd
+ #mozconfig_use_enable mozdevelop xpctools
+ mozconfig_use_extension mozdevelop venkman
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ if use xulrunner; then
+ # Add xulrunner variable
+ mozconfig_annotate '' --with-libxul-sdk=/usr/$(get_libdir)/xulrunner-1.9
+ fi
+
+ if ! use bindist && ! use iceweasel; then
+ mozconfig_annotate '' --enable-official-branding
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # -fstack-protector breaks us
+ if gcc-version ge 4 1; then
+ gcc-specs-ssp && append-flags -fno-stack-protector
+ else
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ fi
+ filter-flags -fstack-protector -fstack-protector-all
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ "${S}"/config/autoconf.mk \
+ "${S}"/toolkit/content/buildconfig.html
+
+ # Should the build use multiprocessing? Not enabled by default, as it tends to break
+ [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
+ emake ${jobs} || die
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ einfo "Removing old installs with some really ugly code. It potentially"
+ einfo "eliminates any problems during the install, however suggestions to"
+ einfo "replace this are highly welcome. Send comments and suggestions to"
+ einfo "mozilla@gentoo.org."
+ rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm "${D}"/usr/bin/firefox
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
+ done
+
+ use xulrunner && prefs=preferences || prefs=pref
+ cp "${FILESDIR}"/gentoo-default-prefs.js "${D}"${MOZILLA_FIVE_HOME}/defaults/${prefs}/all-gentoo.js
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
+ ${MOZILLA_FIVE_HOME}/defaults/${prefs}/firefox.js \
+ ${MOZILLA_FIVE_HOME}/defaults/${prefs}/firefox-l10n.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Install icon and .desktop for menu entry
+ if use iceweasel; then
+ newicon "${S}"/browser/base/branding/icon48.png iceweasel-icon.png
+ newmenu "${FILESDIR}"/icon/iceweasel.desktop \
+ mozilla-firefox-3.0.desktop
+ elif ! use bindist; then
+ newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
+ newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
+ mozilla-firefox-3.0.desktop
+ else
+ newicon "${S}"/browser/base/branding/icon48.png firefox-icon-unbranded.png
+ newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
+ mozilla-firefox-3.0.desktop
+ sed -i -e "s/Bon Echo/Minefield/" "${D}"/usr/share/applications/mozilla-firefox-3.0.desktop
+ fi
+
+ if use xulrunner; then
+ # Create /usr/bin/firefox
+ cat <<EOF >"${D}"/usr/bin/firefox
+#!/bin/sh
+export LD_LIBRARY_PATH="${MOZILLA_FIVE_HOME}"
+exec "${MOZILLA_FIVE_HOME}"/firefox "\$@"
+EOF
+ fperms 0755 /usr/bin/firefox
+
+ dosym /usr/$(get_libdir)/xulrunner-1.9/defaults/autoconfig \
+ ${MOZILLA_FIVE_HOME}/defaults/autoconfig
+ else
+ # Create /usr/bin/firefox
+ make_wrapper firefox "${MOZILLA_FIVE_HOME}/firefox"
+
+ # Add vendor
+ echo "pref(\"general.useragent.vendor\",\"Gentoo\");" \
+ >> "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/vendor.js
+ fi
+
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ ewarn "All the packages built against ${PN} won't compile,"
+ ewarn "if after installing firefox 3.0 you get some blockers,"
+ ewarn "please add 'xulrunner' to your USE-flags."
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+}