summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-06-24 13:38:33 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-06-24 13:38:33 +0000
commitd336bb15cff5eca1a3bb5a0bb04a516d3b64f29e (patch)
treef7c6d52419b00e5d9f404b20d1e486e8e00056cb /www-client
parentVersion bump (diff)
downloadgentoo-2-d336bb15cff5eca1a3bb5a0bb04a516d3b64f29e.tar.gz
gentoo-2-d336bb15cff5eca1a3bb5a0bb04a516d3b64f29e.tar.bz2
gentoo-2-d336bb15cff5eca1a3bb5a0bb04a516d3b64f29e.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.17.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 84ee93476c7d..c232bf8f10ba 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.66 2009/04/10 13:25:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.67 2009/06/24 13:38:33 armin76 Exp $
+
+*seamonkey-bin-1.1.17 (24 Jun 2009)
+
+ 24 Jun 2009; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.17.ebuild:
+ Version bump
10 Apr 2009; Raúl Porcel <armin76@gentoo.org>
-seamonkey-bin-1.1.15.ebuild, seamonkey-bin-1.1.16.ebuild:
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.17.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.17.ebuild
new file mode 100644
index 000000000000..c1226a5b1e20
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.17.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.17.ebuild,v 1.1 2009/06/24 13:38:33 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}