summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-09 03:45:47 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-09 03:45:47 +0000
commit809f2ce6bc64bb7700a0761a27b09f9089682940 (patch)
tree7ccaf04ef772995af2f74cc372713cbb35c9d6c4 /www-client
parentBeta channel bump. (diff)
downloadgentoo-2-809f2ce6bc64bb7700a0761a27b09f9089682940.tar.gz
gentoo-2-809f2ce6bc64bb7700a0761a27b09f9089682940.tar.bz2
gentoo-2-809f2ce6bc64bb7700a0761a27b09f9089682940.zip
Beta channel bump. Tweak src_test to output each failed test command.
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog9
-rw-r--r--www-client/chromium/chromium-29.0.1547.41.ebuild (renamed from www-client/chromium/chromium-29.0.1547.22.ebuild)34
-rw-r--r--www-client/chromium/chromium-30.0.1581.2.ebuild6
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild6
4 files changed, 42 insertions, 13 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index b70cdd14bf42..3f13e47c3bb9 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.926 2013/07/31 22:31:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.927 2013/08/09 03:45:47 floppym Exp $
+
+*chromium-29.0.1547.41 (09 Aug 2013)
+
+ 09 Aug 2013; Mike Gilbert <floppym@gentoo.org> +chromium-29.0.1547.41.ebuild,
+ -chromium-29.0.1547.22.ebuild, chromium-30.0.1581.2.ebuild,
+ chromium-9999-r1.ebuild:
+ Beta channel bump. Tweak src_test to output each failed test command.
31 Jul 2013; Mike Gilbert <floppym@gentoo.org> chromium-9999-r1.ebuild:
Apply src_test change to live ebuild.
diff --git a/www-client/chromium/chromium-29.0.1547.22.ebuild b/www-client/chromium/chromium-29.0.1547.41.ebuild
index 5a22ca5b9809..d6e37fde8302 100644
--- a/www-client/chromium/chromium-29.0.1547.22.ebuild
+++ b/www-client/chromium/chromium-29.0.1547.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-29.0.1547.22.ebuild,v 1.2 2013/07/18 16:11:30 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-29.0.1547.41.ebuild,v 1.1 2013/08/09 03:45:46 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -397,26 +397,42 @@ src_compile() {
src_test() {
# For more info see bug #350349.
- local mylocale='en_US.utf8'
- if ! locale -a | grep -q "$mylocale"; then
- eerror "${PN} requires ${mylocale} locale for tests"
+ local LC_ALL="en_US.utf8"
+
+ if ! locale -a | grep -q "${LC_ALL}"; then
+ eerror "${PN} requires ${LC_ALL} locale for tests"
eerror "Please read the following guides for more information:"
eerror " http://www.gentoo.org/doc/en/guide-localization.xml"
eerror " http://www.gentoo.org/doc/en/utf-8.xml"
- die "locale ${mylocale} is not supported"
+ die "locale ${LC_ALL} is not supported"
fi
+ # If we have the right locale, export it to the environment
+ export LC_ALL
+
# For more info see bug #370957.
if [[ $UID -eq 0 ]]; then
die "Tests must be run as non-root. Please use FEATURES=userpriv."
fi
+ # virtualmake dies on failure, so we run our tests in a function
+ VIRTUALX_COMMAND="chromium_test" virtualmake
+}
+
+chromium_test() {
+ # Keep track of the cumulative exit status for all tests
+ local exitstatus=0
+
runtest() {
local cmd=$1
shift
- local filter="--gtest_filter=$(IFS=:; echo "-${*}")"
- einfo "${cmd}" "${filter}"
- LC_ALL="${mylocale}" VIRTUALX_COMMAND="${cmd}" virtualmake "${filter}"
+ local IFS=:
+ set -- "${cmd}" "--gtest_filter=-$*"
+ einfo "$@"
+ "$@"
+ local st=$?
+ (( st )) && eerror "${cmd} failed"
+ (( exitstatus |= st ))
}
local excluded_base_unittests=(
@@ -461,6 +477,8 @@ src_test() {
"SQLiteFeaturesTest.FTS2" # bug #461286
)
runtest out/Release/sql_unittests "${excluded_sql_unittests[@]}"
+
+ return ${exitstatus}
}
src_install() {
diff --git a/www-client/chromium/chromium-30.0.1581.2.ebuild b/www-client/chromium/chromium-30.0.1581.2.ebuild
index 0035aa636990..a3ebb249d55e 100644
--- a/www-client/chromium/chromium-30.0.1581.2.ebuild
+++ b/www-client/chromium/chromium-30.0.1581.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-30.0.1581.2.ebuild,v 1.2 2013/07/31 22:29:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-30.0.1581.2.ebuild,v 1.3 2013/08/09 03:45:47 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -436,7 +436,9 @@ chromium_test() {
set -- "${cmd}" "--gtest_filter=-$*"
einfo "$@"
"$@"
- (( exitstatus |= $? ))
+ local st=$?
+ (( st )) && eerror "${cmd} failed"
+ (( exitstatus |= st ))
}
local excluded_base_unittests=(
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index ea72eb7032b7..707f37a96c47 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.206 2013/07/31 22:31:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.207 2013/08/09 03:45:46 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -507,7 +507,9 @@ chromium_test() {
set -- "${cmd}" "--gtest_filter=-$*"
einfo "$@"
"$@"
- (( exitstatus |= $? ))
+ local st=$?
+ (( st )) && eerror "${cmd} failed"
+ (( exitstatus |= st ))
}
local excluded_base_unittests=(