summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-13 12:47:05 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-13 12:47:05 +0000
commit3dbea955dcfdc94623c87e921a5cdccc4a467fdd (patch)
treec2a2fe7e3d6797aeddc6812ba9b92f46e558358d /www-client
parentAdd missing dev-util/pkgconfig to DEPEND. (diff)
downloadgentoo-2-3dbea955dcfdc94623c87e921a5cdccc4a467fdd.tar.gz
gentoo-2-3dbea955dcfdc94623c87e921a5cdccc4a467fdd.tar.bz2
gentoo-2-3dbea955dcfdc94623c87e921a5cdccc4a467fdd.zip
Bump and correct some build time deps. GNOME_DOC_INIT implies at least version 0.3.2 of gnome-doc-utils. eauroreconf means that we need to pull the GNOME_COMPILE_WARNINGS macro from gnome-common provided m4 file, and can't rely on the tarball providing an appropriately generated aclocal.m4 - so dep on gnome-common too
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog7
-rw-r--r--www-client/epiphany/epiphany-2.16.1.ebuild72
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.16.13
3 files changed, 81 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 2d6e4485b93f..71e96399e577 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.85 2006/10/08 18:08:43 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.86 2006/10/13 12:47:05 leio Exp $
+
+*epiphany-2.16.1 (13 Oct 2006)
+
+ 13 Oct 2006; Mart Raudsepp <leio@gentoo.org> +epiphany-2.16.1.ebuild:
+ Version bump; correct some build deps
08 Oct 2006; Stefan Schweizer <genstef@gentoo.org> epiphany-2.16.0.ebuild:
Firefox 2 also works with this ebuild. From overlay and bug 149104
diff --git a/www-client/epiphany/epiphany-2.16.1.ebuild b/www-client/epiphany/epiphany-2.16.1.ebuild
new file mode 100644
index 000000000000..1b7c16ad6b82
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.16.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.16.1.ebuild,v 1.1 2006/10/13 12:47:05 leio Exp $
+
+inherit eutils gnome2 multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc python"
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ >=www-client/mozilla-firefox-1.5
+ >=sys-apps/dbus-0.35
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ >=gnome-base/gnome-common-2.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ --with-mozilla=firefox \
+ $(use_enable python)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-1.9.2-broken-firefox.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR=". ${S}/m4" WANT_AUTOCONF="2.5" \
+ eautoreconf || die "Failed to reconfigure"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-2.16.1 b/www-client/epiphany/files/digest-epiphany-2.16.1
new file mode 100644
index 000000000000..0d91ef770a7e
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.16.1
@@ -0,0 +1,3 @@
+MD5 25fecb147b1c68cc71d2af2bac727724 epiphany-2.16.1.tar.bz2 3761594
+RMD160 dd4fe05f8ca019a5ba83788ca5d73c169e247cce epiphany-2.16.1.tar.bz2 3761594
+SHA256 edc36ae24624cae00aa06dde6475c31574d5fc281612dfd1e51cda63c7a9300a epiphany-2.16.1.tar.bz2 3761594