summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-01-24 23:40:49 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-01-24 23:40:49 +0000
commit2a29fad682a0f67e9ff4b0708a5db69cfd653c01 (patch)
treedb7e5ebd7d2d06a2d7bddc2c24e9cbf48c4829d8 /www-client
parentVersion bump. Includes upstream parallel build fixes. (diff)
downloadgentoo-2-2a29fad682a0f67e9ff4b0708a5db69cfd653c01.tar.gz
gentoo-2-2a29fad682a0f67e9ff4b0708a5db69cfd653c01.tar.bz2
gentoo-2-2a29fad682a0f67e9ff4b0708a5db69cfd653c01.zip
Allow H.264 codec with our system ffmpeg, patch from Alt Linux in bug #302098
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog11
-rw-r--r--www-client/chromium/chromium-4.0.266.0-r1.ebuild154
-rw-r--r--www-client/chromium/chromium-4.0.295.0.ebuild6
-rw-r--r--www-client/chromium/chromium-4.0.302.2.ebuild6
-rw-r--r--www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch48
5 files changed, 222 insertions, 3 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 6a974635550c..6ae344b8142b 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.41 2010/01/22 21:38:44 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.42 2010/01/24 23:40:49 voyageur Exp $
+
+*chromium-4.0.266.0-r1 (24 Jan 2010)
+
+ 24 Jan 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +chromium-4.0.266.0-r1.ebuild, chromium-4.0.295.0.ebuild,
+ chromium-4.0.302.2.ebuild,
+ +files/chromium-20100122-ubuntu-html5-video-mimetypes.patch:
+ Allow H.264 codec with our system ffmpeg, patch from Alt Linux in bug
+ #302098
*chromium-4.0.302.2 (22 Jan 2010)
diff --git a/www-client/chromium/chromium-4.0.266.0-r1.ebuild b/www-client/chromium/chromium-4.0.266.0-r1.ebuild
new file mode 100644
index 000000000000..b711fc75e6fa
--- /dev/null
+++ b/www-client/chromium/chromium-4.0.266.0-r1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.266.0-r1.ebuild,v 1.1 2010/01/24 23:40:49 voyageur Exp $
+
+EAPI="2"
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Open-source version of Google Chrome web browser"
+HOMEPAGE="http://chromium.org/"
+#SRC_URI="http://build.chromium.org/buildbot/archives/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+ffmpeg"
+
+RDEPEND="app-arch/bzip2
+ >=dev-libs/libevent-1.4.13
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-libs/nss-3.12.3
+ >=gnome-base/gconf-2.24.0
+ media-fonts/corefonts
+ >=media-libs/alsa-lib-1.0.19
+ media-libs/jpeg
+ media-libs/libpng
+ ffmpeg? ( >=media-video/ffmpeg-0.5_p19787 )
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.14.7
+ x11-misc/xdg-utils
+ || (
+ x11-themes/gnome-icon-theme
+ x11-themes/tango-icon-theme
+ x11-themes/xfce4-icon-theme
+ )"
+# dev-db/sqlite:3
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.3
+ >=dev-util/pkgconfig-0.23"
+
+src_prepare() {
+ # Gentoo uses .kde4, not .kde
+ # TODO: this does not work with kdeprefix, fixing http:/crbug.com/29927
+ # would be better
+ sed -e 's/\.kde/.kde4/' -i net/proxy/proxy_config_service_linux.cc \
+ || die "kde proxy sed failed"
+ # Changing this in ~/include.gypi does not work
+ sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
+ # Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
+ epatch "${FILESDIR}"/${PN}-drop_sse2.patch
+ # Add configuration flag to use system libevent
+ epatch "${FILESDIR}"/${PN}-use_system_libevent-1.4.13.patch
+ # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
+ epatch "${FILESDIR}"/${PN}-20100122-ubuntu-html5-video-mimetypes.patch
+
+ # Disable prefixing to allow linking against system zlib
+ sed -e '/^#include "mozzconf.h"$/d' \
+ -i third_party/{,WebKit/WebCore/platform/image-decoders}/zlib/zconf.h \
+ || die "zlib sed failed"
+}
+
+src_configure() {
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ # CFLAGS/LDFLAGS
+ mkdir -p "${S}"/.gyp
+ cat << EOF > "${S}"/.gyp/include.gypi
+{
+ 'target_defaults': {
+ 'cflags': [ '${CFLAGS// /','}' ],
+ 'ldflags': [ '${LDFLAGS// /','}' ],
+ },
+}
+EOF
+ export HOME="${S}"
+
+ # Configuration options (system libraries)
+ local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1"
+ # -Duse_system_sqlite=1 : http://crbug.com/22208
+ # Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
+
+ # Sandbox paths
+ myconf="${myconf} -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+
+ if [[ "$ABI" == "amd64" ]] ; then
+ myconf="${myconf} -Dtarget_arch=x64"
+ fi
+
+ if [[ "$ABI" == "x86" ]] ; then
+ myconf="${myconf} -Dtarget_arch=ia32"
+ fi
+
+ if use arm; then
+ myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dv8_use_snapshot=false -Dlinux_use_tcmalloc=0"
+ fi
+
+ if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
+ myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
+ fi
+
+ build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
+}
+
+src_compile() {
+ emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
+ rootdir="${S}" \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ || die "compilation failed"
+}
+
+src_install() {
+ # Chromium does not have "install" target in the build system.
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ dodir ${CHROMIUM_HOME}
+
+ exeinto ${CHROMIUM_HOME}
+ doexe out/Release/chrome
+ doexe out/Release/chrome_sandbox
+ fperms 4755 ${CHROMIUM_HOME}/chrome_sandbox
+ doexe out/Release/xdg-settings
+ doexe "${FILESDIR}"/chromium-launcher.sh
+
+ insinto ${CHROMIUM_HOME}
+ doins out/Release/chrome.pak
+
+ doins -r out/Release/locales
+ doins -r out/Release/resources
+
+ # chrome.1 is for chromium --help
+ newman out/Release/chrome.1 chrome.1
+ newman out/Release/chrome.1 chromium.1
+
+ if use ffmpeg; then
+ # Chromium looks for these in its folder
+ # See media_posix.cc and base_paths_linux.cc
+ dosym /usr/$(get_libdir)/libavcodec.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavformat.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavutil.so.50 ${CHROMIUM_HOME}
+ fi
+
+ # Plugins symlink
+ dosym /usr/$(get_libdir)/nsbrowser/plugins ${CHROMIUM_HOME}/plugins
+
+ newicon out/Release/product_logo_48.png ${PN}-browser.png
+ dosym ${CHROMIUM_HOME}/chromium-launcher.sh /usr/bin/chromium
+ make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser"
+ sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
+ || die "desktop file sed failed"
+}
diff --git a/www-client/chromium/chromium-4.0.295.0.ebuild b/www-client/chromium/chromium-4.0.295.0.ebuild
index 80955b504e63..4cc9f6ce9213 100644
--- a/www-client/chromium/chromium-4.0.295.0.ebuild
+++ b/www-client/chromium/chromium-4.0.295.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.295.0.ebuild,v 1.2 2010/01/18 19:41:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.295.0.ebuild,v 1.3 2010/01/24 23:40:49 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -41,12 +41,16 @@ DEPEND="${RDEPEND}
src_prepare() {
# Gentoo uses .kde4, not .kde
+ # TODO: this does not work with kdeprefix, fixing http:/crbug.com/29927
+ # would be better
sed -e 's/\.kde/.kde4/' -i net/proxy/proxy_config_service_linux.cc \
|| die "kde proxy sed failed"
# Changing this in ~/include.gypi does not work
sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
# Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
epatch "${FILESDIR}"/${PN}-drop_sse2.patch
+ # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
+ epatch "${FILESDIR}"/${PN}-20100122-ubuntu-html5-video-mimetypes.patch
# Disable prefixing to allow linking against system zlib
sed -e '/^#include "mozzconf.h"$/d' \
diff --git a/www-client/chromium/chromium-4.0.302.2.ebuild b/www-client/chromium/chromium-4.0.302.2.ebuild
index 0ef5e785a076..16d67429316f 100644
--- a/www-client/chromium/chromium-4.0.302.2.ebuild
+++ b/www-client/chromium/chromium-4.0.302.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.302.2.ebuild,v 1.1 2010/01/22 21:38:44 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.302.2.ebuild,v 1.2 2010/01/24 23:40:49 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -41,12 +41,16 @@ DEPEND="${RDEPEND}
src_prepare() {
# Gentoo uses .kde4, not .kde
+ # TODO: this does not work with kdeprefix, fixing http:/crbug.com/29927
+ # would be better
sed -e 's/\.kde/.kde4/' -i net/proxy/proxy_config_service_linux.cc \
|| die "kde proxy sed failed"
# Changing this in ~/include.gypi does not work
sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
# Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
epatch "${FILESDIR}"/${PN}-drop_sse2.patch
+ # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
+ epatch "${FILESDIR}"/${PN}-20100122-ubuntu-html5-video-mimetypes.patch
# Disable prefixing to allow linking against system zlib
sed -e '/^#include "mozzconf.h"$/d' \
diff --git a/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch b/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
new file mode 100644
index 000000000000..f4e534a16603
--- /dev/null
+++ b/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
@@ -0,0 +1,48 @@
+---
+ net/base/mime_util.cc | 4 ----
+ 1 file changed, 4 deletions(-)
+
+Index: src/net/base/mime_util.cc
+===================================================================
+--- src.orig/net/base/mime_util.cc
++++ src/net/base/mime_util.cc
+@@ -183,39 +183,35 @@
+ // A list of media types: http://en.wikipedia.org/wiki/Internet_media_type
+ // A comprehensive mime type list: http://plugindoc.mozdev.org/winmime.php
+ static const char* const supported_media_types[] = {
+ // Ogg.
+ "video/ogg",
+ "audio/ogg",
+ "application/ogg",
+
+-#if defined(GOOGLE_CHROME_BUILD)
+ // MPEG-4.
+ "video/mp4",
+ "video/x-m4v",
+ "audio/mp4",
+ "audio/x-m4a",
+
+ // MP3.
+ "audio/mp3",
+ "audio/x-mp3",
+ "audio/mpeg",
+-#endif
+ };
+
+ // List of supported codecs when passed in with <source type="...">.
+ //
+ // Refer to http://wiki.whatwg.org/wiki/Video_type_parameters#Browser_Support
+ // for more information.
+ static const char* const supported_media_codecs[] = {
+-#if defined(GOOGLE_CHROME_BUILD)
+ "avc1",
+ "mp4a",
+-#endif
+ "theora",
+ "vorbis",
+ };
+
+ // Note: does not include javascript types list (see supported_javascript_types)
+ static const char* const supported_non_image_types[] = {
+ "text/html",
+ "text/xml",