summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-04-12 05:01:00 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-04-12 05:01:00 +0000
commit1c90f2138208c7ca1a0e35199d488700cf14aaa3 (patch)
tree79cc5dd94e826e689b9c04fc4748bd1f7b9f35c2 /www-client
parentMove app-pda/gtkpod[cdr] mask to eapi-5-files/package.use.stable.mask. (diff)
downloadgentoo-2-1c90f2138208c7ca1a0e35199d488700cf14aaa3.tar.gz
gentoo-2-1c90f2138208c7ca1a0e35199d488700cf14aaa3.tar.bz2
gentoo-2-1c90f2138208c7ca1a0e35199d488700cf14aaa3.zip
Respect CFLAGS, wrt bug #459660, thanks to Agostino Sarubbo
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/netrik/ChangeLog6
-rw-r--r--www-client/netrik/files/netrik-1.16.1-configure.patch67
-rw-r--r--www-client/netrik/netrik-1.16.1-r1.ebuild3
3 files changed, 74 insertions, 2 deletions
diff --git a/www-client/netrik/ChangeLog b/www-client/netrik/ChangeLog
index 07f41baf0c3c..cc4f20d3a271 100644
--- a/www-client/netrik/ChangeLog
+++ b/www-client/netrik/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/netrik
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/netrik/ChangeLog,v 1.15 2013/04/10 09:46:06 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/netrik/ChangeLog,v 1.16 2013/04/12 05:01:00 pinkbyte Exp $
+
+ 12 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> netrik-1.16.1-r1.ebuild,
+ +files/netrik-1.16.1-configure.patch:
+ Respect CFLAGS, wrt bug #459660, thanks to Agostino Sarubbo
*netrik-1.16.1-r1 (10 Apr 2013)
diff --git a/www-client/netrik/files/netrik-1.16.1-configure.patch b/www-client/netrik/files/netrik-1.16.1-configure.patch
new file mode 100644
index 000000000000..45a0368d69d7
--- /dev/null
+++ b/www-client/netrik/files/netrik-1.16.1-configure.patch
@@ -0,0 +1,67 @@
+--- configure.ac.orig 2013-04-12 08:56:35.279744148 +0400
++++ configure.ac 2013-04-12 08:57:09.576747084 +0400
+@@ -1,6 +1,3 @@
+-dnl preserve initial CFLAGS
+-CFLAGS_OLD="$CFLAGS"
+-
+ dnl initialize
+ AC_INIT(main.c)
+ VER=`head -1 $srcdir/README |sed 's/ *netrik \([[^ ]]*\).*/\1/'`
+@@ -56,10 +53,6 @@
+ [AC_HELP_STRING([--disable-debug],
+ [do not include debug options and sanity checks])])
+
+-AC_ARG_ENABLE(optimization,
+- [AC_HELP_STRING([[--enable-optimization[[[=LEVEL]]]]],
+- [use compiler optimization with -OLEVEL (default: -O2 if CFLAGS not set)])])
+-
+ dnl process results
+ dnl define
+ if test x"$enable_debug" != "xno"; then
+@@ -67,46 +60,5 @@
+ [Define if debug options and sanity checks are desired.])
+ fi
+
+-dnl restore CFLAGS
+-CFLAGS="$CFLAGS_OLD"
+-
+-dnl set default CFLAGS
+-if test -z "$CFLAGS_OLD" ; then
+- CFLAGS="$CFLAGS -g"
+-
+- dnl set warning options for GCC
+- if test x"$GCC" = "xyes"; then
+- CFLAGS="$CFLAGS -W -Wall -Wstrict-prototypes -Wmissing-prototypes"
+- fi
+-fi
+-
+-dnl adjust optimization options
+-case x"$enable_optimization" in
+- dnl option given but no argument specified
+- xyes)
+- CFLAGS="$CFLAGS -O2"
+- ;;
+-
+- dnl chosen not to optimize
+- xno)
+- dnl use -O0 to make sure no optimization is performed
+- CFLAGS="$CFLAGS -O0"
+- ;;
+-
+- dnl option not given
+- x)
+- dnl optimize if CFLAGS not specified
+- if test -z "$CFLAGS_OLD"; then
+- CFLAGS="$CFLAGS -O2"
+- fi
+- ;;
+-
+- dnl argument given
+- *)
+- dnl use argument to optimize
+- CFLAGS="$CFLAGS -O${enable_optimization}"
+- ;;
+-esac
+-
+ dnl generate Makefiles
+ AC_OUTPUT(Makefile doc/Makefile debian/Makefile)
diff --git a/www-client/netrik/netrik-1.16.1-r1.ebuild b/www-client/netrik/netrik-1.16.1-r1.ebuild
index 47ecf6201d3b..8f9aec974456 100644
--- a/www-client/netrik/netrik-1.16.1-r1.ebuild
+++ b/www-client/netrik/netrik-1.16.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/netrik/netrik-1.16.1-r1.ebuild,v 1.1 2013/04/10 09:46:06 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/netrik/netrik-1.16.1-r1.ebuild,v 1.2 2013/04/12 05:01:00 pinkbyte Exp $
EAPI=5
@@ -24,6 +24,7 @@ src_prepare() {
# bug #459660
epatch "${FILESDIR}/${P}-ncurses-tinfo.patch"
+ epatch "${FILESDIR}/${P}-configure.patch"
epatch_user
eautoreconf