summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-21 03:27:33 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-21 03:27:33 +0000
commit0030f4da9f0125c7b0288495baf17bc3317c8c26 (patch)
tree1718fb73723cae67e51039f3894606f3da799a09 /www-client
parentopenvas-client: allow not building gtk-gui (diff)
downloadgentoo-2-0030f4da9f0125c7b0288495baf17bc3317c8c26.tar.gz
gentoo-2-0030f4da9f0125c7b0288495baf17bc3317c8c26.tar.bz2
gentoo-2-0030f4da9f0125c7b0288495baf17bc3317c8c26.zip
Version bumped, bug #247797.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/kazehakase/ChangeLog7
-rw-r--r--www-client/kazehakase/kazehakase-0.5.6.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/www-client/kazehakase/ChangeLog b/www-client/kazehakase/ChangeLog
index 5c58e1919b6f..3caa96dba29f 100644
--- a/www-client/kazehakase/ChangeLog
+++ b/www-client/kazehakase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/kazehakase
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.65 2008/11/21 01:57:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.66 2008/11/21 03:27:33 matsuu Exp $
+
+*kazehakase-0.5.6 (21 Nov 2008)
+
+ 21 Nov 2008; MATSUU Takuto <matsuu@gentoo.org> +kazehakase-0.5.6.ebuild:
+ Version bumped, bug #247797.
21 Nov 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Fix package atom.
diff --git a/www-client/kazehakase/kazehakase-0.5.6.ebuild b/www-client/kazehakase/kazehakase-0.5.6.ebuild
new file mode 100644
index 000000000000..e5667a248876
--- /dev/null
+++ b/www-client/kazehakase/kazehakase-0.5.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.6.ebuild,v 1.1 2008/11/21 03:27:33 matsuu Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="hyperestraier migemo ruby ssl webkit"
+
+DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
+SRC_URI="mirror://sourceforge.jp/${PN}/33533/${P}.tar.gz"
+HOMEPAGE="http://kazehakase.sourceforge.jp/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/gtk+-2.12
+ || (
+ >=www-client/mozilla-firefox-2
+ >=www-client/seamonkey-1
+ >=mail-client/mozilla-thunderbird-2
+ >=net-libs/xulrunner-1.8
+ )
+ ssl? ( >=net-libs/gnutls-1.2.0 )
+ ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )
+ hyperestraier? ( >=app-text/hyperestraier-1.2 )
+ webkit? ( net-libs/webkit-gtk )"
+
+RDEPEND="${DEPEND}
+ migemo? ( app-text/migemo )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.5-xulrunner19.patch
+}
+
+src_compile() {
+ local myconf
+
+ # Bug 159949
+ replace-flags -Os -O2
+
+ myconf="${myconf} $(use_enable migemo)"
+ use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
+ use ssl || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README* TODO*
+}