summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-10-02 00:57:42 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-10-02 00:57:42 +0000
commit0727a06f941e105da6bf2433230ec111ca97bd74 (patch)
tree7d8038ced5d48c6416483d325f3d3f2f9e5e1fa1 /www-client/mozilla/mozilla-1.7.12-r2.ebuild
parentStable on ia64, bug 106678. (diff)
downloadgentoo-2-0727a06f941e105da6bf2433230ec111ca97bd74.tar.gz
gentoo-2-0727a06f941e105da6bf2433230ec111ca97bd74.tar.bz2
gentoo-2-0727a06f941e105da6bf2433230ec111ca97bd74.zip
Fix a compilation issue using the 32-bit userland with 64-bit kernel on PowerPC
(Portage version: 2.0.52-r1)
Diffstat (limited to 'www-client/mozilla/mozilla-1.7.12-r2.ebuild')
-rw-r--r--www-client/mozilla/mozilla-1.7.12-r2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/www-client/mozilla/mozilla-1.7.12-r2.ebuild b/www-client/mozilla/mozilla-1.7.12-r2.ebuild
index f301377bd001..7cbc0298943b 100644
--- a/www-client/mozilla/mozilla-1.7.12-r2.ebuild
+++ b/www-client/mozilla/mozilla-1.7.12-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/mozilla-1.7.12-r2.ebuild,v 1.7 2005/09/29 13:29:37 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/mozilla-1.7.12-r2.ebuild,v 1.8 2005/10/02 00:57:42 hansmi Exp $
unset ALLOWED_FLAGS # Stupid extra-functions.sh ... bug 49179
MOZ_FREETYPE2="no" # Need to disable for newer .. remove here and in mozconfig
@@ -102,6 +102,16 @@ src_unpack() {
sed -i -e '1s,usr/local/bin,usr/bin,' ${S}/security/nss/cmd/smimetools/smime
eend $? || die "sed failed"
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, mozilla detects a ppc64 system.
+ # -- hansmi, 2005-10-02
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure.in
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
+
# Needed by some of the patches
WANT_AUTOCONF=2.1 autoconf || die "WANT_AUTOCONF failed"
}