summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2005-03-23 14:29:40 +0000
committerBrad Laue <brad@gentoo.org>2005-03-23 14:29:40 +0000
commitdd5971a6aa60158c236efc211297670dbdec1ce9 (patch)
tree36d7790d4eb6eb0fd52ba9e400e1805d6b00822e /www-client/mozilla-bin
parentchange homepage to a valid one (eg. pygtk) (#86381) (diff)
downloadgentoo-2-dd5971a6aa60158c236efc211297670dbdec1ce9.tar.gz
gentoo-2-dd5971a6aa60158c236efc211297670dbdec1ce9.tar.bz2
gentoo-2-dd5971a6aa60158c236efc211297670dbdec1ce9.zip
Bump to 1.7.6
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-client/mozilla-bin')
-rw-r--r--www-client/mozilla-bin/ChangeLog7
-rw-r--r--www-client/mozilla-bin/files/digest-mozilla-bin-1.7.61
-rw-r--r--www-client/mozilla-bin/mozilla-bin-1.7.6.ebuild81
3 files changed, 88 insertions, 1 deletions
diff --git a/www-client/mozilla-bin/ChangeLog b/www-client/mozilla-bin/ChangeLog
index cd029e87f448..e653f59e855d 100644
--- a/www-client/mozilla-bin/ChangeLog
+++ b/www-client/mozilla-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/mozilla-bin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-bin/ChangeLog,v 1.2 2005/03/18 16:40:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-bin/ChangeLog,v 1.3 2005/03/23 14:29:40 brad Exp $
+
+*mozilla-bin-1.7.6 (23 Mar 2005)
+
+ 23 Mar 2005; Brad Laue <brad@gentoo.org> +mozilla-bin-1.7.6.ebuild:
+ Bump to 1.7.6. See bug #84074 for details.
*mozilla-bin-1.7.5 (18 Mar 2005)
*mozilla-bin-1.7.3 (18 Mar 2005)
diff --git a/www-client/mozilla-bin/files/digest-mozilla-bin-1.7.6 b/www-client/mozilla-bin/files/digest-mozilla-bin-1.7.6
new file mode 100644
index 000000000000..06e4f32f76b6
--- /dev/null
+++ b/www-client/mozilla-bin/files/digest-mozilla-bin-1.7.6
@@ -0,0 +1 @@
+MD5 99adbd71ece39242f4563bd6297e4372 mozilla-i686-pc-linux-gnu-1.7.6.tar.gz 13889017
diff --git a/www-client/mozilla-bin/mozilla-bin-1.7.6.ebuild b/www-client/mozilla-bin/mozilla-bin-1.7.6.ebuild
new file mode 100644
index 000000000000..5543e42cbb6e
--- /dev/null
+++ b/www-client/mozilla-bin/mozilla-bin-1.7.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-bin/mozilla-bin-1.7.6.ebuild,v 1.1 2005/03/23 14:29:40 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE=""
+
+# handle _rc versions
+MY_PV=${PV/_alpha/a} # handle alpha
+MY_PV=${MY_PV/_beta/b} # handle beta
+MY_PV=${MY_PV/_rc/rc} # handle rc
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/mozilla
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+HOMEPAGE="http://www.mozilla.org"
+# Mirrors have it in one of the following places, depending on what
+# mirror you check and when you check it... :-(
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${PV}/mozilla-i686-pc-linux-gnu-${PV}.tar.gz"
+RESTRICT="nostrip"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ =x11-libs/gtk+-1.2*
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ virtual/x11
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install mozilla in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/mozilla
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/mozilla/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/mozilla
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/mozilla-bin
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/mozilla-bin-icon.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/mozilla-bin.desktop
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ # Remove the old plugins dir
+ pkg_mv_plugins ${MOZILLA_FIVE_HOME}/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}