summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-09 15:52:29 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-09 15:52:29 +0000
commitf52a8c6d008e2ebd568407ee2399f6f410d6ae0a (patch)
treeac26007aa481c9dda66d7954a38db890e96db6c4 /www-client/chromium
parentAdd dependency on dev-ruby/fssm. This was mandatory but not noticed due to it... (diff)
downloadgentoo-2-f52a8c6d008e2ebd568407ee2399f6f410d6ae0a.tar.gz
gentoo-2-f52a8c6d008e2ebd568407ee2399f6f410d6ae0a.tar.bz2
gentoo-2-f52a8c6d008e2ebd568407ee2399f6f410d6ae0a.zip
Exclude test that relies on custom ICU patches (bug #350347). Also remove net_unittests for now and make all test failures fatal.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/ChangeLog7
-rw-r--r--www-client/chromium/chromium-10.0.628.0.ebuild13
-rw-r--r--www-client/chromium/chromium-9999.ebuild13
3 files changed, 16 insertions, 17 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 09a1cff69bd0..0e235ee44184 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.255 2011/01/07 08:28:34 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.256 2011/01/09 15:52:29 phajdan.jr Exp $
+
+ 09 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ chromium-10.0.628.0.ebuild, chromium-9999.ebuild:
+ Exclude test that relies on custom ICU patches (bug #350347). Also remove
+ net_unittests for now and make all test failures fatal.
*chromium-9.0.597.45 (07 Jan 2011)
diff --git a/www-client/chromium/chromium-10.0.628.0.ebuild b/www-client/chromium/chromium-10.0.628.0.ebuild
index 3bd3dfd83f41..b509dee1705d 100644
--- a/www-client/chromium/chromium-10.0.628.0.ebuild
+++ b/www-client/chromium/chromium-10.0.628.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.628.0.ebuild,v 1.1 2011/01/06 16:12:21 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.628.0.ebuild,v 1.2 2011/01/09 15:52:29 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -272,9 +272,8 @@ src_compile() {
emake chrome chrome_sandbox BUILDTYPE=Release V=1 || die
pax-mark m out/Release/chrome
if use test; then
- emake base_unittests net_unittests \
- BUILDTYPE=Release V=1 || die
- pax-mark m out/Release/{base_unittests,net_unittests}
+ emake base_unittests BUILDTYPE=Release V=1 || die
+ pax-mark m out/Release/base_unittests
fi
}
@@ -289,11 +288,9 @@ src_test() {
die "locale ${mylocale} is not supported"
fi
- # Make test failures non-fatal for now. This needs more investigation.
+ # For more info see bug #350347.
LC_ALL="${mylocale}" maketype=out/Release/base_unittests virtualmake \
- || eerror "base_unittests failed"
- LC_ALL="${mylocale}" maketype=out/Release/net_unittests virtualmake \
- || eerror "net_unittests failed"
+ '--gtest_filter=-ICUStringConversionsTest.*' || die
}
src_install() {
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 41411ab09bce..0bc20e43fe69 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.121 2011/01/06 16:12:21 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.122 2011/01/09 15:52:29 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -309,9 +309,8 @@ src_compile() {
emake chrome chrome_sandbox BUILDTYPE=Release V=1 || die
pax-mark m out/Release/chrome
if use test; then
- emake base_unittests net_unittests \
- BUILDTYPE=Release V=1 || die
- pax-mark m out/Release/{base_unittests,net_unittests}
+ emake base_unittests BUILDTYPE=Release V=1 || die
+ pax-mark m out/Release/base_unittests
fi
}
@@ -326,11 +325,9 @@ src_test() {
die "locale ${mylocale} is not supported"
fi
- # Make test failures non-fatal for now. This needs more investigation.
+ # For more info see bug #350347.
LC_ALL="${mylocale}" maketype=out/Release/base_unittests virtualmake \
- || eerror "base_unittests failed"
- LC_ALL="${mylocale}" maketype=out/Release/net_unittests virtualmake \
- || eerror "net_unittests failed"
+ '--gtest_filter=-ICUStringConversionsTest.*' || die
}
src_install() {