summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-11-28 21:40:04 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-11-28 21:40:04 +0000
commit3f1410beebed3d8819553c99d4648be0a8298f20 (patch)
treea0ead810c4ad6d04b875888f0995d8820ff8638d /www-apps/viewvc
parentmasked 3.3 series version bump (diff)
downloadgentoo-2-3f1410beebed3d8819553c99d4648be0a8298f20.tar.gz
gentoo-2-3f1410beebed3d8819553c99d4648be0a8298f20.tar.bz2
gentoo-2-3f1410beebed3d8819553c99d4648be0a8298f20.zip
version bump, upstream bug fixes only
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/viewvc')
-rw-r--r--www-apps/viewvc/ChangeLog7
-rw-r--r--www-apps/viewvc/viewvc-1.1.12.ebuild115
2 files changed, 121 insertions, 1 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index 80e2f668d348..04ab4d95d03d 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/viewvc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.80 2011/07/01 21:24:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.81 2011/11/28 21:40:04 darkside Exp $
+
+*viewvc-1.1.12 (28 Nov 2011)
+
+ 28 Nov 2011; Jeremy Olexa <darkside@gentoo.org> +viewvc-1.1.12.ebuild:
+ version bump, upstream bug fixes only
01 Jul 2011; Markos Chandras <hwoarang@gentoo.org> -viewvc-1.1.8.ebuild,
-viewvc-1.1.9.ebuild, -viewvc-1.1.10.ebuild:
diff --git a/www-apps/viewvc/viewvc-1.1.12.ebuild b/www-apps/viewvc/viewvc-1.1.12.ebuild
new file mode 100644
index 000000000000..ac461b912dab
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.1.12.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.12.ebuild,v 1.1 2011/11/28 21:40:04 darkside Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit confutils eutils python webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+DOWNLOAD_NUMBER="49132"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/${DOWNLOAD_NUMBER}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cvs cvsgraph mod_python mod_wsgi mysql pygments +subversion"
+
+DEPEND=""
+RDEPEND="
+ cvs? ( dev-vcs/rcs )
+ subversion? ( >=dev-vcs/subversion-1.3.1[python] )
+
+ mod_python? ( www-apache/mod_python )
+ mod_wsgi? ( www-apache/mod_wsgi )
+ !mod_python? ( !mod_wsgi? ( virtual/httpd-cgi ) )
+
+ cvsgraph? ( >=dev-vcs/cvsgraph-1.5.0 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+ pygments? ( dev-python/pygments )
+"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+}
+
+src_prepare() {
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
+ mv conf/viewvc.conf{.dist,}
+ mv conf/cvsgraph.conf{.dist,}
+ mv conf/mimetypes.conf{.dist,}
+
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ webapp_src_preinst
+
+ newbin bin/standalone.py viewvc-standalone-server || die "newbin failed"
+
+ dodoc CHANGES COMMITTERS INSTALL README || die "dodoc failed"
+
+ installation() {
+ insinto $(python_get_sitedir)/${PN}
+ doins -r lib/*
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r templates/ || die "doins failed"
+ doins -r templates-contrib/ || die "doins failed"
+
+ if use mysql; then
+ exeinto "${MY_HOSTROOTDIR}/bin"
+ doexe bin/{*dbadmin,make-database,loginfo-handler} || die "doexe failed"
+ fi
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins conf/{viewvc,cvsgraph,mimetypes}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py || die "doins failed"
+ doins bin/mod_python/handler.py || die "doins failed"
+ doins bin/mod_python/.htaccess || die "doins failed"
+ if use mysql; then
+ doins bin/mod_python/query.py || die "doins failed"
+ fi
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi || die "doexe failed"
+ if use mysql; then
+ doexe bin/cgi/query.cgi || die "doexe failed"
+ fi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}/conf/"{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize viewvc
+ webapp_pkg_postinst
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup viewvc
+}