summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-24 00:00:38 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-24 00:00:38 +0000
commitcd10b06d2ae1e6b2de31f58a20709199a06b8444 (patch)
tree1984e0d6003e6de7b2b43f3c1f8169287b545f48 /www-apps/twiki
parentmake IUSE=vhosts optional (diff)
downloadgentoo-2-cd10b06d2ae1e6b2de31f58a20709199a06b8444.tar.gz
gentoo-2-cd10b06d2ae1e6b2de31f58a20709199a06b8444.tar.bz2
gentoo-2-cd10b06d2ae1e6b2de31f58a20709199a06b8444.zip
version bump, #209663; ebuild cleanup wrt #208584
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/twiki')
-rw-r--r--www-apps/twiki/ChangeLog10
-rw-r--r--www-apps/twiki/metadata.xml6
-rw-r--r--www-apps/twiki/twiki-4.1.2.ebuild89
-rw-r--r--www-apps/twiki/twiki-4.2.0.ebuild76
4 files changed, 126 insertions, 55 deletions
diff --git a/www-apps/twiki/ChangeLog b/www-apps/twiki/ChangeLog
index 6705a68e7858..e946f7c2c21b 100644
--- a/www-apps/twiki/ChangeLog
+++ b/www-apps/twiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/twiki
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.42 2007/05/26 21:48:05 rl03 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.43 2008/02/24 00:00:38 hollow Exp $
+
+*twiki-4.2.0 (24 Feb 2008)
+
+ 24 Feb 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml,
+ twiki-4.1.2.ebuild, +twiki-4.2.0.ebuild:
+ version bump, #209663; ebuild cleanup wrt #208584
*twiki-4.1.2 (26 May 2007)
diff --git a/www-apps/twiki/metadata.xml b/www-apps/twiki/metadata.xml
index 13bc126c7d91..6632069b5aff 100644
--- a/www-apps/twiki/metadata.xml
+++ b/www-apps/twiki/metadata.xml
@@ -1,9 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>web-apps</herd>
-<maintainer>
-<email>web-apps@gentoo.org</email>
-<name>Gentoo Web Application Packages Maintainers</name>
-</maintainer>
+ <herd>web-apps</herd>
</pkgmetadata>
diff --git a/www-apps/twiki/twiki-4.1.2.ebuild b/www-apps/twiki/twiki-4.1.2.ebuild
index 58492035585b..b99eb7510f9f 100644
--- a/www-apps/twiki/twiki-4.1.2.ebuild
+++ b/www-apps/twiki/twiki-4.1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/twiki-4.1.2.ebuild,v 1.1 2007/05/26 21:48:05 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/twiki-4.1.2.ebuild,v 1.2 2008/02/24 00:00:38 hollow Exp $
-inherit webapp eutils depend.apache
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit webapp
MY_PN="TWiki"
@@ -14,56 +16,50 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
-S=${WORKDIR}
-
-RDEPEND=">=dev-lang/perl-5.8
- >=app-text/rcs-5.7
- sys-apps/diffutils
- dev-perl/Algorithm-Diff
- >=virtual/perl-CGI-3.20
- virtual/perl-File-Spec
- dev-perl/Text-Diff
- virtual/perl-Time-Local
- dev-perl/CGI-Session
- virtual/perl-digest-base
- dev-perl/Digest-SHA1
- dev-perl/locale-maketext-lexicon
- virtual/perl-libnet
- dev-perl/URI
- virtual/cron
- dev-perl/HTML-Parser
-"
-
-want_apache
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- mv ${S}/bin/LocalLib.cfg.txt ${S}/bin/LocalLib.cfg
- # change web user to apache
- cd ${S}/lib/TWiki
- find . -name '*,v' -exec sed -i 's|nobody:|apache:|g' '{}' ';'
-}
+S="${WORKDIR}"
+
+RDEPEND=">=app-text/rcs-5.7
+ sys-apps/diffutils
+ >=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff
+ dev-perl/CGI-Session
+ dev-perl/Digest-SHA1
+ dev-perl/HTML-Parser
+ dev-perl/locale-maketext-lexicon
+ dev-perl/Text-Diff
+ dev-perl/URI
+ virtual/cron
+ >=virtual/perl-CGI-3.20
+ virtual/perl-digest-base
+ virtual/perl-File-Spec
+ virtual/perl-libnet
+ virtual/perl-Time-Local"
+
+need_httpd_cgi
src_install() {
webapp_src_preinst
- cp -r . ${D}/${MY_HTDOCSDIR}
-
- dodoc readme.txt
+ dodoc AUTHORS COPYRIGHT readme.txt
dohtml T*.html INSTALL.html
+ rm -f readme.txt T*.html INSTALL.html
- for file in $(find data pub) ; do
- webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ mv bin/LocalLib.cfg{.txt,}
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for f in $(find data pub); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${f}
done
- for a in bin/setlib.cfg bin/LocalLib.cfg ; do
- webapp_configfile ${MY_HTDOCSDIR}/${a}
+ for f in bin/setlib.cfg bin/LocalLib.cfg; do
+ webapp_configfile "${MY_HTDOCSDIR}"/${f}
done
- webapp_hook_script ${FILESDIR}/reconfig
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_postupgrade_txt en ${FILESDIR}/postupgrade-en.txt
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
webapp_src_install
}
@@ -76,8 +72,5 @@ pkg_postinst() {
ewarn "You are _strongly_ encouraged to to read the upgrade guide:"
ewarn "http://twiki.org/cgi-bin/view/TWiki/TWikiDocumentation"
ewarn
- elog "webapp-config will not be run automatically"
- elog "Run webapp-config -I -h <host> -d ${PN} ${PN} ${PVR} to install"
- elog
- # webapp_pkg_postinst
+ webapp_pkg_postinst
}
diff --git a/www-apps/twiki/twiki-4.2.0.ebuild b/www-apps/twiki/twiki-4.2.0.ebuild
new file mode 100644
index 000000000000..c675c0037f45
--- /dev/null
+++ b/www-apps/twiki/twiki-4.2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/twiki-4.2.0.ebuild,v 1.1 2008/02/24 00:00:38 hollow Exp $
+
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit webapp
+
+MY_PN="TWiki"
+
+DESCRIPTION="A Web Based Collaboration Platform"
+HOMEPAGE="http://twiki.org/"
+SRC_URI="http://twiki.org/p/pub/Codev/Release/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+RDEPEND=">=app-text/rcs-5.7
+ sys-apps/diffutils
+ >=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff
+ dev-perl/CGI-Session
+ dev-perl/Digest-SHA1
+ dev-perl/HTML-Parser
+ dev-perl/locale-maketext-lexicon
+ dev-perl/Text-Diff
+ dev-perl/URI
+ virtual/cron
+ >=virtual/perl-CGI-3.20
+ virtual/perl-digest-base
+ virtual/perl-File-Spec
+ virtual/perl-libnet
+ virtual/perl-Time-Local"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc AUTHORS COPYRIGHT readme.txt
+ dohtml T*.html INSTALL.html
+ rm -f readme.txt T*.html INSTALL.html
+
+ mv bin/LocalLib.cfg{.txt,}
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for f in $(find data pub); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${f}
+ done
+
+ for f in bin/setlib.cfg bin/LocalLib.cfg; do
+ webapp_configfile "${MY_HTDOCSDIR}"/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version of TWiki, back up your"
+ ewarn "data/ and pub/ directories and any local changes before upgrading!"
+ ewarn
+ ewarn "You are _strongly_ encouraged to to read the upgrade guide:"
+ ewarn "http://twiki.org/cgi-bin/view/TWiki/TWikiDocumentation"
+ ewarn
+ webapp_pkg_postinst
+}