summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-12-29 13:01:25 +0000
committerStuart Herbert <stuart@gentoo.org>2004-12-29 13:01:25 +0000
commitef122adf184cce739712035d6cdfff641dcb23d3 (patch)
tree408c065a8223353a9194d39d69dc4f1595603a86 /www-apps/phprojekt/phprojekt-4.2-r2.ebuild
parentrepoman not committing manifest (Manifest recommit) (diff)
downloadgentoo-2-ef122adf184cce739712035d6cdfff641dcb23d3.tar.gz
gentoo-2-ef122adf184cce739712035d6cdfff641dcb23d3.tar.bz2
gentoo-2-ef122adf184cce739712035d6cdfff641dcb23d3.zip
Security fix; see bug #75858
Diffstat (limited to 'www-apps/phprojekt/phprojekt-4.2-r2.ebuild')
-rw-r--r--www-apps/phprojekt/phprojekt-4.2-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/phprojekt/phprojekt-4.2-r2.ebuild b/www-apps/phprojekt/phprojekt-4.2-r2.ebuild
new file mode 100644
index 000000000000..2c49dd717099
--- /dev/null
+++ b/www-apps/phprojekt/phprojekt-4.2-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-4.2-r2.ebuild,v 1.1 2004/12/29 13:01:25 stuart Exp $
+
+inherit webapp
+
+DESCRIPTION="Project management and coordination system"
+HOMEPAGE="http://www.phprojekt.com/"
+IUSE="postgres mysql"
+SRC_URI="mirror://gentoo/${P}.tar.gz http://phprojekt.com/files/4.2/setup.zip http://phprojekt.com/files/4.2/lib.zip"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+RDEPEND="net-www/apache
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ virtual/php"
+
+src_unpack () {
+ unpack ${A}
+
+ # patch for security flaw - see bug #73021
+ cp ${WORKDIR}/setup.php ${S}
+
+ # patch for security flaw - see bug #75858
+ cp ${WORKDIR}/authform.inc.php ${S}/lib/
+ cp ${WORKDIR}/gpcs_vars.inc.php ${S}/lib/
+}
+
+pkg_setup () {
+ webapp_pkg_setup
+ einfo "Please make sure that your PHP is compiled with support for IMAP and your database of choice"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog install readme
+ rm -f ChangeLog install readme
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ for file in chat attach upload; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${file}
+ done
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}