summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-11-21 22:01:32 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-11-21 22:01:32 +0000
commit73f1141377dbb88c09a0d84de7d80aaad1596769 (patch)
tree80cca982b88353119e633e0ea2b594572b161e5d /www-apps/otrs
parentVersion bump, see bug #150421. (diff)
downloadgentoo-2-73f1141377dbb88c09a0d84de7d80aaad1596769.tar.gz
gentoo-2-73f1141377dbb88c09a0d84de7d80aaad1596769.tar.bz2
gentoo-2-73f1141377dbb88c09a0d84de7d80aaad1596769.zip
Version bump
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'www-apps/otrs')
-rw-r--r--www-apps/otrs/ChangeLog7
-rw-r--r--www-apps/otrs/files/digest-otrs-2.1.33
-rw-r--r--www-apps/otrs/otrs-2.1.3.ebuild119
3 files changed, 128 insertions, 1 deletions
diff --git a/www-apps/otrs/ChangeLog b/www-apps/otrs/ChangeLog
index 16f63e3d07b3..0132310e9671 100644
--- a/www-apps/otrs/ChangeLog
+++ b/www-apps/otrs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/otrs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.23 2006/10/27 15:12:25 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.24 2006/11/21 22:01:32 rl03 Exp $
+
+*otrs-2.1.3 (21 Nov 2006)
+
+ 21 Nov 2006; Renat Lumpau <rl03@gentoo.org> +otrs-2.1.3.ebuild:
+ Version bump
*otrs-2.1.2 (27 Oct 2006)
diff --git a/www-apps/otrs/files/digest-otrs-2.1.3 b/www-apps/otrs/files/digest-otrs-2.1.3
new file mode 100644
index 000000000000..116a78a4f22c
--- /dev/null
+++ b/www-apps/otrs/files/digest-otrs-2.1.3
@@ -0,0 +1,3 @@
+MD5 16ce641d7bee277d25c9a391171bcbf7 otrs-2.1.3.tar.bz2 12602207
+RMD160 1f14ba0b3adca976927b34a1c3f035c18c59ab59 otrs-2.1.3.tar.bz2 12602207
+SHA256 c8ac296f74db61bb4d81f071fe6b105687645adeb07b8089c91d684ff6875ac3 otrs-2.1.3.tar.bz2 12602207
diff --git a/www-apps/otrs/otrs-2.1.3.ebuild b/www-apps/otrs/otrs-2.1.3.ebuild
new file mode 100644
index 000000000000..d2373d25c2f9
--- /dev/null
+++ b/www-apps/otrs/otrs-2.1.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.1.3.ebuild,v 1.1 2006/11/21 22:01:32 rl03 Exp $
+
+inherit webapp eutils
+
+IUSE="mysql postgres fastcgi apache2 ldap gd pdf"
+
+DESCRIPTION="OTRS is an Open source Ticket Request System"
+HOMEPAGE="http://otrs.org/"
+SRC_URI="ftp://ftp.otrs.org/pub/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ ${DEPEND}
+ =dev-lang/perl-5*
+ dev-perl/Date-Pcalc
+ dev-perl/TimeDate
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/DBI
+ virtual/perl-CGI
+ virtual/perl-Digest-MD5
+ dev-perl/libwww-perl
+ dev-perl/IO-stringy
+ virtual/perl-MIME-Base64
+ dev-perl/MIME-tools
+ dev-perl/MailTools
+ dev-perl/Net-DNS
+ virtual/perl-libnet
+ dev-perl/Authen-SASL
+ dev-perl/XML-Parser
+ virtual/mta
+ pdf? ( dev-perl/PDF-API2 )
+ ldap? ( dev-perl/perl-ldap net-nds/openldap )
+ mysql? ( dev-db/mysql dev-perl/DBD-mysql )
+ postgres? ( dev-db/postgresql dev-perl/DBD-Pg )
+ apache2? ( >=net-www/apache-2
+ fastcgi? ( dev-perl/FCGI net-www/mod_fastcgi )
+ !fastcgi? ( =www-apache/libapreq2-2* ) )
+ !apache2? ( =net-www/apache-1*
+ fastcgi? ( dev-perl/FCGI net-www/mod_fastcgi )
+ !fastcgi? ( =www-apache/libapreq-1* ) )
+ gd? ( dev-perl/GD dev-perl/GDTextUtil dev-perl/GDGraph )
+"
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser otrs -1 -1 /dev/null apache
+}
+
+src_unpack() {
+ unpack ${A}
+ cp ${S}/Kernel/Config.pm.dist ${S}/Kernel/Config.pm
+
+ # http://bugs.otrs.org/show_bug.cgi?id=1231
+ cd ${S}
+ epatch ${FILESDIR}/dbi_finish.patch
+
+ cd ${S}/Kernel/Config/
+ for foo in *.dist; do cp ${foo} $(basename ${foo} .dist); done
+
+ cd ${S}/scripts
+ rm -rf auto_* redhat* suse*
+
+ if use fastcgi; then
+ if ! use apache2; then
+ epatch ${FILESDIR}/apache1.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache-httpd.include.conf
+ fi
+ if use apache2; then
+ epatch ${FILESDIR}/apache2.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
+ fi
+ sed -e "s|index.pl|index.fpl|" -i ${S}/var/httpd/htdocs/index.html
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PF}
+
+ # install documentation
+ dodoc CHANGES CREDITS INSTALL README* TODO UPGRADING \
+ doc/otrs-database.dia doc/test-* doc/X-OTRS-Headers.txt \
+ .fetchmailrc.dist .mailfilter.dist .procmailrc.dist
+ dohtml doc/manual/{en,de}/html/*
+
+ # copy main files
+ cp -R .fetchmailrc.dist .mailfilter.dist .procmailrc.dist RELEASE Kernel bin scripts var ${D}/${MY_HOSTROOTDIR}/${PF}
+ mv ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd/htdocs/* ${D}/${MY_HTDOCSDIR}
+
+ # remove stuff from ${D} that shouldn't be there
+ rm -rf ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd
+
+ # keep some empty dirs
+ local a
+ local d="article log pics/images pics/stats pics sessions spool tmp"
+ for a in ${d}; do
+ keepdir ${MY_HOSTROOTDIR}/${PF}/var/${a}
+ done
+
+ # helpers
+ webapp_configfile ${MY_HOSTROOTDIR}/${PF}/Kernel/Config.pm
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "webapp-config will not be run automatically"
+ ewarn "That messes up Apache configs"
+ ewarn "Don't run webapp-config with -d otrs. Instead, try"
+ ewarn "webapp-config -I -h <host> -d ot ${PN} ${PVR}"
+ ewarn
+ # webapp_pkg_postinst
+}