summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-12-09 09:02:31 +0000
committerTim Harder <radhermit@gentoo.org>2010-12-09 09:02:31 +0000
commitfc7de128f4b99e49dcb91631c437b5897824bdd3 (patch)
tree3e58dc77d9e764411bb17dd87343bb6a3df3fdf2 /www-apps/gallery
parentstable x86, security bug 345559 (diff)
downloadgentoo-2-fc7de128f4b99e49dcb91631c437b5897824bdd3.tar.gz
gentoo-2-fc7de128f4b99e49dcb91631c437b5897824bdd3.tar.bz2
gentoo-2-fc7de128f4b99e49dcb91631c437b5897824bdd3.zip
Version bump (bug #299307 by Chan Min Wai). Allow media-gfx/graphicsmagick[imagemagick] to satisfy the imagemagick dependency (bug #314387 by Wojciech Porczyk) and allow mysql or mysqli USE flags for php (bug #286636).
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog10
-rw-r--r--www-apps/gallery/gallery-2.3.1.ebuild63
2 files changed, 72 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 0c5b8522c40c..3c7741e96388 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/gallery
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.176 2010/12/09 08:19:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.177 2010/12/09 09:02:31 radhermit Exp $
+
+*gallery-2.3.1 (09 Dec 2010)
+
+ 09 Dec 2010; Tim Harder <radhermit@gentoo.org> +gallery-2.3.1.ebuild:
+ Version bump (bug #299307 by Chan Min Wai). Allow
+ media-gfx/graphicsmagick[imagemagick] to satisfy the imagemagick dependency
+ (bug #314387 by Wojciech Porczyk) and allow mysql or mysqli USE flags for php
+ (bug #286636).
09 Dec 2010; Tim Harder <radhermit@gentoo.org> gallery-2.3-r2.ebuild:
Fix mysql and postgres USE flag dependencies (bug #326883 by Diego E.
diff --git a/www-apps/gallery/gallery-2.3.1.ebuild b/www-apps/gallery/gallery-2.3.1.ebuild
new file mode 100644
index 000000000000..13744017d271
--- /dev/null
+++ b/www-apps/gallery/gallery-2.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.3.1.ebuild,v 1.1 2010/12/09 09:02:31 radhermit Exp $
+
+EAPI="2"
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw sqlite unzip zip"
+
+RDEPEND="raw? ( media-gfx/dcraw )
+ ffmpeg? ( media-video/ffmpeg )
+ imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )
+ netpbm? ( media-libs/netpbm media-gfx/jhead )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+ sqlite? ( dev-lang/php[pdo] )
+ gd? ( || ( dev-lang/php[gd] dev-lang/php[gd-external] ) )
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ dev-lang/php[mysql?,session,postgres?,sqlite?]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres sqlite
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE
+ sed -i -e "/^LICENSE\>/d" -e "/^README\.html\>/d" MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading may make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}