summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-08-21 15:35:14 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-08-21 15:35:14 +0000
commit4985ecb14e185fd7da0416a429ee58d9fe429919 (patch)
treeca321ec0d3a080c01b9628ea7f48f64cbb7cf973 /www-apps/gallery
parentVersion bump, bug #144340. (diff)
downloadgentoo-2-4985ecb14e185fd7da0416a429ee58d9fe429919.tar.gz
gentoo-2-4985ecb14e185fd7da0416a429ee58d9fe429919.tar.bz2
gentoo-2-4985ecb14e185fd7da0416a429ee58d9fe429919.zip
Version bumps, bug #144379.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog9
-rw-r--r--www-apps/gallery/files/digest-gallery-1.5.43
-rw-r--r--www-apps/gallery/files/digest-gallery-2.1.23
-rw-r--r--www-apps/gallery/gallery-1.5.4.ebuild38
-rw-r--r--www-apps/gallery/gallery-2.1.2.ebuild84
5 files changed, 136 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index a91c312e2787..1d68f3d7ff33 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.96 2006/07/24 22:14:32 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.97 2006/08/21 15:35:14 rl03 Exp $
+
+*gallery-2.1.2 (21 Aug 2006)
+*gallery-1.5.4 (21 Aug 2006)
+
+ 21 Aug 2006; Renat Lumpau <rl03@gentoo.org> +gallery-1.5.4.ebuild,
+ -gallery-2.1.1a.ebuild, +gallery-2.1.2.ebuild:
+ Version bumps, bug #144379.
24 Jul 2006; Renat Lumpau <rl03@gentoo.org> gallery-2.1.1a.ebuild:
Better detect PHP use flags when USE="gd" (bug #141343).
diff --git a/www-apps/gallery/files/digest-gallery-1.5.4 b/www-apps/gallery/files/digest-gallery-1.5.4
new file mode 100644
index 000000000000..4e29a7f54786
--- /dev/null
+++ b/www-apps/gallery/files/digest-gallery-1.5.4
@@ -0,0 +1,3 @@
+MD5 1fa40c8dd944471b24c7bd2b78444e49 gallery-1.5.4.tar.gz 2371082
+RMD160 4866d55f2b04db44d2c61da40ebe9df8dc039d0d gallery-1.5.4.tar.gz 2371082
+SHA256 c5c92e08e83bcb48f34e1ebc51633de0cb5f20f007f2f988d40c831a97e848f7 gallery-1.5.4.tar.gz 2371082
diff --git a/www-apps/gallery/files/digest-gallery-2.1.2 b/www-apps/gallery/files/digest-gallery-2.1.2
new file mode 100644
index 000000000000..a3b92114a1fc
--- /dev/null
+++ b/www-apps/gallery/files/digest-gallery-2.1.2
@@ -0,0 +1,3 @@
+MD5 c394014997bfed2fc45cdd73124871a5 gallery-2.1.2-full.tar.gz 8061300
+RMD160 46ed198fb5f7d5968d7216b4f73d6d3b8182deac gallery-2.1.2-full.tar.gz 8061300
+SHA256 84aa2a164cc684c0923d4da6f9b418975d823690c399baf1dd41477f3ec428f2 gallery-2.1.2-full.tar.gz 8061300
diff --git a/www-apps/gallery/gallery-1.5.4.ebuild b/www-apps/gallery/gallery-1.5.4.ebuild
new file mode 100644
index 000000000000..103ca4c505c4
--- /dev/null
+++ b/www-apps/gallery/gallery-1.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.4.ebuild,v 1.1 2006/08/21 15:35:14 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="imagemagick netpbm unzip zip"
+
+RDEPEND=">=net-www/apache-1.3.24-r1
+ virtual/php
+ media-libs/jpeg
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R * ${D}/${MY_HTDOCSDIR}
+ for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
+ dodoc ${file}
+ rm -f ${D}/${MY_HTDOCSDIR}/${file}
+ done
+ dohtml docs/*
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/gallery/gallery-2.1.2.ebuild b/www-apps/gallery/gallery-2.1.2.ebuild
new file mode 100644
index 000000000000..c2876b8d07b6
--- /dev/null
+++ b/www-apps/gallery/gallery-2.1.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.1.2.ebuild,v 1.1 2006/08/21 15:35:14 rl03 Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="dcraw ffmpeg gd imagemagick mysql netpbm postgres unzip zip"
+
+RDEPEND="virtual/httpd-php
+ media-libs/jpeg
+ dcraw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ gd? ( >=media-libs/gd-2 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ mysql? ( dev-db/mysql )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ postgres? ( >=dev-db/postgresql-7 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+"
+
+S=${WORKDIR}/${PN}2
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ local php_flags="session"
+ local DIE=
+
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags}; then
+ DIE="yes"
+ fi
+ if use gd; then
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ DIE="yes"
+ fi
+ fi
+
+ if [[ ${DIE} == "yes" ]]; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ if use gd; then
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "gd gd-external"
+ eerror
+ fi
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R * ${D}/${MY_HTDOCSDIR}
+ dohtml README.html
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en2.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.1.x will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}