summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-27 12:01:41 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-27 12:01:41 +0000
commit236534b8deb1f493ceb9a8dae11f11dbc5b07640 (patch)
treea3bbc08c8ac8fb2005747323ea4aa7be485e72d6 /www-apps/gallery
parentx86 stable wrt #256415 (diff)
downloadgentoo-2-236534b8deb1f493ceb9a8dae11f11dbc5b07640.tar.gz
gentoo-2-236534b8deb1f493ceb9a8dae11f11dbc5b07640.tar.bz2
gentoo-2-236534b8deb1f493ceb9a8dae11f11dbc5b07640.zip
Added sqlite support, bug #247271, thank Marcin Deranek for report. Sqlite support is a bit experimental, so I'd like it to be ~arch for some time.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog10
-rw-r--r--www-apps/gallery/gallery-2.3-r1.ebuild72
2 files changed, 80 insertions, 2 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 9a2ae8e680bb..27081c8f7a4a 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/gallery
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.173 2008/12/28 21:04:58 wrobel Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.174 2009/01/27 12:01:41 pva Exp $
+
+*gallery-2.3-r1 (27 Jan 2009)
+
+ 27 Jan 2009; Peter Volkov <pva@gentoo.org> +gallery-2.3-r1.ebuild:
+ Added sqlite support, bug #247271, thank Marcin Deranek for report. Sqlite
+ support is a bit experimental, so I'd like it to be ~arch for some time.
28 Dec 2008; Gunnar Wrobel <wrobel@gentoo.org> -gallery-1.5.9.ebuild:
Removed vulnerable www-apps/gallery-1.5.9 (sec issue #249277).
diff --git a/www-apps/gallery/gallery-2.3-r1.ebuild b/www-apps/gallery/gallery-2.3-r1.ebuild
new file mode 100644
index 000000000000..4fcd0327c0dc
--- /dev/null
+++ b/www-apps/gallery/gallery-2.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.3-r1.ebuild,v 1.1 2009/01/27 12:01:41 pva Exp $
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw sqlite unzip zip"
+
+RDEPEND="raw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ imagemagick? ( >media-gfx/imagemagick-6.2.4 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres sqlite
+
+ local php_flags="pcre session"
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+ use sqlite && php_flags="${php_flags} pdo"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
+ ( use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ use gd && eerror "as well as with either gd or gd-external USE flag enabled."
+ die "Re-install ${PHP_PKG}."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE
+ sed -i -e "/^LICENSE\>/d" -e "/^README\.html\>/d" MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}