summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-09 08:37:18 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-09 08:37:18 +0000
commitc2fdbdf32362418d8cfec77239329dd2fa0ae048 (patch)
treedb52b7b4275af51d2f3405f8feb6b8edaca2ece8 /www-apache
parentsupport apache 2.4 (#532822) (diff)
downloadgentoo-2-c2fdbdf32362418d8cfec77239329dd2fa0ae048.tar.gz
gentoo-2-c2fdbdf32362418d8cfec77239329dd2fa0ae048.tar.bz2
gentoo-2-c2fdbdf32362418d8cfec77239329dd2fa0ae048.zip
Support apache 2.4 (#532824)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_extract_forwarded/ChangeLog10
-rw-r--r--www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/www-apache/mod_extract_forwarded/ChangeLog b/www-apache/mod_extract_forwarded/ChangeLog
index 4ad9d5e54fbb..6eadc3731361 100644
--- a/www-apache/mod_extract_forwarded/ChangeLog
+++ b/www-apache/mod_extract_forwarded/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_extract_forwarded
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_extract_forwarded/ChangeLog,v 1.7 2014/08/10 20:15:28 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_extract_forwarded/ChangeLog,v 1.8 2015/05/09 08:37:18 pacho Exp $
+
+*mod_extract_forwarded-2.0.3_pre2015052015 (09 May 2015)
+
+ 09 May 2015; Pacho Ramos <pacho@gentoo.org>
+ +mod_extract_forwarded-2.0.3_pre2015052015.ebuild:
+ Support apache 2.4 (#532824)
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
mod_extract_forwarded-2.0.2.ebuild:
diff --git a/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild b/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
new file mode 100644
index 000000000000..515599079d80
--- /dev/null
+++ b/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild,v 1.1 2015/05/09 08:37:18 pacho Exp $
+
+EAPI=5
+inherit apache-module
+
+DESCRIPTION="Apache module that rewrites X-Forwarded-For to REMOTE_ADDR for reverse proxy configurations"
+HOMEPAGE="http://www.openinfo.co.uk/apache/index.html"
+#SRC_URI="http://www.openinfo.co.uk/apache/extract_forwarded-${PV}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mod_proxy"
+
+DEPEND=""
+RDEPEND="mod_proxy? ( www-servers/apache[apache2_modules_proxy_connect] )"
+
+APACHE2_MOD_CONF="98_${PN}"
+APACHE2_MOD_DEFINE="EXTRACT_FORWARDED"
+
+need_apache2
+
+src_prepare() {
+ if ! use mod_proxy; then
+ sed -i -e 's:#define USING_proxy_http_module .*::' mod_extract_forwarded.c || die
+ fi
+}