summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-03-15 20:13:40 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-03-15 20:13:40 +0000
commita0ea0877e138ea046e02787445e9f9b78b121790 (patch)
tree388cc889fbbb89279b65026b4038e6d12dbac779 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-a0ea0877e138ea046e02787445e9f9b78b121790.tar.gz
gentoo-2-a0ea0877e138ea046e02787445e9f9b78b121790.tar.bz2
gentoo-2-a0ea0877e138ea046e02787445e9f9b78b121790.zip
Version bump.
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/ChangeLog8
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.15.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index ec23623efd54..ffa7ba6a625b 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.59 2011/03/15 19:34:51 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.60 2011/03/15 20:13:40 nelchael Exp $
+
+*mod_caucho-4.0.15 (15 Mar 2011)
+
+ 15 Mar 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ +mod_caucho-4.0.15.ebuild:
+ Version bump.
15 Mar 2011; Krzysztof Pawlik <nelchael@gentoo.org>
-mod_caucho-3.0.25.ebuild, -mod_caucho-3.1.8.ebuild,
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.15.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.15.ebuild
new file mode 100644
index 000000000000..27370fd6c3b1
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-4.0.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.15.ebuild,v 1.1 2011/03/15 20:13:40 nelchael Exp $
+
+EAPI="2"
+
+inherit eutils apache-module autotools
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
+
+need_apache2
+
+src_prepare() {
+ for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
+ epatch "${i}"
+ done
+
+ mkdir m4
+ eautoreconf
+ chmod 755 ./configure
+}
+
+src_configure() {
+ econf --with-apxs=${APXS} || die "econf failed"
+}
+
+src_compile() {
+ emake -C "${S}/modules/c/src/apache2/" || die "emake failed"
+}