summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-03-30 22:52:28 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-03-30 22:52:28 +0000
commit8a8eaf2aae1a043918a4ab1d35c5e16a2f5bd70c (patch)
tree2773aa9daba417e0319cab095145dc83eb04547a /www-apache
parentBug 172293, version bump (diff)
downloadgentoo-2-8a8eaf2aae1a043918a4ab1d35c5e16a2f5bd70c.tar.gz
gentoo-2-8a8eaf2aae1a043918a4ab1d35c5e16a2f5bd70c.tar.bz2
gentoo-2-8a8eaf2aae1a043918a4ab1d35c5e16a2f5bd70c.zip
Bug 172676
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_perl/ChangeLog8
-rw-r--r--www-apache/mod_perl/files/1.30/75_mod_perl.conf6
-rw-r--r--www-apache/mod_perl/files/digest-mod_perl-1.303
-rw-r--r--www-apache/mod_perl/mod_perl-1.30.ebuild71
4 files changed, 87 insertions, 1 deletions
diff --git a/www-apache/mod_perl/ChangeLog b/www-apache/mod_perl/ChangeLog
index 8c7e6bb05184..fa441336633e 100644
--- a/www-apache/mod_perl/ChangeLog
+++ b/www-apache/mod_perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_perl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.37 2007/02/23 14:19:22 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.38 2007/03/30 22:52:28 mcummings Exp $
+
+*mod_perl-1.30 (30 Mar 2007)
+
+ 30 Mar 2007; Michael Cummings <mcummings@gentoo.org>
+ +files/1.30/75_mod_perl.conf, +mod_perl-1.30.ebuild:
+ Bug 172676
23 Feb 2007; Michael Cummings <mcummings@gentoo.org>
mod_perl-2.0.2.ebuild, mod_perl-2.0.3.ebuild:
diff --git a/www-apache/mod_perl/files/1.30/75_mod_perl.conf b/www-apache/mod_perl/files/1.30/75_mod_perl.conf
new file mode 100644
index 000000000000..edf5a11b5c1f
--- /dev/null
+++ b/www-apache/mod_perl/files/1.30/75_mod_perl.conf
@@ -0,0 +1,6 @@
+<IfDefine PERL>
+ <IfModule !mod_perl.c>
+ LoadModule perl_module modules/libperl.so
+ </IfModule>
+</IfDefine>
+
diff --git a/www-apache/mod_perl/files/digest-mod_perl-1.30 b/www-apache/mod_perl/files/digest-mod_perl-1.30
new file mode 100644
index 000000000000..db5fcc7e80bb
--- /dev/null
+++ b/www-apache/mod_perl/files/digest-mod_perl-1.30
@@ -0,0 +1,3 @@
+MD5 bfd6f6cff1ab1cc3dbb58a236701d169 mod_perl-1.30.tar.gz 389029
+RMD160 f71613f2fc386e56e49c165123e8d2226f37e7fc mod_perl-1.30.tar.gz 389029
+SHA256 af6e1380a9197750b2d443f02a7a0dba3586c3fc0c8269beaafef09159184a08 mod_perl-1.30.tar.gz 389029
diff --git a/www-apache/mod_perl/mod_perl-1.30.ebuild b/www-apache/mod_perl/mod_perl-1.30.ebuild
new file mode 100644
index 000000000000..ab1735452818
--- /dev/null
+++ b/www-apache/mod_perl/mod_perl-1.30.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-1.30.ebuild,v 1.1 2007/03/30 22:52:28 mcummings Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="A Perl Module for Apache"
+SRC_URI="http://perl.apache.org/dist/${P}.tar.gz"
+HOMEPAGE="http://perl.apache.org"
+
+SLOT="0"
+LICENSE="Apache-1.1 as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+APACHE1_MOD_DEFINE="PERL"
+APACHE1_MOD_CONF="${PV}/75_mod_perl"
+APACHE1_MOD_FILE="${S}/apaci/libperl.so"
+
+IUSE=""
+
+need_apache1
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ for f in "apaci/mod_perl.config.sh" "apaci/libperl.module"
+ do
+ echo "tail -1 fix in ${f}"
+ sed -i -e "s/tail -1/tail -n1/" ${f}
+ done
+}
+
+src_compile() {
+ perl Makefile.PL USE_APXS=1 \
+ INSTALLDIRS=vendor \
+ WITH_APXS=${APXS1} EVERYTHING=1 PERL_DEBUG=1
+
+ cp Makefile Makefile.orig
+ sed -e "s:apxs_install doc_install:doc_install:" Makefile.orig > Makefile
+ emake -j1 || die
+}
+
+src_install () {
+ eval `perl '-V:installvendorarch'`
+ eval `perl '-V:installvendorlib'`
+
+ make \
+ PREFIX=${D}/usr \
+ INSTALLVENDORARCH=${D}/${installvendorarch} \
+ INSTALLVENDORLIB=${D}/${installvendorlib} \
+ INSTALLVENDORMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLVENDORMAN3DIR=${D}/usr/share/man/man3 \
+ pure_vendor_install || die
+
+ dodoc Changes CREDITS MANIFEST README SUPPORT ToDo
+ dohtml -r ./
+ # The following kludge is from the perl-module eclass to correct
+ # the packlist file. packlist is used by other apps to determine
+ # where to find parts of mod-perl
+ for FILE in `find ${D} -type f -name "*.html" -o -name ".packlist"`; do
+ sed -i -e "s:${D}:/:g" ${FILE}
+ done
+
+ apache-module_src_install
+
+ fperms 600 ${APACHE1_MODULES_CONFDIR}/$(basename ${APACHE1_MOD_CONF})
+}