summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-08 18:35:00 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-08 18:35:00 +0000
commit0fe6ddc2f7f91a9eb81debe81f7f0353d8b13f4b (patch)
tree5aaeaac451d19cbc8b1ab0f88adec742406c4db0 /www-apache/mod_qos
parentRevision bump, add DEPEND on app-text/pandoc. (diff)
downloadgentoo-2-0fe6ddc2f7f91a9eb81debe81f7f0353d8b13f4b.tar.gz
gentoo-2-0fe6ddc2f7f91a9eb81debe81f7f0353d8b13f4b.tar.bz2
gentoo-2-0fe6ddc2f7f91a9eb81debe81f7f0353d8b13f4b.zip
Version bump (#356435 by Marcin Mirosław and Toffanin)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-apache/mod_qos')
-rw-r--r--www-apache/mod_qos/ChangeLog9
-rw-r--r--www-apache/mod_qos/mod_qos-11.12.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/www-apache/mod_qos/ChangeLog b/www-apache/mod_qos/ChangeLog
index 126834dad209..637cd668db92 100644
--- a/www-apache/mod_qos/ChangeLog
+++ b/www-apache/mod_qos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_qos
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_qos/ChangeLog,v 1.3 2012/11/27 19:29:00 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_qos/ChangeLog,v 1.4 2015/05/08 18:35:00 pacho Exp $
+
+*mod_qos-11.12 (08 May 2015)
+
+ 08 May 2015; Pacho Ramos <pacho@gentoo.org> +mod_qos-11.12.ebuild:
+ Version bump (#356435 by Marcin Mirosław and Toffanin)
27 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop apache herd as discussed in http://www.gossamer-
diff --git a/www-apache/mod_qos/mod_qos-11.12.ebuild b/www-apache/mod_qos/mod_qos-11.12.ebuild
new file mode 100644
index 000000000000..9080c70837d9
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_qos/mod_qos-11.12.ebuild,v 1.1 2015/05/08 18:35:00 pacho Exp $
+
+EAPI="5"
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/openssl:0
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${DEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+src_prepare() {
+ cd "${S}/tools" && eautoreconf
+}
+
+src_configure() {
+ cd "${S}/tools" && econf
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}/tools"
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ cd "${S}/tools"
+ apache-module_src_install
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}/tools" install DESTDIR="${D}"
+
+ # installing html documentation
+ dohtml -r -x *.txt "${S}/doc/"
+}