summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-25 01:42:56 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-25 01:42:56 +0000
commit420fd6298cb61bc90ac7e8adf6c96e9fc4c4f6c5 (patch)
tree528e9ba1b9e185845713b2210a8e9451dc8706b5 /www-apache/mod_python/mod_python-3.3.1-r1.ebuild
parentStable for HPPA (bug #222219). (diff)
downloadgentoo-2-420fd6298cb61bc90ac7e8adf6c96e9fc4c4f6c5.tar.gz
gentoo-2-420fd6298cb61bc90ac7e8adf6c96e9fc4c4f6c5.tar.bz2
gentoo-2-420fd6298cb61bc90ac7e8adf6c96e9fc4c4f6c5.zip
Revision bump. Closes bug #230211. Thanks Cilly <cilly@cilly.mine.nu> for the patch
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apache/mod_python/mod_python-3.3.1-r1.ebuild')
-rw-r--r--www-apache/mod_python/mod_python-3.3.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/www-apache/mod_python/mod_python-3.3.1-r1.ebuild b/www-apache/mod_python/mod_python-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..dd554ca98e76
--- /dev/null
+++ b/www-apache/mod_python/mod_python-3.3.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.3.1-r1.ebuild,v 1.1 2008/08/25 01:42:55 neurogeek Exp $
+
+inherit eutils python apache-module multilib
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+DESCRIPTION="An Apache2 module providing an embedded Python interpreter."
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="mirror://apache/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="16_${PN}"
+APACHE2_MOD_DEFINE="PYTHON"
+
+DOCFILES="README NEWS CREDITS"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-apr_brigade_sentinel.patch"
+ # Remove optimisations, we do that outside Portage
+ sed -i -e 's:--optimize 2:--no-compile:' dist/Makefile.in
+}
+
+src_compile() {
+ econf --with-apxs=${APXS} || die "econf failed"
+ sed -i -e 's/ -Wl,--hash-style $//' src/Makefile
+ emake OPT="`apxs2 -q CFLAGS` -fPIC" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dohtml -r doc-html/*
+ apache-module_src_install
+}
+
+src_test() {
+ python_version
+ cd test
+ PYTHONPATH="$(ls -d ${S}/dist/build/lib.*)"
+ sed -i \
+ -e "120ios.environ['PYTHONPATH']=\"${PYTHONPATH}\"" \
+ test.py || die "sed failed"
+ "${python}" test.py || die "tests failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize $(python_get_sitedir)/mod_python
+ apache-module_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/mod_python
+}