summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-10-14 17:11:32 +0000
committerSteve Dibb <beandog@gentoo.org>2011-10-14 17:11:32 +0000
commit9f5a787496c6795f48e4e08e308f38fc61eac9d6 (patch)
tree470816c1856ee5508aa6c650aa7c6f0f23afed6f /www-apache/mod_musicindex
parentNew Apache module. Original ebuild by Lance Albertson. bug 304675 (diff)
downloadgentoo-2-9f5a787496c6795f48e4e08e308f38fc61eac9d6.tar.gz
gentoo-2-9f5a787496c6795f48e4e08e308f38fc61eac9d6.tar.bz2
gentoo-2-9f5a787496c6795f48e4e08e308f38fc61eac9d6.zip
Version bump, bug 377951
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_musicindex')
-rw-r--r--www-apache/mod_musicindex/ChangeLog9
-rw-r--r--www-apache/mod_musicindex/mod_musicindex-1.3.5.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/www-apache/mod_musicindex/ChangeLog b/www-apache/mod_musicindex/ChangeLog
index 17fa07d78fd2..3f9d2819e81d 100644
--- a/www-apache/mod_musicindex/ChangeLog
+++ b/www-apache/mod_musicindex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_musicindex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_musicindex/ChangeLog,v 1.2 2010/06/15 13:16:23 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_musicindex/ChangeLog,v 1.3 2011/10/14 17:11:32 beandog Exp $
+
+*mod_musicindex-1.3.5 (14 Oct 2011)
+
+ 14 Oct 2011; Steve Dibb <beandog@gentoo.org> +mod_musicindex-1.3.5.ebuild:
+ Version bump, bug 377951
15 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
mod_musicindex-1.2.5.ebuild:
diff --git a/www-apache/mod_musicindex/mod_musicindex-1.3.5.ebuild b/www-apache/mod_musicindex/mod_musicindex-1.3.5.ebuild
new file mode 100644
index 000000000000..2f8b27eadc00
--- /dev/null
+++ b/www-apache/mod_musicindex/mod_musicindex-1.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_musicindex/mod_musicindex-1.3.5.ebuild,v 1.1 2011/10/14 17:11:32 beandog Exp $
+
+EAPI="2"
+
+inherit apache-module
+
+DESCRIPTION="mod_musicindex allows nice displaying of directories containing music files"
+HOMEPAGE="http://www.parisc-linux.org/~varenet/musicindex/"
+SRC_URI="http://www.parisc-linux.org/~varenet/musicindex/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mp3 +mp4 +flac +vorbis"
+
+DEPEND="mp3? ( media-libs/libmad )
+ mp4? ( media-libs/libmp4v2 )
+ flac? ( media-libs/flac )
+ vorbis? ( media-libs/liboggz )"
+RDEPEND="${DEPEND}
+ sys-devel/libtool"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="MUSICINDEX"
+DOCFILES="AUTHORS BUGS ChangeLog README UPGRADING"
+
+need_apache2
+
+src_configure() {
+ econf \
+ $(use_enable mp3) \
+ $(use_enable mp4) \
+ $(use_enable flac) \
+ $(use_enable vorbis)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ apache-module_src_install
+}