summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-30 21:04:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-30 21:04:25 +0000
commite413004d6a4b4337d31da6408c5a1fc1ef961041 (patch)
tree978662d2591d3a12cfd449d9c519ef8f560d6e21 /www-apache/mod_lisp2
parentversion bump (diff)
downloadgentoo-2-e413004d6a4b4337d31da6408c5a1fc1ef961041.tar.gz
gentoo-2-e413004d6a4b4337d31da6408c5a1fc1ef961041.tar.bz2
gentoo-2-e413004d6a4b4337d31da6408c5a1fc1ef961041.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>; Partially resolves Bug #116672.
(Portage version: 2.1_pre2)
Diffstat (limited to 'www-apache/mod_lisp2')
-rw-r--r--www-apache/mod_lisp2/ChangeLog13
-rw-r--r--www-apache/mod_lisp2/Manifest7
-rw-r--r--www-apache/mod_lisp2/files/1.2-content-length.patch44
-rw-r--r--www-apache/mod_lisp2/files/10_mod_lisp2.conf15
-rw-r--r--www-apache/mod_lisp2/files/README.Gentoo5
-rw-r--r--www-apache/mod_lisp2/files/apache.conf24
-rw-r--r--www-apache/mod_lisp2/files/digest-mod_lisp2-1.21
-rw-r--r--www-apache/mod_lisp2/metadata.xml9
-rw-r--r--www-apache/mod_lisp2/mod_lisp2-1.2.ebuild28
9 files changed, 146 insertions, 0 deletions
diff --git a/www-apache/mod_lisp2/ChangeLog b/www-apache/mod_lisp2/ChangeLog
new file mode 100644
index 000000000000..bda56c375bdd
--- /dev/null
+++ b/www-apache/mod_lisp2/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for www-apache/mod_lisp2
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp2/ChangeLog,v 1.1 2005/12/30 21:04:25 mkennedy Exp $
+
+*mod_lisp2-1.2 (30 Dec 2005)
+
+ 30 Dec 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/1.2-content-length.patch, +files/10_mod_lisp2.conf,
+ +files/README.Gentoo, +files/apache.conf, +metadata.xml,
+ +mod_lisp2-1.2.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>;
+ Partially resolves Bug #116672.
+
diff --git a/www-apache/mod_lisp2/Manifest b/www-apache/mod_lisp2/Manifest
new file mode 100644
index 000000000000..1d8f71a6a9c8
--- /dev/null
+++ b/www-apache/mod_lisp2/Manifest
@@ -0,0 +1,7 @@
+MD5 ed55ab52746f06be4e9da84028cbd68b files/1.2-content-length.patch 1111
+MD5 0934df016f72c1014a1af3c23a98610f files/10_mod_lisp2.conf 258
+MD5 1f3a0bdf19c02dda19ca25e457b2e9e0 files/README.Gentoo 130
+MD5 9612cb5b42a552575760404670303d0f files/apache.conf 543
+MD5 b831dd66b82d22d2c7cbc47b1ac3a6a8 files/digest-mod_lisp2-1.2 59
+MD5 ee3df1ea4e43c452304e380ccd539c06 metadata.xml 251
+MD5 82cd5732f9a7687b468bf4315b950687 mod_lisp2-1.2.ebuild 788
diff --git a/www-apache/mod_lisp2/files/1.2-content-length.patch b/www-apache/mod_lisp2/files/1.2-content-length.patch
new file mode 100644
index 000000000000..dbd867cf0b19
--- /dev/null
+++ b/www-apache/mod_lisp2/files/1.2-content-length.patch
@@ -0,0 +1,44 @@
+--- mod_lisp2.c.orig 2005-12-24 23:04:20.000000000 +0100
++++ mod_lisp2.c 2005-12-24 23:05:09.000000000 +0100
+@@ -58,13 +58,17 @@
+ /*
+ Change log:
+
+- Fixed a declaration for some versions of gcc
+- -- Marc Battyani
+- 2005-08-26
+-
+- Set r->mtime directly
+- -- Dr. Edmund Weitz <edi@agharta.de>
+- 2005-06-07
++ Handle Lisp data correctly if there's no Content-Length header
++ -- Dr. Edmund Weitz <edi@agharta.de>
++ 2005-12-24
++
++ Fixed a declaration for some versions of gcc
++ -- Marc Battyani
++ 2005-08-26
++
++ Set r->mtime directly
++ -- Dr. Edmund Weitz <edi@agharta.de>
++ 2005-06-07
+
+ Read data from Lisp even if it's a HEAD request
+ Added "Lisp-Content-Length" header (send after "Content-Length" header to overwrite its value)
+@@ -88,7 +92,7 @@
+ 2003-12-02
+ */
+
+-#define VERSION_STRING "1.2"
++#define VERSION_STRING "1.3"
+ #define READ_TIMEOUT 60000000
+
+ #include "httpd.h"
+@@ -673,7 +677,6 @@
+ }
+
+ /* Copy the reply entity from Lisp to the client... */
+- if (content_length > 0)
+ {
+ unsigned int n_read = 0;
+ input_buffer_t * buffer;
diff --git a/www-apache/mod_lisp2/files/10_mod_lisp2.conf b/www-apache/mod_lisp2/files/10_mod_lisp2.conf
new file mode 100644
index 000000000000..ee014f89e82b
--- /dev/null
+++ b/www-apache/mod_lisp2/files/10_mod_lisp2.conf
@@ -0,0 +1,15 @@
+<IfDefine LISP>
+ <IfModule !mod_lisp.c>
+ LoadModule lisp_module modules/mod_lisp.so
+ </IfModule>
+</IfDefine>
+
+
+<IfModule mod_lisp.c>
+ LispServer 127.0.0.1 3000 "userdefinedstring"
+
+ <Location /asp>
+ SetHandler lisp-handler
+ </Location>
+
+</IfModule>
diff --git a/www-apache/mod_lisp2/files/README.Gentoo b/www-apache/mod_lisp2/files/README.Gentoo
new file mode 100644
index 000000000000..58d240af67f7
--- /dev/null
+++ b/www-apache/mod_lisp2/files/README.Gentoo
@@ -0,0 +1,5 @@
+A basic Apache configuration example has been included in this port's
+documentation path.
+
+zul @ gentoo.org
+mkennedy @ gentoo.org
diff --git a/www-apache/mod_lisp2/files/apache.conf b/www-apache/mod_lisp2/files/apache.conf
new file mode 100644
index 000000000000..5ec8f6e452f1
--- /dev/null
+++ b/www-apache/mod_lisp2/files/apache.conf
@@ -0,0 +1,24 @@
+
+# This is an example configuration to get you started.
+
+<IfDefine MODLISP>
+ LoadModule lisp_module extramodules/mod_lisp.so
+</IfDefine>
+
+<IfModule mod_lisp.c>
+ LispServer 127.0.0.1 3000 "server1"
+ AddHandler lisp-handler .lsp
+</IfModule>
+
+# In the Common Lisp implementation, the initialization code
+# corresponding to the above would be:
+#
+# (require :modlisp)
+# (ml:modlisp-start :port 3000)
+#
+# Example requests:
+#
+# http://localhost/debug.lsp
+# http://localhost/fixed.lsp
+
+# Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/www-apache/mod_lisp2/files/digest-mod_lisp2-1.2 b/www-apache/mod_lisp2/files/digest-mod_lisp2-1.2
new file mode 100644
index 000000000000..e69643c230a5
--- /dev/null
+++ b/www-apache/mod_lisp2/files/digest-mod_lisp2-1.2
@@ -0,0 +1 @@
+MD5 5d8fffee038fb7e802729b31b32f0670 mod_lisp2-1.2.c 24379
diff --git a/www-apache/mod_lisp2/metadata.xml b/www-apache/mod_lisp2/metadata.xml
new file mode 100644
index 000000000000..7683d2600588
--- /dev/null
+++ b/www-apache/mod_lisp2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+<herd>common-lisp</herd>
+<maintainer>
+ <email>apache-bugs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_lisp2/mod_lisp2-1.2.ebuild b/www-apache/mod_lisp2/mod_lisp2-1.2.ebuild
new file mode 100644
index 000000000000..cf593b957b58
--- /dev/null
+++ b/www-apache/mod_lisp2/mod_lisp2-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_lisp2/mod_lisp2-1.2.ebuild,v 1.1 2005/12/30 21:04:25 mkennedy Exp $
+
+inherit apache-module eutils
+
+DESCRIPTION="mod_lisp is an Apache module to easily write web applications in Common Lisp"
+HOMEPAGE="http://www.fractalconcept.com/asp/sdataQIceRsMvtN9fDM==/sdataQuvY9x3g$ecX"
+SRC_URI="mirror://gentoo/${P}.c"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="LISP"
+
+need_apache2
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ cp ${DISTDIR}/${P}.c ${PN}.c
+ epatch ${FILESDIR}/${PV}-content-length.patch || die # http://common-lisp.net/pipermail/mod-lisp-devel/2005-December/000082.html
+}