summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-09-18 12:52:19 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-09-18 12:52:19 +0000
commitb41a5f476ec901577e78580e90eb9e525312c516 (patch)
treed7949b4d73fc189d2f940d0ec97dd77b8519dcff /www-apache/mod_caucho
parentFix db4.7 patch, #283596 (diff)
downloadgentoo-2-b41a5f476ec901577e78580e90eb9e525312c516.tar.gz
gentoo-2-b41a5f476ec901577e78580e90eb9e525312c516.tar.bz2
gentoo-2-b41a5f476ec901577e78580e90eb9e525312c516.zip
cleanup ebuild and convert to EAPI2
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'www-apache/mod_caucho')
-rw-r--r--www-apache/mod_caucho/ChangeLog7
-rw-r--r--www-apache/mod_caucho/files/88_mod_caucho.conf34
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.0.25.ebuild37
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.1.8.ebuild39
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.2.1.ebuild39
5 files changed, 61 insertions, 95 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index c7c7bddd4f21..66f679b31a16 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.47 2009/08/02 14:13:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.48 2009/09/18 12:52:19 hollow Exp $
+
+ 18 Sep 2009; Benedikt Böhm <hollow@gentoo.org> files/88_mod_caucho.conf,
+ mod_caucho-3.0.25.ebuild, mod_caucho-3.1.8.ebuild,
+ mod_caucho-3.2.1.ebuild:
+ cleanup ebuild and convert to EAPI2
02 Aug 2009; Markus Meier <maekke@gentoo.org> mod_caucho-3.2.1.ebuild:
amd64 stable, bug #275672
diff --git a/www-apache/mod_caucho/files/88_mod_caucho.conf b/www-apache/mod_caucho/files/88_mod_caucho.conf
index 079791061ccc..20e0e7081136 100644
--- a/www-apache/mod_caucho/files/88_mod_caucho.conf
+++ b/www-apache/mod_caucho/files/88_mod_caucho.conf
@@ -1,25 +1,21 @@
-#
-# mod_caucho Resin Configuration
-#
-
<IfDefine CAUCHO>
+# Load module:
+LoadModule caucho_module modules/mod_caucho.so
- # Load module:
- LoadModule caucho_module modules/mod_caucho.so
-
- # Define first Resin server:
- ResinConfigServer localhost 6802
+# Define first Resin server:
+ResinConfigServer localhost 6802
- # If you want to use load balancing add more hosts:
- # ResinConfigServer host1.example.com 6802
- # ResinConfigServer host2.example.com 6802
+# If you want to use load balancing add more hosts:
+# ResinConfigServer host1.example.com 6802
+# ResinConfigServer host2.example.com 6802
- # This enables status page of server: http://localhost/caucho-status
- CauchoStatus yes
-
- # To use this module:
- #<Location /webapp/*>
- # SetHandler caucho-request
- #</Location>
+# This enables status page of server: http://localhost/caucho-status
+CauchoStatus yes
+# To use this module:
+#<Location /webapp/*>
+# SetHandler caucho-request
+#</Location>
</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild b/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild
index 73b6844e73a3..ae638bb598b9 100644
--- a/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild
@@ -1,52 +1,47 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild,v 1.5 2008/05/11 16:54:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.25.ebuild,v 1.6 2009/09/18 12:52:19 hollow Exp $
-inherit eutils apache-module autotools
+EAPI="2"
-KEYWORDS="amd64 ppc ppc64 x86"
+inherit eutils apache-module autotools
DESCRIPTION="mod_caucho connects Resin and Apache2."
HOMEPAGE="http://www.caucho.com/"
SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=""
+
S="${WORKDIR}/resin-${PV}"
# See apache-module.eclass for more information.
APACHE2_MOD_CONF="88_${PN}"
APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
need_apache2
-DEPEND="${DEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
epatch "${i}"
done
+
eautoreconf
chmod 755 ./configure
}
-src_compile() {
+src_configure() {
econf --with-apxs=${APXS} || die "econf failed"
-
- emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
}
-src_install() {
- cd "${S}/modules/c/src/apache2"
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
- || die "internal ebuild error: ${APACHE2_MOD_CONF} not found."
+src_compile() {
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
}
diff --git a/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild b/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild
index c35714ba7243..9237c051e7a4 100644
--- a/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild,v 1.1 2009/01/10 15:14:13 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.8.ebuild,v 1.2 2009/09/18 12:52:19 hollow Exp $
-inherit eutils apache-module autotools
+EAPI="2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+inherit eutils apache-module autotools
DESCRIPTION="mod_caucho connects Resin and Apache2."
HOMEPAGE="http://www.caucho.com/"
SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
-DEPEND=""
+DEPEND="${DEPEND}
+ app-arch/unzip"
RDEPEND=""
S="${WORKDIR}/resin-${PV}"
@@ -22,18 +25,11 @@ S="${WORKDIR}/resin-${PV}"
# See apache-module.eclass for more information.
APACHE2_MOD_CONF="88_${PN}"
APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
need_apache2
-DEPEND="${DEPEND}
- app-arch/unzip"
-
-src_unpack() {
-
- unpack ${A}
-
- cd "${S}"
-
+src_prepare() {
for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
epatch "${i}"
done
@@ -41,23 +37,12 @@ src_unpack() {
eautoreconf
chmod 755 ./configure
-
}
-src_compile() {
-
+src_configure() {
econf --with-apxs=${APXS} || die "econf failed"
- emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
-
}
-src_install() {
-
- cd "${S}/modules/c/src/apache2"
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
- || die "internal ebuild error: ${APACHE2_MOD_CONF}.conf not found."
-
+src_compile() {
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
}
diff --git a/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild b/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
index f85bb8a3a9e4..a35dcc9b032e 100644
--- a/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild,v 1.3 2009/08/02 14:13:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild,v 1.4 2009/09/18 12:52:19 hollow Exp $
-inherit eutils apache-module autotools
+EAPI="2"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
+inherit eutils apache-module autotools
DESCRIPTION="mod_caucho connects Resin and Apache2."
HOMEPAGE="http://www.caucho.com/"
SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE=""
-DEPEND=""
+DEPEND="${DEPEND}
+ app-arch/unzip"
RDEPEND=""
S="${WORKDIR}/resin-${PV}"
@@ -22,41 +25,23 @@ S="${WORKDIR}/resin-${PV}"
# See apache-module.eclass for more information.
APACHE2_MOD_CONF="88_${PN}"
APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
need_apache2
-DEPEND="${DEPEND}
- app-arch/unzip"
-
-src_unpack() {
-
- unpack ${A}
-
- cd "${S}"
-
+src_prepare() {
for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
epatch "${i}"
done
eautoreconf
chmod 755 ./configure
-
}
-src_compile() {
-
+src_configure() {
econf --with-apxs=${APXS} || die "econf failed"
- emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
-
}
-src_install() {
-
- cd "${S}/modules/c/src/apache2"
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
- || die "internal ebuild error: ${APACHE2_MOD_CONF}.conf not found."
-
+src_compile() {
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
}