summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-08-05 16:22:05 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-08-05 16:22:05 +0000
commit0f0be905913efcc43b7aca2ed4fbd1b3fb20be0a (patch)
tree1b45261406208fcddb91f12903438f3ab16b96a4 /www-apache/mod_caucho
parentRevision bump. Fixing build issues I encountered while compiling on uclibc. (diff)
downloadgentoo-2-0f0be905913efcc43b7aca2ed4fbd1b3fb20be0a.tar.gz
gentoo-2-0f0be905913efcc43b7aca2ed4fbd1b3fb20be0a.tar.bz2
gentoo-2-0f0be905913efcc43b7aca2ed4fbd1b3fb20be0a.zip
Version bump to match www-servers/resin version.
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'www-apache/mod_caucho')
-rw-r--r--www-apache/mod_caucho/ChangeLog8
-rw-r--r--www-apache/mod_caucho/files/digest-mod_caucho-3.0.203
-rw-r--r--www-apache/mod_caucho/files/mod_caucho-3.0.20-gentoo.patch17
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.0.20.ebuild57
4 files changed, 84 insertions, 1 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index a87a7968ae6a..89a6f64d33ee 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.2 2006/07/27 06:40:13 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.3 2006/08/05 16:22:05 nelchael Exp $
+
+*mod_caucho-3.0.20 (05 Aug 2006)
+
+ 05 Aug 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/mod_caucho-3.0.20-gentoo.patch, +mod_caucho-3.0.20.ebuild:
+ Version bump to match www-servers/resin version.
27 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
mod_caucho-3.0.19.ebuild:
diff --git a/www-apache/mod_caucho/files/digest-mod_caucho-3.0.20 b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.20
new file mode 100644
index 000000000000..6ba5b302e614
--- /dev/null
+++ b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.20
@@ -0,0 +1,3 @@
+MD5 8ae9651a4a8a928b696352288636e5f7 resin-3.0.20-src.tar.gz 5396774
+RMD160 0e82848e3e88048db10019563d0c731e71b52b66 resin-3.0.20-src.tar.gz 5396774
+SHA256 b78f94ae294289292eb954a11ae4cbe10ed7e8e8de068b14f916cb46e2cd735e resin-3.0.20-src.tar.gz 5396774
diff --git a/www-apache/mod_caucho/files/mod_caucho-3.0.20-gentoo.patch b/www-apache/mod_caucho/files/mod_caucho-3.0.20-gentoo.patch
new file mode 100644
index 000000000000..2fad0cc7c444
--- /dev/null
+++ b/www-apache/mod_caucho/files/mod_caucho-3.0.20-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Nru resin-3.0.20.vanilla/modules/c/src/apache2/Makefile.in resin-3.0.20/modules/c/src/apache2/Makefile.in
+--- resin-3.0.20.vanilla/modules/c/src/apache2/Makefile.in 2006-08-05 18:17:13.000000000 +0200
++++ resin-3.0.20/modules/c/src/apache2/Makefile.in 2006-08-05 18:18:16.000000000 +0200
+@@ -36,11 +36,8 @@
+ $(CC) -c $(INCLUDES) $(CFLAGS) $<
+
+ install : mod_caucho.la
+- $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
+- - rm -f $(apache_libexec)/mod_caucho.la
+- - rm -f $(apache_libexec)/mod_caucho.a
+- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
+- -resin_home $(resin_home)
++ mkdir -p $(DESTDIR)$(apache_libexec)
++ $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(DESTDIR)$(apache_libexec)
+
+ clean :
+ - rm -r *.o *.lo *.la *.so .libs
diff --git a/www-apache/mod_caucho/mod_caucho-3.0.20.ebuild b/www-apache/mod_caucho/mod_caucho-3.0.20.ebuild
new file mode 100644
index 000000000000..bc765075ef7b
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-3.0.20.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.20.ebuild,v 1.1 2006/08/05 16:22:05 nelchael Exp $
+
+inherit apache-module autotools
+
+DESCRIPTION="mod_caucho connects Resin and Apache2"
+HOMEPAGE="http://www.caucho.com"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT="0"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+
+need_apache2
+
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/resin-${PV}"
+
+src_unpack() {
+
+ unpack "${A}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ cd "${S}"
+ eautoreconf
+
+ chmod 755 ./configure
+
+}
+
+src_compile() {
+
+ econf --with-apxs=${APXS2} || die "econf failed"
+
+ emake -j1 -C "${S}/modules/c/src/common/" || die "emake failed"
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
+
+}
+
+src_install() {
+
+ cd "${S}/modules/c/src/apache2"
+ make DESTDIR="${D}" install || die "install failed"
+
+ insinto ${APACHE2_MODULES_CONFDIR}
+ doins ${FILESDIR}/${APACHE2_MOD_CONF}.conf || \
+ die "internal ebuild error: '${FILESDIR}/${APACHE2_MOD_CONF}.conf' not found."
+
+}