summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-31 16:03:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-31 16:03:56 +0000
commit298c7375b35d02c642650e30a9442dd4b0002bf3 (patch)
tree10243fadce576c9a42725cdcf6c84398f47a1e1c /www-apache/mod_auth_token
parentForgot to save. (diff)
downloadgentoo-2-298c7375b35d02c642650e30a9442dd4b0002bf3.tar.gz
gentoo-2-298c7375b35d02c642650e30a9442dd4b0002bf3.tar.bz2
gentoo-2-298c7375b35d02c642650e30a9442dd4b0002bf3.zip
Respect CFLAGS/LDFLAGS properly.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_auth_token')
-rw-r--r--www-apache/mod_auth_token/ChangeLog6
-rw-r--r--www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild16
2 files changed, 21 insertions, 1 deletions
diff --git a/www-apache/mod_auth_token/ChangeLog b/www-apache/mod_auth_token/ChangeLog
index 61a7721dd99e..a49ddc6c5036 100644
--- a/www-apache/mod_auth_token/ChangeLog
+++ b/www-apache/mod_auth_token/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_auth_token
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_token/ChangeLog,v 1.2 2011/08/31 15:55:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_token/ChangeLog,v 1.3 2011/08/31 16:03:56 flameeyes Exp $
+
+ 31 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ mod_auth_token-1.0.6_beta.ebuild:
+ Respect CFLAGS/LDFLAGS properly.
31 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org>
mod_auth_token-1.0.6_beta.ebuild:
diff --git a/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild b/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
index 30d9ce57b954..e50dc62639cd 100644
--- a/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
+++ b/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
@@ -29,3 +29,19 @@ S="${WORKDIR}/${PN}"
src_prepare() {
epatch "${FILESDIR}"/${P}-ap_pstrcat.patch
}
+
+src_compile() {
+ local flag=
+ APXS2_ARGS=
+
+ for flag in ${CFLAGS}; do
+ APXS2_ARGS+=" -Wc,${flag}"
+ done
+
+ for flag in ${LDFLAGS}; do
+ APXS2_ARGS+=" -Wl,${flag}"
+ done
+
+ APXS2_ARGS="${APXS2_ARGS} -c ${PN}.c"
+ apache-module_src_compile
+}