summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-07-01 19:40:48 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-07-01 19:40:48 +0000
commit59255750ae6233747edb5b4619648ffa702d9818 (patch)
treed2c41d5574e6ce3b6c02ebfdfbde956f92ba72dc /www-apache/anyterm
parentversion bump wrt #229449 (diff)
downloadgentoo-2-59255750ae6233747edb5b4619648ffa702d9818.tar.gz
gentoo-2-59255750ae6233747edb5b4619648ffa702d9818.tar.bz2
gentoo-2-59255750ae6233747edb5b4619648ffa702d9818.zip
version bump wrt #229977
(Portage version: 2.2_pre8/cvs/Linux 2.6.22-vs2.2.0.6-gentoo x86_64)
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/ChangeLog7
-rw-r--r--www-apache/anyterm/anyterm-1.1.24.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index dd65a20e72b3..8d0ddcf73af6 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/anyterm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.14 2008/06/01 09:29:03 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.15 2008/07/01 19:40:48 hollow Exp $
+
+*anyterm-1.1.24 (01 Jul 2008)
+
+ 01 Jul 2008; Benedikt Böhm <hollow@gentoo.org> +anyterm-1.1.24.ebuild:
+ version bump wrt #229977
01 Jun 2008; Benedikt Böhm <hollow@gentoo.org>
+files/anyterm-1.1.22-respect-flags.patch, anyterm-1.1.22.ebuild:
diff --git a/www-apache/anyterm/anyterm-1.1.24.ebuild b/www-apache/anyterm/anyterm-1.1.24.ebuild
new file mode 100644
index 000000000000..32746f68eab5
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.24.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.24.ebuild,v 1.1 2008/07/01 19:40:48 hollow Exp $
+
+inherit apache-module eutils toolchain-funcs webapp
+
+DESCRIPTION="A terminal anywhere."
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="opera pam ssl"
+
+DEPEND="dev-libs/boost
+ >=dev-libs/rote-0.2.8
+ >=sys-devel/gcc-3
+ virtual/ssh
+ pam? ( || ( www-apache/mod_authn_pam www-apache/mod_auth_pam ) )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="ANYTERM"
+use pam && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} AUTH_PAM"
+use ssl && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} SSL"
+APACHE2_MOD_FILE="${S}/apachemod/.libs/${PN}.so"
+DOCFILES="CHANGELOG README"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+need_apache2_2
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use ssl && ! built_with_use www-servers/apache ssl; then
+ die "Build www-servers/apache with USE=ssl."
+ fi
+
+ if ! built_with_use --missing true dev-libs/boost threads; then
+ die "Build dev-libs/boost with USE=threads."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.1.15-browser-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-1.1.22-respect-flags.patch
+ sed -i -e "s:apr-config:apr-1-config:g" apachemod/Makefile
+}
+
+src_compile() {
+ local my_LDFLAGS
+ for flag in ${LDFLAGS} ; do
+ my_LDFLAGS="${my_LDFLAGS} -Wl,${flag}"
+ done
+ unset flag
+ export LDFLAGS="${my_LDFLAGS# }"
+
+ cd apachemod
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed"
+ cd ..
+
+ # Modify browser files to reflect USE flags.
+ for flag in opera pam ssl ; do
+ if use ${flag} ; then
+ sed -i -e "s/^#USE=${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=-${flag}#/D" browser/{*,.htaccess}
+ else
+ sed -i -e "s/^#USE=-${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=${flag}#/D" browser/{*,.htaccess}
+ fi
+ done
+}
+
+src_install() {
+ apache-module_src_install
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r browser/{*,.htaccess}
+
+ webapp_postinst_txt en "${FILESDIR}"/${PN}-1.1.15-postinst-en.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ apache-module_pkg_postinst
+
+ use ssl || ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
+ use pam || ewarn "USE=-pam: You will have to add your own authentication mechanism."
+ use opera && ewarn "USE=opera: Be sure to disable some logging in your Apache configuration files!"
+
+ if ! use ssl || ! use pam || use opera ; then
+ ewarn "For more information see http://anyterm.org/security.html"
+ fi
+}