summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-05-08 08:04:37 +0000
committerYixun Lan <dlan@gentoo.org>2015-05-08 08:04:37 +0000
commitb23e40d83a1be47ae320670bed073aff9a752440 (patch)
tree8fe25019b529a81fb459f706fac3fea4f2a20e0e /sys-process
parentversion bump (diff)
downloadgentoo-2-b23e40d83a1be47ae320670bed073aff9a752440.tar.gz
gentoo-2-b23e40d83a1be47ae320670bed073aff9a752440.tar.bz2
gentoo-2-b23e40d83a1be47ae320670bed073aff9a752440.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/criu/ChangeLog7
-rw-r--r--sys-process/criu/criu-1.5.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-process/criu/ChangeLog b/sys-process/criu/ChangeLog
index 3d9897b672ea..a1384b522ca7 100644
--- a/sys-process/criu/ChangeLog
+++ b/sys-process/criu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/criu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.22 2015/04/14 10:06:22 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.23 2015/05/08 08:04:37 dlan Exp $
+
+*criu-1.5.2 (08 May 2015)
+
+ 08 May 2015; Yixun Lan <dlan@gentoo.org> +criu-1.5.2.ebuild:
+ version bump
14 Apr 2015; Yixun Lan <dlan@gentoo.org> -criu-1.5-r2.ebuild,
criu-1.5.1.ebuild, +files/criu-1.5.1-arm64-ptrace.patch:
diff --git a/sys-process/criu/criu-1.5.2.ebuild b/sys-process/criu/criu-1.5.2.ebuild
new file mode 100644
index 000000000000..3a314792df6d
--- /dev/null
+++ b/sys-process/criu/criu-1.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/criu-1.5.2.ebuild,v 1.1 2015/05/08 08:04:37 dlan Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs linux-info flag-o-matic
+
+DESCRIPTION="utility to checkpoint/restore a process tree"
+HOMEPAGE="http://criu.org/"
+SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="setproctitle"
+
+RDEPEND="dev-libs/protobuf-c
+ setproctitle? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto"
+
+CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
+ ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.5-automagic-libbsd.patch
+}
+
+src_compile() {
+ unset ARCH
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" V=1 SETPROCTITLE=$(usex setproctitle) WERROR=0 all docs
+}
+
+src_test() {
+ # root privileges are required to dump all necessary info
+ if [[ ${EUID} -eq 0 ]] ; then
+ emake -j1 CC="$(tc-getCC)" V=1 WERROR=0 test
+ fi
+}
+
+src_install() {
+ emake SYSCONFDIR="${EPREFIX}"/etc PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+ dodoc CREDITS README
+}