summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-03-06 21:53:17 +0000
committerThilo Bangert <bangert@gentoo.org>2010-03-06 21:53:17 +0000
commit5a2e5c1f785ee335baecd53355cee126816fc108 (patch)
tree49c51a1d1e886e849baa36596da1ac09e1322fb6 /sys-process
parentMove gvfs to PDEPEND to avoid a circular dependency: gnome-base/gnome -> naut... (diff)
downloadgentoo-2-5a2e5c1f785ee335baecd53355cee126816fc108.tar.gz
gentoo-2-5a2e5c1f785ee335baecd53355cee126816fc108.tar.bz2
gentoo-2-5a2e5c1f785ee335baecd53355cee126816fc108.zip
security version bump (bug #308055)
(Portage version: 2.2_rc65/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/ChangeLog9
-rw-r--r--sys-process/cronie/cronie-1.4.4.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index 90bfb6311b99..ee6900f68198 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/cronie
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.10 2009/12/03 11:37:19 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.11 2010/03/06 21:53:17 bangert Exp $
+
+*cronie-1.4.4 (06 Mar 2010)
+
+ 06 Mar 2010; Thilo Bangert <bangert@gentoo.org> +cronie-1.4.4.ebuild:
+ security version bump (bug #308055)
03 Dec 2009; Markus Meier <maekke@gentoo.org> cronie-1.4.3-r1.ebuild:
add ~amd64, bug #290780
diff --git a/sys-process/cronie/cronie-1.4.4.ebuild b/sys-process/cronie/cronie-1.4.4.ebuild
new file mode 100644
index 000000000000..3947966cc891
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.4.ebuild,v 1.1 2010/03/06 21:53:17 bangert Exp $
+
+EAPI="2"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir
+ fowners root:cron /usr/bin/crontab
+ fperms 2750 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}